source: MondoRescue/branches/2.05/mondo/mondo.spec@ 247

Last change on this file since 247 was 247, checked in by bcornec, 18 years ago
  • fix automake bug for post-nuke.example (creation of the Makefile.am)
  • fix sles9 build for mondo (remove of extra doc)
  • Property svn:keywords set to Id
File size: 19.0 KB
RevLine 
[35]1#
2# $Id: mondo.spec 247 2005-12-20 12:24:03Z bcornec $
3#
[53]4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
[1]9
[53]10%define name mondo
[237]11%define version VVV
[53]12%define mrel 1
[247]13%define docname %{name}-%{version}
14%define src %{name}-%{version}.tgz
[53]15
16%if %is_redhat
17Group: Applications/Archiving
18Autoreq: 0
19%endif
20
21%if %is_mandrake
22%define src %{name}-%{version}.tar.bz2
23Group: Archiving/Backup
24Autoreqprov: no
25%endif
26
[64]27%if %is_mandriva
28%define src %{name}-%{version}.tar.bz2
29Group: Archiving/Backup
30Autoreqprov: no
31%endif
32
[233]33%if %is_suse
34Group: Archiving/Backup
[247]35%define docname %{name}
[233]36%endif
[64]37
[1]38Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
39Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
40Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
41Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
[53]42
43Name: %{name}
44Version: %{version}
[64]45Release: %{mrel}
[1]46License: GPL
[53]47Url: http://mondorescue.berlios.de
48Source: %{src}
49BuildRoot: %{_tmppath}/%{name}-%{version}
[1]50BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
51%ifarch ia64
[102]52Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
[1]53%else
[241]54Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, buffer
[1]55%endif
56
[53]57#%package xmondo
58#Summary: A QT based graphical front end for %{name}
59#Group: Applications/Archiving
60#Requires: %{name} = %{version}-${release}, qt, kdelibs
61#
62#%package %{name}-devel
63#Summary: Header files for building against Mondo
64#%if %is_mandrake
65#Group: Development/Libraries
66#%endif
67#if %is_redhat
68#Group: Development/Other
69#%endif
70#Provides: libmondo-devel mondo-devel
71#Obsoletes: libmondo-devel
72#
73#%description -n %{name}-devel
74#Mondo libraries and includes
[1]75
76%description
[53]77Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
[1]78
79%description -l fr
80Objectif
81""""""""
[53]82Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
[1]83
84%description -l it
85Scopo
86"""""
87Mondo e' un programma che permette a qualsiasi utente Linux
88di creare un cd di rescue/restore (o piu' cd qualora l'installazione
89dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
90nastro, ed il NFS, anche.
91
92%description -l sp
93Objectivo
94"""""""""
95Mondo es un programa que permite cualquier usuario de Linux a crear una CD
96de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
97con cintas y NFS, tambien.
98
[53]99#%description xmondo
100#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
101#set up a backup by following onscreen prompts.
[1]102
103%prep
[53]104%setup -q -n %name-%{version}
[1]105
[53]106%build
[1]107%configure %{!?_without_xmondo:--with-x11}
108%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
109
110%install
[53]111%{__rm} -rf $RPM_BUILD_ROOT
112%makeinstall
[247]113%if %is_suse
114%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/doc/%name-%{version}
115%endif
[1]116
[53]117%post
118/sbin/ldconfig
[187]119%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
[1]120
[53]121%postun
122/sbin/ldconfig
[1]123
124%clean
125%{__rm} -rf $RPM_BUILD_ROOT
126
127%files
[53]128%defattr(644,root,root,755)
129%doc ChangeLog mondo/docs/en/1.6x-howto/*
130%doc INSTALL COPYING README TODO AUTHORS NEWS
[1]131
[53]132%attr(755,root,root) %{_sbindir}/*
[187]133#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
134%{_libdir}
135%{_mandir}
[53]136
[79]137#%{!?_without_xmondo:%files xmondo}
138#%{!?_without_xmondo:%{_sbindir}/xmondo}
139#%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
140#%{!?_without_xmondo:%{_libdir}/libXmondo.so}
141#%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
[1]142
143%changelog
[102]144* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
145- ia64 is now working
146- -p option related bug fixed
[179]147- use libdir instead of datadir
[102]148
[14]149* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
[13]150- Merge of patches mentionned on mondo ML + ia64 updates
[53]151- Add -p option
[13]152
[1]153* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
154- made mondo more clever about finding its home. Avoids mondo considering
155 directories like '/usr/share/doc/momdo' as its home.
156
157* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
158- test sanity of user-specified tempdir
159- better SLES8 support
160
161* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
162- instead of using 'dd' to erase partition table, delete existing
163 partitions w/ the same call to fdisk that is used to create the
164 new partitions; this should avoids locking up the partition table
165- set bootable partition in the above same call to fdisk, for
166 the same reason (avoids locking up the partition table)
167- better software RAID support
168- mount ext3 partitions as ext2 when restoring - better for Debian
169- better star, ACL support
170- added ACL, xattr support for afio users
171
172* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
173- fixed cvs for SuSE systems
174- fixed NTFS backup/restore bug relating to partimagehack
175 log file overflow and NTFS v non-NTFS differentiation
176- more reliable extraction of config info from CDs, floppies
177- better support of ISO dirs at restore-time (Conor Daly)
178- fixed spec file for SuSE users
179- added ldconfig to install section
180
181* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
182- first 2.0 release
183- updated grub-install.patched to support SuSE and Red Hat
184- call 'mt' to set block size to 32K before opening in/out tape
185- updated mondo-prep.c to create each disk's partitions all at once
186 (one call per drive) instead of one call to fdisk per partition
187- when extracting cfg file and mountlist from all.tar.gz (tape copy),
188 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
189- added star and rudimentary SELinux support
190- fixed lots of bugs
191- all logging now goes to /var/log/mondo-archive.log, with symlink
192 to /tmp/mondo-restore.log for restore-time log-tracking
193- added grub-install.patched
194- removed embleer & other binaries
195- added '-b' to specify block size
196- added '-R' for star support
197
198* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
199- ia64 fixes
200
201* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
202- fixed symbolic links for libraries
203- added support for boot/root multi floppies
204
205- added kdelibs as xmondo dependency
206- added xmondo pixmap installation
207- better find_cdrom_device(), to cope w/ multiple CD writers
208- fixed -m and -Vc flags
209- fixed NTFS support!
210- bootable CD uses native, not El Torito, support now
211- removed mondo-makefilelist
212- added 2.6 kernel support
213- if 2.6 kernel, insist that the user specify CD device
214- drop Embleer; insist on ms-sys and parted if Windows partition
215
216* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
217- added -devel package
218
219* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
220- made xmondo a second package
221- added ability to specify --without xmondo at build time
222
223* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
224- Clean up, added spanish translation
225- Set prefix to be /usr
226- added/fixed Requires
227- remove CVS directories prior to building
228
229* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
230- nothing yet
231
232* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
233- fixed chmod/chown bug (Jens Richter)
234- ask user to confirm NFS mountpoint in Interactive Mode
235- rewritten format_everything() to make sure LVMs, RAIDs and
236 regular partitions are prepped in the correct order
237- better magicdev support
238- rewritten external binary caller subroutine
239- DVD support added
240- better backup-time control gui; offer to exclude nfs if appl.
241- fixed multi-tape support
242- re-implemented -D and -J
243- fixed bug in extract_config_file_from_ramdisk() which
244 affected tape+floppy users
245- updated is_incoming_block_valid() to make it
246 return end-of-tape if >300 flotsam blocks
247- unmount CD-ROM before burning (necessary for RH8/9)
248- fixed some stray assert()'s
249- fixed bug in grub-MR (Christian)
250- make user remove floppy/CD before restoring interactively from tape
251- fixed bug in am_I_in_disaster_recovery_mode()
252- added code to nuke_mode() to make sure NFS
253 (backup) share is mounted in Nuke Mode
254- improved tape device detection code
255- better GRUB support
256- better logging of changed bigfiles at compare-time
257- better NTFS support, thanks to partimagehack-static
258- better logging
259- rewrote tape-handling code, breaking compatibility w/ previous versions
260- fixed ISO/CD biggiefile verification bug in mondoarchive
261- fixed bug which stopped boot/compare-time changelist from popping up
262- replaced mondo-makefilelist with C code - faster, cleaner
263- tweaked GUI - better feedback
264
265* Wed May 28 2003 Anonymous <root@rohan> 1.74
266- misc fixes (Michael Hanscho's friend)
267- added rudimentary support for SME
268- added better label support
269- fixed biggietime atime/ctime restoration bug 73
270- fixed 'default boot loader' detection bug (Joshua Oreman)
271- use single-threaded make_afioballs_and_images() if FreeBSD
272- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
273- superior get_phys_size_of_drive() (Joshua Oreman)
274- fixed RAID-related bug in where_is_root_mounted()
275- ISO tweaks
276- fixed silly bug in load_filelist() which stopped
277 funny German filenames from being handled properly
278- fixed various calls to popup_and_get_string()
279- fixed spec file
280- reject -E /
281- added partimagehack to the mix
282
283* Tue May 20 2003 Anonymous <root@rohan> 1.73
284- mark devices as bootable _after_ unmounting them
285- resolve boot device (-f) if softlink
286- post_param_configuration() --- store iso-dev and isodir
287- added post-nuke-sample.tgz to package
288- Nuke Mode now checks mountlist against hardware; offer user
289 opportunity to edit mountlist if insane; if user declines, abort
290- added lots of assert()'s and other checks
291- ran code thru Valgrind to catch & fix some memory leaks
292- made mondo-restore.c smaller by moving some subroutines to
293 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
294- added '-Q' to let user test mondoarchive's ability to find
295 their boot loader and type
296- improved which_boot_loader()
297- when burning or comparing to a CD, defeat autorun if it is
298 running, to avoid confusing mondoarchive and the user
299- if original backup media no longer available at boot-time
300 then offer user chance to choose another media source
301- when booting, type 'nuke noresize' to nuke w/o resizing
302 mountlist to fill your drives
303- add 'textonly' when booting, to avoid using Newt gui
304- run nice(20) to prioritize mondoarchive at start
305- don't pause and wait for next blank CD at backup-time
306 unless necessary (e.g. previous CD has not been removed)
307- get_phys_size_of_drive() --- better support of older drives
308- don't eject if "donteject" is in kernel's command line
309- cleaned up segfault-handling
310- added Conor's strip_path() to improve file list display
311- added Herman Kuster's multi-level bkp patch
312- better boot-time screen/message
313- added Joshua Oreman's FreeBSD patches x3
314- fixed interactive/textonly support
315- fixed support for subdir-within-NFS-mount
316- fixed "Can't backup if ramdisk not mounted" bug
317- try to work around eccentricities of multi-CD drive PCs
318- misc clean-ups (Steve Hindle)
319
320* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
321- LVM/RAID bugs fixed (Brian Borgeson)
322- major clean-up of code (Stan Benoit)
323- make-me-bootable fix (Juraj Ziegler)
324- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
325- removed duplicate entry from makefile
326- if root is /dev/root then assume not a ramdisk
327- reject relative paths if -d flag (Alessandro Polverini)
328- fixed potentially infinite loop in log_to_screen (Tom Mortell)
329- add '/' to custom filelist as workaround for obscure bug
330- ask user speed of CDRW if writing to CD
331- find_cdrom_device() --- if nonexistent/not found then
332 make sure to return '' as dev str and 1 as res
333- tweaked restore scripts tgz
334- cleaned up find_cdrom_device()
335- if user creates /usr/share/mondo/payload.tgz then untar
336 payload to CD at backup-time
337- fixed insist_on_this_cd_number()
338- fixed am_i_in_disaster_recovery_mode()
339- misc clean-up (Tom Mortell)
340- made code more legible
341- fixed post-nuke support
342- added -e support
343- fixed nfs support
344- fixed iso support
345- at restore-time, only sort mountlist internally,
346 in mount_all_devices() and unmount_all_devices()
347- fixed cosmetic bug in label-partitions-as-necessary
348- updated documentation
349- fixed fstab-hacking scripts
350
351* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
352- log newt, slang, ncurses info
353- updated man page
354- handle %% chars in issue.net properly (Heiko Schlittermann)
355- fixed serious NFS restore bug
356- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
357- changed various strcpy() calls to strncpy() calls
358- added mondo-makefilelist to makefile (Mikael Hultgren)
359- mount_cdrom() better at handling multiple CD drives
360- exclude /media/cdrom,cdrecorder,floppy
361- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
362- better logging by eval_call_to_make_ISO()
363- accept -J <fname> to let user provide their own fs catalog
364 instead of -I <paths> to backup
365- if dir excluded with -E or included with -I and dir is actually
366 a softlink then exclude/include the dir pointed to, as well
367- better location for manpage
368- adjusted block size of tarball at start of tape, to help
369 users w/ broken tape driver firmware
370- sort -u fstab after modifying it
371- if backup type is nfs then don't estimate noof media
372- fixed Makefile (Mikael Hultgren)
373- updated manpage
374
375* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
376- new devel branch opened
377
378* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
379- fixed bug in multithreading
380- use new grub-MR instead of grub-install
381- wipe only the partition table (not the MBR) when partitioning drives
382- ignore lilo.conf.anaconda when looking for lilo.conf file
383- accepts '-l RAW' to backup/restore original boot sector instead
384 of running grub or lilo to init it after restoring
385- fixed&updated stabgrub-me script; software RAID + GRUB work now
386- mount/unmount /boot partition for Gentoo 1.2 users
387- re-enabled extra tape checksums
388- disabled spurious warnings
389- unmount/remount supermounts at start/end of live restore, if nec.
390- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
391 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
392- added Makefile
393- added -l RAW, to backup and restore original MBR
394- cleaned up iso_mode() and nfs restoring
395- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
396- made mondorestore CD bootable for ArkLinux users
397- if user runs as 'su' not 'su -' then work around
398
399* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
400- pop-up list of changed files, at end of verification phase
401- better handling of changed.files list at restore-time
402- lots of CD-related fixes
403- added '-N' flag --- to let user exclude all NFS-related mounts&devices
404- better handling of 'kill'
405- restructuring of code to ease integration of mondo w/XMondo
406- fixed obscure bug in find_and_mount_actual_cd()
407- if / or /root has <50MB free then abort & complain
408- fixed install.sh
409- fixed .spec file
410- updated documentation
411- commented code
412- updated man page
413- added -v / --version flag
414- replace convoluted grep with wc (KP)
415- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
416- fixed BurnProof-related bug
417- better at figuring out which is the best partition for temp/scratchdir
418- added do-not-compress-these (text file) to RPM
419- do not compress files of types listed in do-not-compress-these
420- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
421- added Cosgrove's do-not-compress-these list
422- included various patches from KP
423- chmod tmpdir, scratchdir to 700 before using
424- restore from specified backup device, even if its own cfg file disagrees
425- fixed multi-tape bug
426- fixed "Can't find first ISO when verifying nonbootable ISO" bug
427- multithreaded make_afioballs_and_images()
428- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
429 command-line parameters or not
430- fixed bug in strip_spaces() which stopped it from handling
431 small strings correctly - affected mountlist editor
432- create a repaired copy of grub-install which is RAID-friendly;
433 use it when initializing boot sector with run_grub()
434- fixed bug in mondo-makefilelist
435
436* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
437- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
438- during selective restore, skip filesets which don't contain relevant archives
439- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
440- remove /var/run/*.pid after restoring
441- move spurious lockfiles from /home/* to /home/*/.disabled
442- ask user to confirm the tape/CD device name
443- lots of multitape-related fixes
444- added code to autodetect the hardware of the user, if possible
445- if isodir does not exist then abort
446- more sanity-checking for -d flag
447- doubled 'biggiefile' threshold... to 32MB
448- exclude /root/images/mindi
449- fixed multi-imagedev bug (Emmanuel Druon)
450- unmount/remount /mnt/floppy before/after backing up, if Mandrake
451- restructured the source files
452- fixed serious bug in line 1546 - should have been !=, not ==; stopped
453 mondorestore from correctly restoring big files
454- added '#include <signal.h>' to my-stuff.h
455- exclude "incheckentry xwait()" from changed.files
456- fixed minor bug in find_cdrom_device()
457- fixed bug in friendly_sizestr...
458- insist on tape #1 when start verifying
459- added internal buffering, replacing the external 'buffer' exe
460- if differential backup then don't permit formatting or fdisking,
461 whether Interactive or Nuke mode
462- if mondorestore is run on live filesystem (or from ramdisk) without
463 parameters then mondorestore will ask which backup media (tape, CD, etc.)
464 was used; it will read the config file from the media and proceed from there
465- if tape streamer is softlink then resolve it first
466- incorporate post-nuke tarball
467- if user doesn't specify tape size, proceed anyway; behave intelligently
468 in the event of end-of-tape
469- prefix bkpinfo->restore_path to biggiefile fname before generating
470 checksum & comparing to archived biggiefile
471- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
472 then create a softlink from the former to the latter, to work
473 around RH7.3's b0rken LILO support
474- LFS support (mharris, michele, hugo)
475- fixed verify bug --- CD#1 was being verified again & again & ...
476- differential mode fixed; supported again
477- ask user for boot loader + device if not detectible
478- list up to 512 files in file selection window at once (was 128)
479- better handling of bigfiles' checksums, perms and owns
480- delete final filelist if <=2 bytes long
481- if kernel not found and mondo in graphics mode then popup and ask
482 for kernel path+filename
483
484* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
485- 1.5x branch forked off from 1.4x branch
486
487
488
489
Note: See TracBrowser for help on using the repository browser.