source: MondoRescue/branches/2.05/mondo/mondo.spec@ 233

Last change on this file since 233 was 233, checked in by bcornec, 18 years ago

sles9 rpm build support

  • Property svn:keywords set to Id
File size: 18.9 KB
RevLine 
[35]1#
2# $Id: mondo.spec 233 2005-12-17 10:02:11Z bcornec $
3#
[53]4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
[1]9
[53]10%define name mondo
[102]11%define version 2.05
[53]12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
[64]26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
[233]32%if %is_suse
33%define src %{name}-%{version}.tgz
34Group: Archiving/Backup
35%endif
[64]36
[1]37Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
38Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
39Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
40Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
[53]41
42Name: %{name}
43Version: %{version}
[64]44Release: %{mrel}
[1]45License: GPL
[53]46Url: http://mondorescue.berlios.de
47Source: %{src}
48BuildRoot: %{_tmppath}/%{name}-%{version}
[1]49BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
50%ifarch ia64
[102]51Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
[1]52%else
[102]53Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, cdrecord, buffer
[1]54%endif
55
[53]56#%package xmondo
57#Summary: A QT based graphical front end for %{name}
58#Group: Applications/Archiving
59#Requires: %{name} = %{version}-${release}, qt, kdelibs
60#
61#%package %{name}-devel
62#Summary: Header files for building against Mondo
63#%if %is_mandrake
64#Group: Development/Libraries
65#%endif
66#if %is_redhat
67#Group: Development/Other
68#%endif
69#Provides: libmondo-devel mondo-devel
70#Obsoletes: libmondo-devel
71#
72#%description -n %{name}-devel
73#Mondo libraries and includes
[1]74
75%description
[53]76Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
[1]77
78%description -l fr
79Objectif
80""""""""
[53]81Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
[1]82
83%description -l it
84Scopo
85"""""
86Mondo e' un programma che permette a qualsiasi utente Linux
87di creare un cd di rescue/restore (o piu' cd qualora l'installazione
88dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
89nastro, ed il NFS, anche.
90
91%description -l sp
92Objectivo
93"""""""""
94Mondo es un programa que permite cualquier usuario de Linux a crear una CD
95de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
96con cintas y NFS, tambien.
97
[53]98#%description xmondo
99#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
100#set up a backup by following onscreen prompts.
[1]101
102%prep
[53]103%setup -q -n %name-%{version}
[1]104
[53]105%build
[1]106%configure %{!?_without_xmondo:--with-x11}
107%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
108
109%install
[53]110%{__rm} -rf $RPM_BUILD_ROOT
111%makeinstall
[1]112
[53]113%post
114/sbin/ldconfig
[187]115%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
[1]116
[53]117%postun
118/sbin/ldconfig
[1]119
120%clean
121%{__rm} -rf $RPM_BUILD_ROOT
122
123%files
[53]124%defattr(644,root,root,755)
125%doc ChangeLog mondo/docs/en/1.6x-howto/*
126%doc INSTALL COPYING README TODO AUTHORS NEWS
[1]127
[53]128%attr(755,root,root) %{_sbindir}/*
[187]129#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
130%{_libdir}
131%{_mandir}
[53]132
[79]133#%{!?_without_xmondo:%files xmondo}
134#%{!?_without_xmondo:%{_sbindir}/xmondo}
135#%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
136#%{!?_without_xmondo:%{_libdir}/libXmondo.so}
137#%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
[1]138
139%changelog
[102]140* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
141- ia64 is now working
142- -p option related bug fixed
[179]143- use libdir instead of datadir
[102]144
[14]145* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
[13]146- Merge of patches mentionned on mondo ML + ia64 updates
[53]147- Add -p option
[13]148
[1]149* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
150- made mondo more clever about finding its home. Avoids mondo considering
151 directories like '/usr/share/doc/momdo' as its home.
152
153* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
154- test sanity of user-specified tempdir
155- better SLES8 support
156
157* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
158- instead of using 'dd' to erase partition table, delete existing
159 partitions w/ the same call to fdisk that is used to create the
160 new partitions; this should avoids locking up the partition table
161- set bootable partition in the above same call to fdisk, for
162 the same reason (avoids locking up the partition table)
163- better software RAID support
164- mount ext3 partitions as ext2 when restoring - better for Debian
165- better star, ACL support
166- added ACL, xattr support for afio users
167
168* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
169- fixed cvs for SuSE systems
170- fixed NTFS backup/restore bug relating to partimagehack
171 log file overflow and NTFS v non-NTFS differentiation
172- more reliable extraction of config info from CDs, floppies
173- better support of ISO dirs at restore-time (Conor Daly)
174- fixed spec file for SuSE users
175- added ldconfig to install section
176
177* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
178- first 2.0 release
179- updated grub-install.patched to support SuSE and Red Hat
180- call 'mt' to set block size to 32K before opening in/out tape
181- updated mondo-prep.c to create each disk's partitions all at once
182 (one call per drive) instead of one call to fdisk per partition
183- when extracting cfg file and mountlist from all.tar.gz (tape copy),
184 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
185- added star and rudimentary SELinux support
186- fixed lots of bugs
187- all logging now goes to /var/log/mondo-archive.log, with symlink
188 to /tmp/mondo-restore.log for restore-time log-tracking
189- added grub-install.patched
190- removed embleer & other binaries
191- added '-b' to specify block size
192- added '-R' for star support
193
194* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
195- ia64 fixes
196
197* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
198- fixed symbolic links for libraries
199- added support for boot/root multi floppies
200
201- added kdelibs as xmondo dependency
202- added xmondo pixmap installation
203- better find_cdrom_device(), to cope w/ multiple CD writers
204- fixed -m and -Vc flags
205- fixed NTFS support!
206- bootable CD uses native, not El Torito, support now
207- removed mondo-makefilelist
208- added 2.6 kernel support
209- if 2.6 kernel, insist that the user specify CD device
210- drop Embleer; insist on ms-sys and parted if Windows partition
211
212* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
213- added -devel package
214
215* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
216- made xmondo a second package
217- added ability to specify --without xmondo at build time
218
219* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
220- Clean up, added spanish translation
221- Set prefix to be /usr
222- added/fixed Requires
223- remove CVS directories prior to building
224
225* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
226- nothing yet
227
228* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
229- fixed chmod/chown bug (Jens Richter)
230- ask user to confirm NFS mountpoint in Interactive Mode
231- rewritten format_everything() to make sure LVMs, RAIDs and
232 regular partitions are prepped in the correct order
233- better magicdev support
234- rewritten external binary caller subroutine
235- DVD support added
236- better backup-time control gui; offer to exclude nfs if appl.
237- fixed multi-tape support
238- re-implemented -D and -J
239- fixed bug in extract_config_file_from_ramdisk() which
240 affected tape+floppy users
241- updated is_incoming_block_valid() to make it
242 return end-of-tape if >300 flotsam blocks
243- unmount CD-ROM before burning (necessary for RH8/9)
244- fixed some stray assert()'s
245- fixed bug in grub-MR (Christian)
246- make user remove floppy/CD before restoring interactively from tape
247- fixed bug in am_I_in_disaster_recovery_mode()
248- added code to nuke_mode() to make sure NFS
249 (backup) share is mounted in Nuke Mode
250- improved tape device detection code
251- better GRUB support
252- better logging of changed bigfiles at compare-time
253- better NTFS support, thanks to partimagehack-static
254- better logging
255- rewrote tape-handling code, breaking compatibility w/ previous versions
256- fixed ISO/CD biggiefile verification bug in mondoarchive
257- fixed bug which stopped boot/compare-time changelist from popping up
258- replaced mondo-makefilelist with C code - faster, cleaner
259- tweaked GUI - better feedback
260
261* Wed May 28 2003 Anonymous <root@rohan> 1.74
262- misc fixes (Michael Hanscho's friend)
263- added rudimentary support for SME
264- added better label support
265- fixed biggietime atime/ctime restoration bug 73
266- fixed 'default boot loader' detection bug (Joshua Oreman)
267- use single-threaded make_afioballs_and_images() if FreeBSD
268- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
269- superior get_phys_size_of_drive() (Joshua Oreman)
270- fixed RAID-related bug in where_is_root_mounted()
271- ISO tweaks
272- fixed silly bug in load_filelist() which stopped
273 funny German filenames from being handled properly
274- fixed various calls to popup_and_get_string()
275- fixed spec file
276- reject -E /
277- added partimagehack to the mix
278
279* Tue May 20 2003 Anonymous <root@rohan> 1.73
280- mark devices as bootable _after_ unmounting them
281- resolve boot device (-f) if softlink
282- post_param_configuration() --- store iso-dev and isodir
283- added post-nuke-sample.tgz to package
284- Nuke Mode now checks mountlist against hardware; offer user
285 opportunity to edit mountlist if insane; if user declines, abort
286- added lots of assert()'s and other checks
287- ran code thru Valgrind to catch & fix some memory leaks
288- made mondo-restore.c smaller by moving some subroutines to
289 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
290- added '-Q' to let user test mondoarchive's ability to find
291 their boot loader and type
292- improved which_boot_loader()
293- when burning or comparing to a CD, defeat autorun if it is
294 running, to avoid confusing mondoarchive and the user
295- if original backup media no longer available at boot-time
296 then offer user chance to choose another media source
297- when booting, type 'nuke noresize' to nuke w/o resizing
298 mountlist to fill your drives
299- add 'textonly' when booting, to avoid using Newt gui
300- run nice(20) to prioritize mondoarchive at start
301- don't pause and wait for next blank CD at backup-time
302 unless necessary (e.g. previous CD has not been removed)
303- get_phys_size_of_drive() --- better support of older drives
304- don't eject if "donteject" is in kernel's command line
305- cleaned up segfault-handling
306- added Conor's strip_path() to improve file list display
307- added Herman Kuster's multi-level bkp patch
308- better boot-time screen/message
309- added Joshua Oreman's FreeBSD patches x3
310- fixed interactive/textonly support
311- fixed support for subdir-within-NFS-mount
312- fixed "Can't backup if ramdisk not mounted" bug
313- try to work around eccentricities of multi-CD drive PCs
314- misc clean-ups (Steve Hindle)
315
316* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
317- LVM/RAID bugs fixed (Brian Borgeson)
318- major clean-up of code (Stan Benoit)
319- make-me-bootable fix (Juraj Ziegler)
320- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
321- removed duplicate entry from makefile
322- if root is /dev/root then assume not a ramdisk
323- reject relative paths if -d flag (Alessandro Polverini)
324- fixed potentially infinite loop in log_to_screen (Tom Mortell)
325- add '/' to custom filelist as workaround for obscure bug
326- ask user speed of CDRW if writing to CD
327- find_cdrom_device() --- if nonexistent/not found then
328 make sure to return '' as dev str and 1 as res
329- tweaked restore scripts tgz
330- cleaned up find_cdrom_device()
331- if user creates /usr/share/mondo/payload.tgz then untar
332 payload to CD at backup-time
333- fixed insist_on_this_cd_number()
334- fixed am_i_in_disaster_recovery_mode()
335- misc clean-up (Tom Mortell)
336- made code more legible
337- fixed post-nuke support
338- added -e support
339- fixed nfs support
340- fixed iso support
341- at restore-time, only sort mountlist internally,
342 in mount_all_devices() and unmount_all_devices()
343- fixed cosmetic bug in label-partitions-as-necessary
344- updated documentation
345- fixed fstab-hacking scripts
346
347* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
348- log newt, slang, ncurses info
349- updated man page
350- handle %% chars in issue.net properly (Heiko Schlittermann)
351- fixed serious NFS restore bug
352- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
353- changed various strcpy() calls to strncpy() calls
354- added mondo-makefilelist to makefile (Mikael Hultgren)
355- mount_cdrom() better at handling multiple CD drives
356- exclude /media/cdrom,cdrecorder,floppy
357- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
358- better logging by eval_call_to_make_ISO()
359- accept -J <fname> to let user provide their own fs catalog
360 instead of -I <paths> to backup
361- if dir excluded with -E or included with -I and dir is actually
362 a softlink then exclude/include the dir pointed to, as well
363- better location for manpage
364- adjusted block size of tarball at start of tape, to help
365 users w/ broken tape driver firmware
366- sort -u fstab after modifying it
367- if backup type is nfs then don't estimate noof media
368- fixed Makefile (Mikael Hultgren)
369- updated manpage
370
371* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
372- new devel branch opened
373
374* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
375- fixed bug in multithreading
376- use new grub-MR instead of grub-install
377- wipe only the partition table (not the MBR) when partitioning drives
378- ignore lilo.conf.anaconda when looking for lilo.conf file
379- accepts '-l RAW' to backup/restore original boot sector instead
380 of running grub or lilo to init it after restoring
381- fixed&updated stabgrub-me script; software RAID + GRUB work now
382- mount/unmount /boot partition for Gentoo 1.2 users
383- re-enabled extra tape checksums
384- disabled spurious warnings
385- unmount/remount supermounts at start/end of live restore, if nec.
386- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
387 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
388- added Makefile
389- added -l RAW, to backup and restore original MBR
390- cleaned up iso_mode() and nfs restoring
391- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
392- made mondorestore CD bootable for ArkLinux users
393- if user runs as 'su' not 'su -' then work around
394
395* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
396- pop-up list of changed files, at end of verification phase
397- better handling of changed.files list at restore-time
398- lots of CD-related fixes
399- added '-N' flag --- to let user exclude all NFS-related mounts&devices
400- better handling of 'kill'
401- restructuring of code to ease integration of mondo w/XMondo
402- fixed obscure bug in find_and_mount_actual_cd()
403- if / or /root has <50MB free then abort & complain
404- fixed install.sh
405- fixed .spec file
406- updated documentation
407- commented code
408- updated man page
409- added -v / --version flag
410- replace convoluted grep with wc (KP)
411- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
412- fixed BurnProof-related bug
413- better at figuring out which is the best partition for temp/scratchdir
414- added do-not-compress-these (text file) to RPM
415- do not compress files of types listed in do-not-compress-these
416- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
417- added Cosgrove's do-not-compress-these list
418- included various patches from KP
419- chmod tmpdir, scratchdir to 700 before using
420- restore from specified backup device, even if its own cfg file disagrees
421- fixed multi-tape bug
422- fixed "Can't find first ISO when verifying nonbootable ISO" bug
423- multithreaded make_afioballs_and_images()
424- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
425 command-line parameters or not
426- fixed bug in strip_spaces() which stopped it from handling
427 small strings correctly - affected mountlist editor
428- create a repaired copy of grub-install which is RAID-friendly;
429 use it when initializing boot sector with run_grub()
430- fixed bug in mondo-makefilelist
431
432* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
433- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
434- during selective restore, skip filesets which don't contain relevant archives
435- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
436- remove /var/run/*.pid after restoring
437- move spurious lockfiles from /home/* to /home/*/.disabled
438- ask user to confirm the tape/CD device name
439- lots of multitape-related fixes
440- added code to autodetect the hardware of the user, if possible
441- if isodir does not exist then abort
442- more sanity-checking for -d flag
443- doubled 'biggiefile' threshold... to 32MB
444- exclude /root/images/mindi
445- fixed multi-imagedev bug (Emmanuel Druon)
446- unmount/remount /mnt/floppy before/after backing up, if Mandrake
447- restructured the source files
448- fixed serious bug in line 1546 - should have been !=, not ==; stopped
449 mondorestore from correctly restoring big files
450- added '#include <signal.h>' to my-stuff.h
451- exclude "incheckentry xwait()" from changed.files
452- fixed minor bug in find_cdrom_device()
453- fixed bug in friendly_sizestr...
454- insist on tape #1 when start verifying
455- added internal buffering, replacing the external 'buffer' exe
456- if differential backup then don't permit formatting or fdisking,
457 whether Interactive or Nuke mode
458- if mondorestore is run on live filesystem (or from ramdisk) without
459 parameters then mondorestore will ask which backup media (tape, CD, etc.)
460 was used; it will read the config file from the media and proceed from there
461- if tape streamer is softlink then resolve it first
462- incorporate post-nuke tarball
463- if user doesn't specify tape size, proceed anyway; behave intelligently
464 in the event of end-of-tape
465- prefix bkpinfo->restore_path to biggiefile fname before generating
466 checksum & comparing to archived biggiefile
467- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
468 then create a softlink from the former to the latter, to work
469 around RH7.3's b0rken LILO support
470- LFS support (mharris, michele, hugo)
471- fixed verify bug --- CD#1 was being verified again & again & ...
472- differential mode fixed; supported again
473- ask user for boot loader + device if not detectible
474- list up to 512 files in file selection window at once (was 128)
475- better handling of bigfiles' checksums, perms and owns
476- delete final filelist if <=2 bytes long
477- if kernel not found and mondo in graphics mode then popup and ask
478 for kernel path+filename
479
480* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
481- 1.5x branch forked off from 1.4x branch
482
483
484
485
Note: See TracBrowser for help on using the repository browser.