source: MondoRescue/branches/2.05/mindi/mindi.spec@ 102

Last change on this file since 102 was 102, checked in by bcornec, 18 years ago

Version adaptations for 2.05/1.05 of mondo/mindi

  • Property svn:keywords set to Id
File size: 12.9 KB
Line 
1#
2# $Id: mindi.spec 102 2005-11-05 00:42:14Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mindi
11%define version 1.05
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
33Name: %name
34Version: %version
35Release: %mrel
36License: GPL
37Group: System/Kernel and hardware
38Url: http://mondorescue.berlios.de
39Source: %{src}
40BuildRoot: %{_tmppath}/%{name}-%{version}
41Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools, afio, which
42# Not on all systems
43#Conflicts: bonnie++
44
45%description
46Mindi takes your kernel, modules, tools and libraries, and puts them on N
47bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
48and do system maintenance - e.g. format partitions, backup/restore data,
49verify packages, etc.
50
51%prep
52%{__rm} -rf $RPM_BUILD_ROOT
53%setup -n %name-%{version}
54
55%build
56%ifarch ia64
57%{__make} -f Makefile.parted2fdisk clean
58%{__make} -f Makefile.parted2fdisk
59%endif
60
61%install
62export DONT_RELINK=1
63
64%{__rm} -rf $RPM_BUILD_ROOT
65MINDIDIR=$RPM_BUILD_ROOT%{_datadir}/mindi
66
67%{__mkdir_p} $MINDIDIR $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_sysconfdir}/mindi $RPM_BUILD_ROOT%{_sbindir}
68%{__cp} deplist.txt $RPM_BUILD_ROOT%{_sysconfdir}/mindi/
69%{__cp} -af * $MINDIDIR
70
71%ifarch ia64
72 %{__make} -f Makefile.parted2fdisk DEST=${MINDIDIR}/ install
73 %{__mv} $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/bin/busybox
74 %{__mv} $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk
75%else
76 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox
77 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386.net $MINDIDIR/rootfs/bin/busybox.net
78 %{__ln_s} fdisk $MINDIDIR/rootfs/sbin/parted2fdisk
79%endif
80%{__rm} -f $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox-i386.net
81
82#
83# These are installed twice if not removed here
84#
85( cd $MINDIDIR
86%{__rm} -f CHANGES INSTALL COPYING README TODO README.ia64 README.pxe
87)
88
89# Symlinks
90
91cd $RPM_BUILD_ROOT%{_sbindir}
92%{__ln_s} -f %{_datadir}/mindi/mindi .
93%{__ln_s} -f %{_datadir}/mindi/analyze-my-lvm .
94%ifarch ia64
95%{__ln_s} -f %{_datadir}/mindi/parted2fdisk.pl .
96%endif
97
98%clean
99%{__rm} -rf $RPM_BUILD_ROOT
100
101%post
102%ifarch ia64
103 %{__mkdir_p} /usr/local/bin
104 if [ "`file /sbin/fdisk |grep 'LF 64-bit LSB executable'`" ] ; then
105 %{__cp} /sbin/fdisk /sbin/fdisk.mondosav
106 %{__mv} /sbin/fdisk /usr/local/bin/fdisk
107 %{__ln_s} -f /usr/share/mindi/parted2fdisk.pl /sbin/fdisk
108 echo "Warning: you fdisk binary is now under /usr/local/bin"
109 fi
110%endif
111
112%files
113%defattr(644,root,root,755)
114%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
115%doc CHANGES INSTALL COPYING README TODO README.ia64 README.pxe
116%attr(755,root,root) %{_sbindir}/mindi
117%attr(755,root,root) %{_sbindir}/analyze-my-lvm
118%{_datadir}/mindi
119%attr(755,root,root) %{_datadir}/mindi/analyze-my-lvm
120%attr(755,root,root) %{_datadir}/mindi/mindi
121%attr(755,root,root) %{_datadir}/mindi/parted2fdisk.pl
122%attr(755,root,root) %{_datadir}/mindi/aux-tools/sbin/*
123%attr(755,root,root) %{_datadir}/mindi/rootfs/bin/*
124%attr(755,root,root) %{_datadir}/mindi/rootfs/sbin/*
125
126%changelog
127* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
128- ia64 is now working
129- NFS related bug fixed
130- ldd related bugs fixed
131
132* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
133- Merge of patches mentionned on mondo ML + ia64 updates
134- Fix bugs when called alone
135
136* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
137- supports exec-shield
138
139* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
140- better support of SLES 8
141
142* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
143- better kernel-level logging
144- added ACL, xattr binaries to deplist.txt
145- fixed obscure bug which occasionally stopped mindi from correctly finding
146 and documenting all LVM2 LVM-on-RAID volumes
147
148* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
149- added ide_tape and other modules to mindi's config detection
150- unmount errant ramdisk ($mtpt) if fail to create boot floppy
151- better support of ISO dirs at restore-time (Conor Daly)
152
153* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
154- first 1.0x release
155- busybox now static
156- trap Ctrl-Alt-Del; trigger soft reset
157- better SuSE 9.1 support
158- added parted2fdisk.pl (IA64) (Bruno Cornec)
159- add LVM2 support for kernel 2.6 (Takeru Komoriya)
160- better detection of multiple Mindis (Martin Fürstenau)
161- don't complain if just a Mindi boot CD & not a platform for Mondo
162- updated busybox to 1.0.0pre10
163- removed uClibc
164- add memtest support
165- 2.6 kernel support
166- removed Embleer files (Andree Leidenfrost)
167- added kernel-only floppy support, to accommodate really big kernels
168- updated+rebuilt busybox
169- added star support
170- mount /sys at boot-time
171- better 64-bit and 2.6 kernel support
172- better LVM, failsafe kernel support (Jim Richard)
173- use LILO, not raw kernel, on 1.4MB boot floppy
174- record names of unsaved modules, for future reference
175- enlarged ramdisk by 8MB
176
177* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
178- changed some '==' to '=' --- now more RH6-friendly
179- allow absolute pathnames again in deplist
180- disable multifunc cd thing
181- better Gentoo support (Bill)
182- better OnStream support
183- better Slackware support (Laurenz)
184- added partimagehack-static to deplist.txt
185- recompiled Busybox - now 10k smaller; better stack-handling
186- fixed boot screen typo
187- added support for 'auto' fs format
188- better devfs support for Mandrake users
189- better Debian+LVM support (Ralph Grewe)
190- updated analyze-my-lvm to handle floating-point gigabyte -L values
191
192* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
193- altered rootfs's /dev entry to stop cvs from becoming confused
194- tweaked MAX_COMPRESSED_SIZE
195- added multi-function CD support to mindi and sbin/post-init
196- re-mount root as rw just in case
197- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
198- added support for 5th column in mountlist.txt for labels
199- added symlinks.tgz
200- suppress erroneous error msgs re: failsafe kernel
201
202* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
203- added cciss.o to SCSI_MODS
204- if format type is (e.g.) ext3,ext2 then use 1st entry
205- re-enabled fsck*
206- if cciss in use the enable it at boot-time
207- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
208- better ISO support
209- tweaked Mindi to use 10-15% fewer floppies
210- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
211 to be run by Mindi before it bootstraps to aux data disks;
212 e.g. 'echo engage > /proc/scsi/something'
213- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
214 to be run by Mindi after it boots but before it runs mondorestore
215- allow for Debian & other Stiefkinder that use 'none', not 'swap'
216 as the mountpoint of the swap partition
217- removed afio dependency
218- re-worked install.sh and tarball not to use tgz's
219- cleared up the boot msg
220- updated busybox to 0.60.5; updated uClibc to 0.9.19
221- add #!/bin/sh to start of insert-all-my-modules
222- fixed obscure bug in install-additional-tools
223- changed grep -m to grep | head -n1 for Debian users
224- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
225
226* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
227- fixed LVM/RAID bugs (Brian Borgeson)
228- if bad lilo, give more verbose error before quitting
229- added mt and perl to deplist.txt
230- insist on gawk being present
231- insmod ide-cd, cdrom, isofs, just in case
232- boot-time tmpfs ramdisk is now 40m (was 34m)
233- cleaned up logs
234- iso mode now calls Interactive
235- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
236- clean up some calls to grep, esp. partition_mountpt=...
237- corrected some bashisms, to suit Debian ped- er, users
238- made first line refer to bash, not sh, to make sure
239 the Debian people know Mindi requires bash, not hs
240- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
241- disabled code which would have made Mindi use sfdisk instead of fdisk
242 if it looked as if Debian's fdisk would misbehave
243
244* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
245- new devel branch
246- EXTRA_SPACE=16384
247- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
248- patched analyze-my-lvm (Benjamin Mampaey)
249- detect built-in boot.b files in lilo
250- cleaned up spec file a bit, more use of macros (Jesse Keating)
251- return w/err, don't abort, if Matt Nelson's RH8 system is farked
252- better at finding isolinux.bin
253- better at analyzing dependencies when running on broken distributions
254- try harder to boot from CD, even if tape fails
255- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
256- better resolution of relative softlinks, leading to fewer
257 duplicates on data disks and therefore fewer data disks
258- detect Debian+devfs; use sfdisk instead of fdisk in that
259 eventuality, to work around yet another of Debian's warts
260- removed /lib/libuuid.* from rootfs.tgz
261- fixed vi
262- mindi now uses gawk --traditional (making gawk behave in a functionally
263 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
264- removed / from list of dirs accessed when trying to resolve deplist entry
265- spinner bugfix; handle odd LABELs properly (Tom Mortell)
266- fixed LVM/RAID bugs (Brian Borgeson)
267
268* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
269- misc code clean-up
270- save boot device's boot sector
271- detect and beware Compaq diagnostic partitions
272- better handling of devfs V non-devfs kernels and boot devs
273- trimmed busybox 0.60.3 binary on boot disk
274- mindi now resides in /usr/local/bin
275- removed lilo from dependencies
276- more Gentoo-friendly
277
278* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
279- if your kernel's builddate doesn't match any of the kernels in
280 your /boot directory then fudge the issue & find the closest
281 match (*grumble* Debian)
282- scan tape & CD at start, to force inclusion of modules on boot device
283- double EXTRA_SPACE if >7 disks
284- slimmer, more lithesome logfile
285- now accepts --findkernel
286- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
287- better handling of non-Linux partitions on DevFS-enabled kernels
288- misc clean-ups
289- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
290- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
291- updated kernel to 2.4.18-mdk6
292- generate mountlist in dev-abetical order ;)
293- fixed minor bug in .spec file
294- better at finding /boot/boot.b if your distro breaks the de facto standard
295- fixed minor bug in MakeMountlist
296- fixed install.sh
297- cleaned up deplist.txt
298- added rudimentary -v / --version flag
299- line 1180 or so --- duplicate mindi.iso entries --- fixed
300- added /bin/[ - a softlink to /bin/sh
301- ListAllPartitions() - sanity fix (KP)
302- fixed .spec bug
303- better feedback
304- added Markus's RAID patch
305- ListAllPartitions() - include /mnt/win* (Hugo)
306
307* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
308- better logging by dependency-calculating code
309- better handling of dependencies, specifically softlinks
310- if called by mondo then use mondo's temp dir as our temp dir too
311- changed gawk to $AWK in a few places, to allow for Debian
312- added host* config files to deplist
313- added tftp, ifconfig to busybox
314- added RPC support to uClibc
315- cleaned up creation of Mondo-Mindi configuration file
316- fixed bug in TryToFindKernelPath which stopped it from handling
317 multiple, same-version kernels gracefully
318- cleaned up deplist.txt
319- receive 'DIFFERENTIAL' variable from Mondo
320- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
321- better devfs support; call fgrep in places instead of grep (Andrew Korn)
322- fixed analyze-my-lvm (Ralph Gruwe)
323- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
324- added x11-tools.tgz option
325- updated /dev/console and /dev/tty0 (Paul Stevens)
326- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
327- catch sigint, sighup, etc.
328- fixed LILO-related message.txt mistake
329- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
330- better devfs support (Andrew Korn)
331
332* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
333- fixed RH7.3 readonly bug
334- improved nfs config file creation
335- search more locations for isolinux.bin
336- added isonuke option
337- faster data disk creation
338- better DevFS support (Hector Alvarez, DuckX)
339- nfs-related fix (Hans Lie)
340- abort if vfat filesystem present but mkfs.vfat missing
341- removed softlink to pico
342- allow Mondo to say no compression will be used
343- added [ to ramdisk
344- tar data disks with -b [block size] of 32k
345- don't autoboot to 'RESTORE' screen - it's scary!
346- let user choose lilo or syslinux as boot loader
347- added syslinux support
348- cleaned up message screens
349
Note: See TracBrowser for help on using the repository browser.