source: MondoRescue/branches/2.05/mindi/mindi.spec@ 200

Last change on this file since 200 was 200, checked in by bcornec, 18 years ago

Fix a nasty bug in permissions for RPM build

  • Property svn:keywords set to Id
File size: 11.7 KB
RevLine 
[35]1#
2# $Id: mindi.spec 200 2005-12-14 11:24:36Z bcornec $
3#
[50]4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mindi
[102]11%define version 1.05
[50]12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
[64]16Group: Applications/Archiving
[50]17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
[64]22Group: Archiving/Backup
[50]23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
[64]28Group: Archiving/Backup
[50]29Autoreqprov: no
30%endif
31
[1]32Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
[50]33Name: %name
34Version: %version
[64]35Release: %mrel
[1]36License: GPL
37Group: System/Kernel and hardware
[50]38Url: http://mondorescue.berlios.de
39Source: %{src}
[1]40BuildRoot: %{_tmppath}/%{name}-%{version}
[69]41Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools, afio, which
[20]42# Not on all systems
43#Conflicts: bonnie++
[1]44
45%description
46Mindi takes your kernel, modules, tools and libraries, and puts them on N
47bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
48and do system maintenance - e.g. format partitions, backup/restore data,
49verify packages, etc.
50
51%prep
[50]52%{__rm} -rf $RPM_BUILD_ROOT
53%setup -n %name-%{version}
[1]54
55%build
56%ifarch ia64
[50]57%{__make} -f Makefile.parted2fdisk clean
58%{__make} -f Makefile.parted2fdisk
[1]59%endif
60
61%install
[50]62export DONT_RELINK=1
63
[1]64%{__rm} -rf $RPM_BUILD_ROOT
[179]65MINDIDIR=$RPM_BUILD_ROOT%{_libdir}/mindi
66export PREFIX=${RPM_BUILD_ROOT}
67export RPMBUILDMINDI="true"
[50]68
[179]69./install.sh
[50]70
[1]71%{__rm} -f $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox-i386.net
[50]72
[1]73%clean
74%{__rm} -rf $RPM_BUILD_ROOT
75
76%post
[179]77if [ -f /usr/local/sbin/mindi ]; then
78 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
79fi
80
[1]81%files
[50]82%defattr(644,root,root,755)
[1]83%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
[179]84%doc CHANGES INSTALL COPYING README TODO README.ia64 README.pxe README.busybox
[200]85%{_mandir}
86%{_libdir}/mindi
87%attr(755,root,root) %{_libdir}/mindi/aux-tools/sbin/*
88%attr(755,root,root) %{_libdir}/mindi/rootfs/bin/*
89%attr(755,root,root) %{_libdir}/mindi/rootfs/sbin/*
[189]90%attr(755,root,root) %{_sbindir}/*
[1]91
92%changelog
[102]93* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
94- ia64 is now working
[179]95- use install.sh script
96- use libdir for binary data
[102]97
[15]98* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
[12]99- Merge of patches mentionned on mondo ML + ia64 updates
[50]100- Fix bugs when called alone
[12]101
[1]102* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
103- supports exec-shield
104
105* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
106- better support of SLES 8
107
108* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
109- better kernel-level logging
110- added ACL, xattr binaries to deplist.txt
111- fixed obscure bug which occasionally stopped mindi from correctly finding
112 and documenting all LVM2 LVM-on-RAID volumes
113
114* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
115- added ide_tape and other modules to mindi's config detection
116- unmount errant ramdisk ($mtpt) if fail to create boot floppy
117- better support of ISO dirs at restore-time (Conor Daly)
118
119* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
120- first 1.0x release
121- busybox now static
122- trap Ctrl-Alt-Del; trigger soft reset
123- better SuSE 9.1 support
124- added parted2fdisk.pl (IA64) (Bruno Cornec)
125- add LVM2 support for kernel 2.6 (Takeru Komoriya)
126- better detection of multiple Mindis (Martin Fürstenau)
127- don't complain if just a Mindi boot CD & not a platform for Mondo
128- updated busybox to 1.0.0pre10
129- removed uClibc
130- add memtest support
131- 2.6 kernel support
132- removed Embleer files (Andree Leidenfrost)
133- added kernel-only floppy support, to accommodate really big kernels
134- updated+rebuilt busybox
135- added star support
136- mount /sys at boot-time
137- better 64-bit and 2.6 kernel support
138- better LVM, failsafe kernel support (Jim Richard)
139- use LILO, not raw kernel, on 1.4MB boot floppy
140- record names of unsaved modules, for future reference
141- enlarged ramdisk by 8MB
142
143* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
144- changed some '==' to '=' --- now more RH6-friendly
145- allow absolute pathnames again in deplist
146- disable multifunc cd thing
147- better Gentoo support (Bill)
148- better OnStream support
149- better Slackware support (Laurenz)
150- added partimagehack-static to deplist.txt
151- recompiled Busybox - now 10k smaller; better stack-handling
152- fixed boot screen typo
153- added support for 'auto' fs format
154- better devfs support for Mandrake users
155- better Debian+LVM support (Ralph Grewe)
156- updated analyze-my-lvm to handle floating-point gigabyte -L values
157
158* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
159- altered rootfs's /dev entry to stop cvs from becoming confused
160- tweaked MAX_COMPRESSED_SIZE
161- added multi-function CD support to mindi and sbin/post-init
162- re-mount root as rw just in case
163- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
164- added support for 5th column in mountlist.txt for labels
165- added symlinks.tgz
166- suppress erroneous error msgs re: failsafe kernel
167
168* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
169- added cciss.o to SCSI_MODS
170- if format type is (e.g.) ext3,ext2 then use 1st entry
171- re-enabled fsck*
172- if cciss in use the enable it at boot-time
173- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
174- better ISO support
175- tweaked Mindi to use 10-15% fewer floppies
176- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
177 to be run by Mindi before it bootstraps to aux data disks;
178 e.g. 'echo engage > /proc/scsi/something'
179- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
180 to be run by Mindi after it boots but before it runs mondorestore
181- allow for Debian & other Stiefkinder that use 'none', not 'swap'
182 as the mountpoint of the swap partition
183- removed afio dependency
184- re-worked install.sh and tarball not to use tgz's
185- cleared up the boot msg
186- updated busybox to 0.60.5; updated uClibc to 0.9.19
187- add #!/bin/sh to start of insert-all-my-modules
188- fixed obscure bug in install-additional-tools
189- changed grep -m to grep | head -n1 for Debian users
190- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
191
192* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
193- fixed LVM/RAID bugs (Brian Borgeson)
194- if bad lilo, give more verbose error before quitting
195- added mt and perl to deplist.txt
196- insist on gawk being present
197- insmod ide-cd, cdrom, isofs, just in case
198- boot-time tmpfs ramdisk is now 40m (was 34m)
199- cleaned up logs
200- iso mode now calls Interactive
201- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
202- clean up some calls to grep, esp. partition_mountpt=...
203- corrected some bashisms, to suit Debian ped- er, users
204- made first line refer to bash, not sh, to make sure
205 the Debian people know Mindi requires bash, not hs
206- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
207- disabled code which would have made Mindi use sfdisk instead of fdisk
208 if it looked as if Debian's fdisk would misbehave
209
210* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
211- new devel branch
212- EXTRA_SPACE=16384
213- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
214- patched analyze-my-lvm (Benjamin Mampaey)
215- detect built-in boot.b files in lilo
216- cleaned up spec file a bit, more use of macros (Jesse Keating)
217- return w/err, don't abort, if Matt Nelson's RH8 system is farked
218- better at finding isolinux.bin
219- better at analyzing dependencies when running on broken distributions
220- try harder to boot from CD, even if tape fails
221- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
222- better resolution of relative softlinks, leading to fewer
223 duplicates on data disks and therefore fewer data disks
224- detect Debian+devfs; use sfdisk instead of fdisk in that
225 eventuality, to work around yet another of Debian's warts
226- removed /lib/libuuid.* from rootfs.tgz
227- fixed vi
228- mindi now uses gawk --traditional (making gawk behave in a functionally
229 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
230- removed / from list of dirs accessed when trying to resolve deplist entry
231- spinner bugfix; handle odd LABELs properly (Tom Mortell)
232- fixed LVM/RAID bugs (Brian Borgeson)
233
234* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
235- misc code clean-up
236- save boot device's boot sector
237- detect and beware Compaq diagnostic partitions
238- better handling of devfs V non-devfs kernels and boot devs
239- trimmed busybox 0.60.3 binary on boot disk
240- mindi now resides in /usr/local/bin
241- removed lilo from dependencies
242- more Gentoo-friendly
243
244* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
245- if your kernel's builddate doesn't match any of the kernels in
246 your /boot directory then fudge the issue & find the closest
247 match (*grumble* Debian)
248- scan tape & CD at start, to force inclusion of modules on boot device
249- double EXTRA_SPACE if >7 disks
250- slimmer, more lithesome logfile
251- now accepts --findkernel
252- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
253- better handling of non-Linux partitions on DevFS-enabled kernels
254- misc clean-ups
255- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
256- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
257- updated kernel to 2.4.18-mdk6
258- generate mountlist in dev-abetical order ;)
259- fixed minor bug in .spec file
260- better at finding /boot/boot.b if your distro breaks the de facto standard
261- fixed minor bug in MakeMountlist
262- fixed install.sh
263- cleaned up deplist.txt
264- added rudimentary -v / --version flag
265- line 1180 or so --- duplicate mindi.iso entries --- fixed
266- added /bin/[ - a softlink to /bin/sh
267- ListAllPartitions() - sanity fix (KP)
268- fixed .spec bug
269- better feedback
270- added Markus's RAID patch
271- ListAllPartitions() - include /mnt/win* (Hugo)
272
273* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
274- better logging by dependency-calculating code
275- better handling of dependencies, specifically softlinks
276- if called by mondo then use mondo's temp dir as our temp dir too
277- changed gawk to $AWK in a few places, to allow for Debian
278- added host* config files to deplist
279- added tftp, ifconfig to busybox
280- added RPC support to uClibc
281- cleaned up creation of Mondo-Mindi configuration file
282- fixed bug in TryToFindKernelPath which stopped it from handling
283 multiple, same-version kernels gracefully
284- cleaned up deplist.txt
285- receive 'DIFFERENTIAL' variable from Mondo
286- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
287- better devfs support; call fgrep in places instead of grep (Andrew Korn)
288- fixed analyze-my-lvm (Ralph Gruwe)
289- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
290- added x11-tools.tgz option
291- updated /dev/console and /dev/tty0 (Paul Stevens)
292- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
293- catch sigint, sighup, etc.
294- fixed LILO-related message.txt mistake
295- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
296- better devfs support (Andrew Korn)
297
298* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
299- fixed RH7.3 readonly bug
300- improved nfs config file creation
301- search more locations for isolinux.bin
302- added isonuke option
303- faster data disk creation
304- better DevFS support (Hector Alvarez, DuckX)
305- nfs-related fix (Hans Lie)
306- abort if vfat filesystem present but mkfs.vfat missing
307- removed softlink to pico
308- allow Mondo to say no compression will be used
309- added [ to ramdisk
310- tar data disks with -b [block size] of 32k
311- don't autoboot to 'RESTORE' screen - it's scary!
312- let user choose lilo or syslinux as boot loader
313- added syslinux support
314- cleaned up message screens
315
Note: See TracBrowser for help on using the repository browser.