source: MondoRescue/branches/2.04_berlios/mondo/mondo.spec@ 3656

Last change on this file since 3656 was 79, checked in by bcornec, 19 years ago

X11 seems broken so remove the X11 files in spec of mondo

  • Property svn:keywords set to Id
File size: 18.9 KB
Line 
1#
2# $Id: mondo.spec 79 2005-10-20 13:54:51Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mondo
11%define version 2.04_berlios
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32
33Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
34Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
35Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
36Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
37
38Name: %{name}
39Version: %{version}
40Release: %{mrel}
41License: GPL
42Url: http://mondorescue.berlios.de
43Source: %{src}
44BuildRoot: %{_tmppath}/%{name}-%{version}
45BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
46%ifarch ia64
47Requires: mindi >= 1.04_berlios, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
48%{!?_without_xmondo:BuildRequires: gcc-c++, XFree86-devel, qt-devel, kdelibs-devel, libpng-devel}
49%else
50Requires: mindi >= 1.04_berlios, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, cdrecord, buffer
51%{!?_without_xmondo:BuildRequires: gcc-c++, XFree86-devel, qt-devel, kdelibs-devel, arts-devel, libart_lgpl-devel, libpng-devel}
52%endif
53
54#%package xmondo
55#Summary: A QT based graphical front end for %{name}
56#Group: Applications/Archiving
57#Requires: %{name} = %{version}-${release}, qt, kdelibs
58#
59#%package %{name}-devel
60#Summary: Header files for building against Mondo
61#%if %is_mandrake
62#Group: Development/Libraries
63#%endif
64#if %is_redhat
65#Group: Development/Other
66#%endif
67#Provides: libmondo-devel mondo-devel
68#Obsoletes: libmondo-devel
69#
70#%description -n %{name}-devel
71#Mondo libraries and includes
72
73%description
74Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
75
76%description -l fr
77Objectif
78""""""""
79Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
80
81%description -l it
82Scopo
83"""""
84Mondo e' un programma che permette a qualsiasi utente Linux
85di creare un cd di rescue/restore (o piu' cd qualora l'installazione
86dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
87nastro, ed il NFS, anche.
88
89%description -l sp
90Objectivo
91"""""""""
92Mondo es un programa que permite cualquier usuario de Linux a crear una CD
93de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
94con cintas y NFS, tambien.
95
96#%description xmondo
97#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
98#set up a backup by following onscreen prompts.
99
100%prep
101%setup -q -n %name-%{version}
102
103%build
104%configure %{!?_without_xmondo:--with-x11}
105%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
106
107%install
108%{__rm} -rf $RPM_BUILD_ROOT
109%makeinstall
110
111%post
112/sbin/ldconfig
113
114%postun
115/sbin/ldconfig
116
117%clean
118%{__rm} -rf $RPM_BUILD_ROOT
119
120%files
121%defattr(644,root,root,755)
122%doc ChangeLog mondo/docs/en/1.6x-howto/*
123%doc INSTALL COPYING README TODO AUTHORS NEWS
124
125%attr(755,root,root) %{_sbindir}/*
126%attr(755,root,root) %{_datadir}/%{name}/restore-scripts/%{name}
127%{_datadir}/%{name}
128%{_mandir}/*
129%{_libdir}/*
130
131#%{!?_without_xmondo:%files xmondo}
132#%{!?_without_xmondo:%{_sbindir}/xmondo}
133#%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
134#%{!?_without_xmondo:%{_libdir}/libXmondo.so}
135#%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
136
137%changelog
138* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
139- Merge of patches mentionned on mondo ML + ia64 updates
140- Add -p option
141
142* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
143- made mondo more clever about finding its home. Avoids mondo considering
144 directories like '/usr/share/doc/momdo' as its home.
145
146* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
147- test sanity of user-specified tempdir
148- better SLES8 support
149
150* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
151- instead of using 'dd' to erase partition table, delete existing
152 partitions w/ the same call to fdisk that is used to create the
153 new partitions; this should avoids locking up the partition table
154- set bootable partition in the above same call to fdisk, for
155 the same reason (avoids locking up the partition table)
156- better software RAID support
157- mount ext3 partitions as ext2 when restoring - better for Debian
158- better star, ACL support
159- added ACL, xattr support for afio users
160
161* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
162- fixed cvs for SuSE systems
163- fixed NTFS backup/restore bug relating to partimagehack
164 log file overflow and NTFS v non-NTFS differentiation
165- more reliable extraction of config info from CDs, floppies
166- better support of ISO dirs at restore-time (Conor Daly)
167- fixed spec file for SuSE users
168- added ldconfig to install section
169
170* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
171- first 2.0 release
172- updated grub-install.patched to support SuSE and Red Hat
173- call 'mt' to set block size to 32K before opening in/out tape
174- updated mondo-prep.c to create each disk's partitions all at once
175 (one call per drive) instead of one call to fdisk per partition
176- when extracting cfg file and mountlist from all.tar.gz (tape copy),
177 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
178- added star and rudimentary SELinux support
179- fixed lots of bugs
180- all logging now goes to /var/log/mondo-archive.log, with symlink
181 to /tmp/mondo-restore.log for restore-time log-tracking
182- added grub-install.patched
183- removed embleer & other binaries
184- added '-b' to specify block size
185- added '-R' for star support
186
187* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
188- ia64 fixes
189
190* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
191- fixed symbolic links for libraries
192- added support for boot/root multi floppies
193
194- added kdelibs as xmondo dependency
195- added xmondo pixmap installation
196- better find_cdrom_device(), to cope w/ multiple CD writers
197- fixed -m and -Vc flags
198- fixed NTFS support!
199- bootable CD uses native, not El Torito, support now
200- removed mondo-makefilelist
201- added 2.6 kernel support
202- if 2.6 kernel, insist that the user specify CD device
203- drop Embleer; insist on ms-sys and parted if Windows partition
204
205* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
206- added -devel package
207
208* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
209- made xmondo a second package
210- added ability to specify --without xmondo at build time
211
212* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
213- Clean up, added spanish translation
214- Set prefix to be /usr
215- added/fixed Requires
216- remove CVS directories prior to building
217
218* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
219- nothing yet
220
221* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
222- fixed chmod/chown bug (Jens Richter)
223- ask user to confirm NFS mountpoint in Interactive Mode
224- rewritten format_everything() to make sure LVMs, RAIDs and
225 regular partitions are prepped in the correct order
226- better magicdev support
227- rewritten external binary caller subroutine
228- DVD support added
229- better backup-time control gui; offer to exclude nfs if appl.
230- fixed multi-tape support
231- re-implemented -D and -J
232- fixed bug in extract_config_file_from_ramdisk() which
233 affected tape+floppy users
234- updated is_incoming_block_valid() to make it
235 return end-of-tape if >300 flotsam blocks
236- unmount CD-ROM before burning (necessary for RH8/9)
237- fixed some stray assert()'s
238- fixed bug in grub-MR (Christian)
239- make user remove floppy/CD before restoring interactively from tape
240- fixed bug in am_I_in_disaster_recovery_mode()
241- added code to nuke_mode() to make sure NFS
242 (backup) share is mounted in Nuke Mode
243- improved tape device detection code
244- better GRUB support
245- better logging of changed bigfiles at compare-time
246- better NTFS support, thanks to partimagehack-static
247- better logging
248- rewrote tape-handling code, breaking compatibility w/ previous versions
249- fixed ISO/CD biggiefile verification bug in mondoarchive
250- fixed bug which stopped boot/compare-time changelist from popping up
251- replaced mondo-makefilelist with C code - faster, cleaner
252- tweaked GUI - better feedback
253
254* Wed May 28 2003 Anonymous <root@rohan> 1.74
255- misc fixes (Michael Hanscho's friend)
256- added rudimentary support for SME
257- added better label support
258- fixed biggietime atime/ctime restoration bug 73
259- fixed 'default boot loader' detection bug (Joshua Oreman)
260- use single-threaded make_afioballs_and_images() if FreeBSD
261- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
262- superior get_phys_size_of_drive() (Joshua Oreman)
263- fixed RAID-related bug in where_is_root_mounted()
264- ISO tweaks
265- fixed silly bug in load_filelist() which stopped
266 funny German filenames from being handled properly
267- fixed various calls to popup_and_get_string()
268- fixed spec file
269- reject -E /
270- added partimagehack to the mix
271
272* Tue May 20 2003 Anonymous <root@rohan> 1.73
273- mark devices as bootable _after_ unmounting them
274- resolve boot device (-f) if softlink
275- post_param_configuration() --- store iso-dev and isodir
276- added post-nuke-sample.tgz to package
277- Nuke Mode now checks mountlist against hardware; offer user
278 opportunity to edit mountlist if insane; if user declines, abort
279- added lots of assert()'s and other checks
280- ran code thru Valgrind to catch & fix some memory leaks
281- made mondo-restore.c smaller by moving some subroutines to
282 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
283- added '-Q' to let user test mondoarchive's ability to find
284 their boot loader and type
285- improved which_boot_loader()
286- when burning or comparing to a CD, defeat autorun if it is
287 running, to avoid confusing mondoarchive and the user
288- if original backup media no longer available at boot-time
289 then offer user chance to choose another media source
290- when booting, type 'nuke noresize' to nuke w/o resizing
291 mountlist to fill your drives
292- add 'textonly' when booting, to avoid using Newt gui
293- run nice(20) to prioritize mondoarchive at start
294- don't pause and wait for next blank CD at backup-time
295 unless necessary (e.g. previous CD has not been removed)
296- get_phys_size_of_drive() --- better support of older drives
297- don't eject if "donteject" is in kernel's command line
298- cleaned up segfault-handling
299- added Conor's strip_path() to improve file list display
300- added Herman Kuster's multi-level bkp patch
301- better boot-time screen/message
302- added Joshua Oreman's FreeBSD patches x3
303- fixed interactive/textonly support
304- fixed support for subdir-within-NFS-mount
305- fixed "Can't backup if ramdisk not mounted" bug
306- try to work around eccentricities of multi-CD drive PCs
307- misc clean-ups (Steve Hindle)
308
309* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
310- LVM/RAID bugs fixed (Brian Borgeson)
311- major clean-up of code (Stan Benoit)
312- make-me-bootable fix (Juraj Ziegler)
313- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
314- removed duplicate entry from makefile
315- if root is /dev/root then assume not a ramdisk
316- reject relative paths if -d flag (Alessandro Polverini)
317- fixed potentially infinite loop in log_to_screen (Tom Mortell)
318- add '/' to custom filelist as workaround for obscure bug
319- ask user speed of CDRW if writing to CD
320- find_cdrom_device() --- if nonexistent/not found then
321 make sure to return '' as dev str and 1 as res
322- tweaked restore scripts tgz
323- cleaned up find_cdrom_device()
324- if user creates /usr/share/mondo/payload.tgz then untar
325 payload to CD at backup-time
326- fixed insist_on_this_cd_number()
327- fixed am_i_in_disaster_recovery_mode()
328- misc clean-up (Tom Mortell)
329- made code more legible
330- fixed post-nuke support
331- added -e support
332- fixed nfs support
333- fixed iso support
334- at restore-time, only sort mountlist internally,
335 in mount_all_devices() and unmount_all_devices()
336- fixed cosmetic bug in label-partitions-as-necessary
337- updated documentation
338- fixed fstab-hacking scripts
339
340* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
341- log newt, slang, ncurses info
342- updated man page
343- handle %% chars in issue.net properly (Heiko Schlittermann)
344- fixed serious NFS restore bug
345- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
346- changed various strcpy() calls to strncpy() calls
347- added mondo-makefilelist to makefile (Mikael Hultgren)
348- mount_cdrom() better at handling multiple CD drives
349- exclude /media/cdrom,cdrecorder,floppy
350- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
351- better logging by eval_call_to_make_ISO()
352- accept -J <fname> to let user provide their own fs catalog
353 instead of -I <paths> to backup
354- if dir excluded with -E or included with -I and dir is actually
355 a softlink then exclude/include the dir pointed to, as well
356- better location for manpage
357- adjusted block size of tarball at start of tape, to help
358 users w/ broken tape driver firmware
359- sort -u fstab after modifying it
360- if backup type is nfs then don't estimate noof media
361- fixed Makefile (Mikael Hultgren)
362- updated manpage
363
364* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
365- new devel branch opened
366
367* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
368- fixed bug in multithreading
369- use new grub-MR instead of grub-install
370- wipe only the partition table (not the MBR) when partitioning drives
371- ignore lilo.conf.anaconda when looking for lilo.conf file
372- accepts '-l RAW' to backup/restore original boot sector instead
373 of running grub or lilo to init it after restoring
374- fixed&updated stabgrub-me script; software RAID + GRUB work now
375- mount/unmount /boot partition for Gentoo 1.2 users
376- re-enabled extra tape checksums
377- disabled spurious warnings
378- unmount/remount supermounts at start/end of live restore, if nec.
379- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
380 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
381- added Makefile
382- added -l RAW, to backup and restore original MBR
383- cleaned up iso_mode() and nfs restoring
384- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
385- made mondorestore CD bootable for ArkLinux users
386- if user runs as 'su' not 'su -' then work around
387
388* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
389- pop-up list of changed files, at end of verification phase
390- better handling of changed.files list at restore-time
391- lots of CD-related fixes
392- added '-N' flag --- to let user exclude all NFS-related mounts&devices
393- better handling of 'kill'
394- restructuring of code to ease integration of mondo w/XMondo
395- fixed obscure bug in find_and_mount_actual_cd()
396- if / or /root has <50MB free then abort & complain
397- fixed install.sh
398- fixed .spec file
399- updated documentation
400- commented code
401- updated man page
402- added -v / --version flag
403- replace convoluted grep with wc (KP)
404- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
405- fixed BurnProof-related bug
406- better at figuring out which is the best partition for temp/scratchdir
407- added do-not-compress-these (text file) to RPM
408- do not compress files of types listed in do-not-compress-these
409- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
410- added Cosgrove's do-not-compress-these list
411- included various patches from KP
412- chmod tmpdir, scratchdir to 700 before using
413- restore from specified backup device, even if its own cfg file disagrees
414- fixed multi-tape bug
415- fixed "Can't find first ISO when verifying nonbootable ISO" bug
416- multithreaded make_afioballs_and_images()
417- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
418 command-line parameters or not
419- fixed bug in strip_spaces() which stopped it from handling
420 small strings correctly - affected mountlist editor
421- create a repaired copy of grub-install which is RAID-friendly;
422 use it when initializing boot sector with run_grub()
423- fixed bug in mondo-makefilelist
424
425* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
426- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
427- during selective restore, skip filesets which don't contain relevant archives
428- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
429- remove /var/run/*.pid after restoring
430- move spurious lockfiles from /home/* to /home/*/.disabled
431- ask user to confirm the tape/CD device name
432- lots of multitape-related fixes
433- added code to autodetect the hardware of the user, if possible
434- if isodir does not exist then abort
435- more sanity-checking for -d flag
436- doubled 'biggiefile' threshold... to 32MB
437- exclude /root/images/mindi
438- fixed multi-imagedev bug (Emmanuel Druon)
439- unmount/remount /mnt/floppy before/after backing up, if Mandrake
440- restructured the source files
441- fixed serious bug in line 1546 - should have been !=, not ==; stopped
442 mondorestore from correctly restoring big files
443- added '#include <signal.h>' to my-stuff.h
444- exclude "incheckentry xwait()" from changed.files
445- fixed minor bug in find_cdrom_device()
446- fixed bug in friendly_sizestr...
447- insist on tape #1 when start verifying
448- added internal buffering, replacing the external 'buffer' exe
449- if differential backup then don't permit formatting or fdisking,
450 whether Interactive or Nuke mode
451- if mondorestore is run on live filesystem (or from ramdisk) without
452 parameters then mondorestore will ask which backup media (tape, CD, etc.)
453 was used; it will read the config file from the media and proceed from there
454- if tape streamer is softlink then resolve it first
455- incorporate post-nuke tarball
456- if user doesn't specify tape size, proceed anyway; behave intelligently
457 in the event of end-of-tape
458- prefix bkpinfo->restore_path to biggiefile fname before generating
459 checksum & comparing to archived biggiefile
460- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
461 then create a softlink from the former to the latter, to work
462 around RH7.3's b0rken LILO support
463- LFS support (mharris, michele, hugo)
464- fixed verify bug --- CD#1 was being verified again & again & ...
465- differential mode fixed; supported again
466- ask user for boot loader + device if not detectible
467- list up to 512 files in file selection window at once (was 128)
468- better handling of bigfiles' checksums, perms and owns
469- delete final filelist if <=2 bytes long
470- if kernel not found and mondo in graphics mode then popup and ask
471 for kernel path+filename
472
473* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
474- 1.5x branch forked off from 1.4x branch
475
476
477
478
Note: See TracBrowser for help on using the repository browser.