source: MondoRescue/branches/2.04_berlios/mondo/mondo.spec@ 53

Last change on this file since 53 was 53, checked in by bcornec, 19 years ago

mondo.spec sharable between distributions (natively OK for mdk/mdv)

  • Property svn:keywords set to Id
File size: 18.9 KB
RevLine 
[35]1#
2# $Id: mondo.spec 53 2005-10-07 23:47:29Z bcornec $
3#
[53]4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
[1]9
[53]10%define name mondo
11%define version 2.04_berlios
12%define mrel 1
13
14%if %is_redhat
15%define release %{mrel}
16%define src %{name}-%{version}.tgz
17Group: Applications/Archiving
18Autoreq: 0
19%endif
20
21%if %is_mandrake
22%define release %{mrel}mdk
23%define src %{name}-%{version}.tar.bz2
24Group: Archiving/Backup
25Autoreqprov: no
26%endif
27
[1]28Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
29Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
30Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
31Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
[53]32
33Name: %{name}
34Version: %{version}
35Release: %{release}
[1]36License: GPL
[53]37Url: http://mondorescue.berlios.de
38Source: %{src}
39BuildRoot: %{_tmppath}/%{name}-%{version}
[1]40BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
41%ifarch ia64
[53]42Requires: mindi >= 1.04_berlios, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
[1]43%{!?_without_xmondo:BuildRequires: gcc-c++, XFree86-devel, qt-devel, kdelibs-devel, libpng-devel}
44%else
[53]45Requires: mindi >= 1.04_berlios, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, cdrecord, buffer
[1]46%{!?_without_xmondo:BuildRequires: gcc-c++, XFree86-devel, qt-devel, kdelibs-devel, arts-devel, libart_lgpl-devel, libpng-devel}
47%endif
48
[53]49#%package xmondo
50#Summary: A QT based graphical front end for %{name}
51#Group: Applications/Archiving
52#Requires: %{name} = %{version}-${release}, qt, kdelibs
53#
54#%package %{name}-devel
55#Summary: Header files for building against Mondo
56#%if %is_mandrake
57#Group: Development/Libraries
58#%endif
59#if %is_redhat
60#Group: Development/Other
61#%endif
62#Provides: libmondo-devel mondo-devel
63#Obsoletes: libmondo-devel
64#
65#%description -n %{name}-devel
66#Mondo libraries and includes
[1]67
68%description
[53]69Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
[1]70
71%description -l fr
72Objectif
73""""""""
[53]74Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
[1]75
76%description -l it
77Scopo
78"""""
79Mondo e' un programma che permette a qualsiasi utente Linux
80di creare un cd di rescue/restore (o piu' cd qualora l'installazione
81dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
82nastro, ed il NFS, anche.
83
84%description -l sp
85Objectivo
86"""""""""
87Mondo es un programa que permite cualquier usuario de Linux a crear una CD
88de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
89con cintas y NFS, tambien.
90
[53]91#%description xmondo
92#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
93#set up a backup by following onscreen prompts.
[1]94
95%prep
[53]96%setup -q -n %name-%{version}
[1]97
[53]98%build
[1]99%configure %{!?_without_xmondo:--with-x11}
100%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
101
102%install
[53]103%{__rm} -rf $RPM_BUILD_ROOT
104%makeinstall
[1]105
[53]106%post
107/sbin/ldconfig
[1]108
[53]109%postun
110/sbin/ldconfig
[1]111
112%clean
113%{__rm} -rf $RPM_BUILD_ROOT
114
115%files
[53]116%defattr(644,root,root,755)
117%doc ChangeLog mondo/docs/en/1.6x-howto/*
118%doc INSTALL COPYING README TODO AUTHORS NEWS
[1]119
[53]120%attr(755,root,root) %{_sbindir}/*
121%attr(755,root,root) %{_datadir}/%{name}/restore-scripts/%{name}
122%{_datadir}/%{name}
123%{_mandir}/*
124%{_libdir}/*
125
[1]126%{!?_without_xmondo:%files xmondo}
127%{!?_without_xmondo:%{_sbindir}/xmondo}
128%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
129%{!?_without_xmondo:%{_libdir}/libXmondo.so}
130%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
131
132%changelog
[14]133* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
[13]134- Merge of patches mentionned on mondo ML + ia64 updates
[53]135- Add -p option
[13]136
[1]137* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
138- made mondo more clever about finding its home. Avoids mondo considering
139 directories like '/usr/share/doc/momdo' as its home.
140
141* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
142- test sanity of user-specified tempdir
143- better SLES8 support
144
145* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
146- instead of using 'dd' to erase partition table, delete existing
147 partitions w/ the same call to fdisk that is used to create the
148 new partitions; this should avoids locking up the partition table
149- set bootable partition in the above same call to fdisk, for
150 the same reason (avoids locking up the partition table)
151- better software RAID support
152- mount ext3 partitions as ext2 when restoring - better for Debian
153- better star, ACL support
154- added ACL, xattr support for afio users
155
156* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
157- fixed cvs for SuSE systems
158- fixed NTFS backup/restore bug relating to partimagehack
159 log file overflow and NTFS v non-NTFS differentiation
160- more reliable extraction of config info from CDs, floppies
161- better support of ISO dirs at restore-time (Conor Daly)
162- fixed spec file for SuSE users
163- added ldconfig to install section
164
165* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
166- first 2.0 release
167- updated grub-install.patched to support SuSE and Red Hat
168- call 'mt' to set block size to 32K before opening in/out tape
169- updated mondo-prep.c to create each disk's partitions all at once
170 (one call per drive) instead of one call to fdisk per partition
171- when extracting cfg file and mountlist from all.tar.gz (tape copy),
172 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
173- added star and rudimentary SELinux support
174- fixed lots of bugs
175- all logging now goes to /var/log/mondo-archive.log, with symlink
176 to /tmp/mondo-restore.log for restore-time log-tracking
177- added grub-install.patched
178- removed embleer & other binaries
179- added '-b' to specify block size
180- added '-R' for star support
181
182* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
183- ia64 fixes
184
185* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
186- fixed symbolic links for libraries
187- added support for boot/root multi floppies
188
189- added kdelibs as xmondo dependency
190- added xmondo pixmap installation
191- better find_cdrom_device(), to cope w/ multiple CD writers
192- fixed -m and -Vc flags
193- fixed NTFS support!
194- bootable CD uses native, not El Torito, support now
195- removed mondo-makefilelist
196- added 2.6 kernel support
197- if 2.6 kernel, insist that the user specify CD device
198- drop Embleer; insist on ms-sys and parted if Windows partition
199
200* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
201- added -devel package
202
203* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
204- made xmondo a second package
205- added ability to specify --without xmondo at build time
206
207* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
208- Clean up, added spanish translation
209- Set prefix to be /usr
210- added/fixed Requires
211- remove CVS directories prior to building
212
213* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
214- nothing yet
215
216* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
217- fixed chmod/chown bug (Jens Richter)
218- ask user to confirm NFS mountpoint in Interactive Mode
219- rewritten format_everything() to make sure LVMs, RAIDs and
220 regular partitions are prepped in the correct order
221- better magicdev support
222- rewritten external binary caller subroutine
223- DVD support added
224- better backup-time control gui; offer to exclude nfs if appl.
225- fixed multi-tape support
226- re-implemented -D and -J
227- fixed bug in extract_config_file_from_ramdisk() which
228 affected tape+floppy users
229- updated is_incoming_block_valid() to make it
230 return end-of-tape if >300 flotsam blocks
231- unmount CD-ROM before burning (necessary for RH8/9)
232- fixed some stray assert()'s
233- fixed bug in grub-MR (Christian)
234- make user remove floppy/CD before restoring interactively from tape
235- fixed bug in am_I_in_disaster_recovery_mode()
236- added code to nuke_mode() to make sure NFS
237 (backup) share is mounted in Nuke Mode
238- improved tape device detection code
239- better GRUB support
240- better logging of changed bigfiles at compare-time
241- better NTFS support, thanks to partimagehack-static
242- better logging
243- rewrote tape-handling code, breaking compatibility w/ previous versions
244- fixed ISO/CD biggiefile verification bug in mondoarchive
245- fixed bug which stopped boot/compare-time changelist from popping up
246- replaced mondo-makefilelist with C code - faster, cleaner
247- tweaked GUI - better feedback
248
249* Wed May 28 2003 Anonymous <root@rohan> 1.74
250- misc fixes (Michael Hanscho's friend)
251- added rudimentary support for SME
252- added better label support
253- fixed biggietime atime/ctime restoration bug 73
254- fixed 'default boot loader' detection bug (Joshua Oreman)
255- use single-threaded make_afioballs_and_images() if FreeBSD
256- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
257- superior get_phys_size_of_drive() (Joshua Oreman)
258- fixed RAID-related bug in where_is_root_mounted()
259- ISO tweaks
260- fixed silly bug in load_filelist() which stopped
261 funny German filenames from being handled properly
262- fixed various calls to popup_and_get_string()
263- fixed spec file
264- reject -E /
265- added partimagehack to the mix
266
267* Tue May 20 2003 Anonymous <root@rohan> 1.73
268- mark devices as bootable _after_ unmounting them
269- resolve boot device (-f) if softlink
270- post_param_configuration() --- store iso-dev and isodir
271- added post-nuke-sample.tgz to package
272- Nuke Mode now checks mountlist against hardware; offer user
273 opportunity to edit mountlist if insane; if user declines, abort
274- added lots of assert()'s and other checks
275- ran code thru Valgrind to catch & fix some memory leaks
276- made mondo-restore.c smaller by moving some subroutines to
277 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
278- added '-Q' to let user test mondoarchive's ability to find
279 their boot loader and type
280- improved which_boot_loader()
281- when burning or comparing to a CD, defeat autorun if it is
282 running, to avoid confusing mondoarchive and the user
283- if original backup media no longer available at boot-time
284 then offer user chance to choose another media source
285- when booting, type 'nuke noresize' to nuke w/o resizing
286 mountlist to fill your drives
287- add 'textonly' when booting, to avoid using Newt gui
288- run nice(20) to prioritize mondoarchive at start
289- don't pause and wait for next blank CD at backup-time
290 unless necessary (e.g. previous CD has not been removed)
291- get_phys_size_of_drive() --- better support of older drives
292- don't eject if "donteject" is in kernel's command line
293- cleaned up segfault-handling
294- added Conor's strip_path() to improve file list display
295- added Herman Kuster's multi-level bkp patch
296- better boot-time screen/message
297- added Joshua Oreman's FreeBSD patches x3
298- fixed interactive/textonly support
299- fixed support for subdir-within-NFS-mount
300- fixed "Can't backup if ramdisk not mounted" bug
301- try to work around eccentricities of multi-CD drive PCs
302- misc clean-ups (Steve Hindle)
303
304* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
305- LVM/RAID bugs fixed (Brian Borgeson)
306- major clean-up of code (Stan Benoit)
307- make-me-bootable fix (Juraj Ziegler)
308- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
309- removed duplicate entry from makefile
310- if root is /dev/root then assume not a ramdisk
311- reject relative paths if -d flag (Alessandro Polverini)
312- fixed potentially infinite loop in log_to_screen (Tom Mortell)
313- add '/' to custom filelist as workaround for obscure bug
314- ask user speed of CDRW if writing to CD
315- find_cdrom_device() --- if nonexistent/not found then
316 make sure to return '' as dev str and 1 as res
317- tweaked restore scripts tgz
318- cleaned up find_cdrom_device()
319- if user creates /usr/share/mondo/payload.tgz then untar
320 payload to CD at backup-time
321- fixed insist_on_this_cd_number()
322- fixed am_i_in_disaster_recovery_mode()
323- misc clean-up (Tom Mortell)
324- made code more legible
325- fixed post-nuke support
326- added -e support
327- fixed nfs support
328- fixed iso support
329- at restore-time, only sort mountlist internally,
330 in mount_all_devices() and unmount_all_devices()
331- fixed cosmetic bug in label-partitions-as-necessary
332- updated documentation
333- fixed fstab-hacking scripts
334
335* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
336- log newt, slang, ncurses info
337- updated man page
338- handle %% chars in issue.net properly (Heiko Schlittermann)
339- fixed serious NFS restore bug
340- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
341- changed various strcpy() calls to strncpy() calls
342- added mondo-makefilelist to makefile (Mikael Hultgren)
343- mount_cdrom() better at handling multiple CD drives
344- exclude /media/cdrom,cdrecorder,floppy
345- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
346- better logging by eval_call_to_make_ISO()
347- accept -J <fname> to let user provide their own fs catalog
348 instead of -I <paths> to backup
349- if dir excluded with -E or included with -I and dir is actually
350 a softlink then exclude/include the dir pointed to, as well
351- better location for manpage
352- adjusted block size of tarball at start of tape, to help
353 users w/ broken tape driver firmware
354- sort -u fstab after modifying it
355- if backup type is nfs then don't estimate noof media
356- fixed Makefile (Mikael Hultgren)
357- updated manpage
358
359* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
360- new devel branch opened
361
362* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
363- fixed bug in multithreading
364- use new grub-MR instead of grub-install
365- wipe only the partition table (not the MBR) when partitioning drives
366- ignore lilo.conf.anaconda when looking for lilo.conf file
367- accepts '-l RAW' to backup/restore original boot sector instead
368 of running grub or lilo to init it after restoring
369- fixed&updated stabgrub-me script; software RAID + GRUB work now
370- mount/unmount /boot partition for Gentoo 1.2 users
371- re-enabled extra tape checksums
372- disabled spurious warnings
373- unmount/remount supermounts at start/end of live restore, if nec.
374- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
375 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
376- added Makefile
377- added -l RAW, to backup and restore original MBR
378- cleaned up iso_mode() and nfs restoring
379- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
380- made mondorestore CD bootable for ArkLinux users
381- if user runs as 'su' not 'su -' then work around
382
383* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
384- pop-up list of changed files, at end of verification phase
385- better handling of changed.files list at restore-time
386- lots of CD-related fixes
387- added '-N' flag --- to let user exclude all NFS-related mounts&devices
388- better handling of 'kill'
389- restructuring of code to ease integration of mondo w/XMondo
390- fixed obscure bug in find_and_mount_actual_cd()
391- if / or /root has <50MB free then abort & complain
392- fixed install.sh
393- fixed .spec file
394- updated documentation
395- commented code
396- updated man page
397- added -v / --version flag
398- replace convoluted grep with wc (KP)
399- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
400- fixed BurnProof-related bug
401- better at figuring out which is the best partition for temp/scratchdir
402- added do-not-compress-these (text file) to RPM
403- do not compress files of types listed in do-not-compress-these
404- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
405- added Cosgrove's do-not-compress-these list
406- included various patches from KP
407- chmod tmpdir, scratchdir to 700 before using
408- restore from specified backup device, even if its own cfg file disagrees
409- fixed multi-tape bug
410- fixed "Can't find first ISO when verifying nonbootable ISO" bug
411- multithreaded make_afioballs_and_images()
412- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
413 command-line parameters or not
414- fixed bug in strip_spaces() which stopped it from handling
415 small strings correctly - affected mountlist editor
416- create a repaired copy of grub-install which is RAID-friendly;
417 use it when initializing boot sector with run_grub()
418- fixed bug in mondo-makefilelist
419
420* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
421- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
422- during selective restore, skip filesets which don't contain relevant archives
423- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
424- remove /var/run/*.pid after restoring
425- move spurious lockfiles from /home/* to /home/*/.disabled
426- ask user to confirm the tape/CD device name
427- lots of multitape-related fixes
428- added code to autodetect the hardware of the user, if possible
429- if isodir does not exist then abort
430- more sanity-checking for -d flag
431- doubled 'biggiefile' threshold... to 32MB
432- exclude /root/images/mindi
433- fixed multi-imagedev bug (Emmanuel Druon)
434- unmount/remount /mnt/floppy before/after backing up, if Mandrake
435- restructured the source files
436- fixed serious bug in line 1546 - should have been !=, not ==; stopped
437 mondorestore from correctly restoring big files
438- added '#include <signal.h>' to my-stuff.h
439- exclude "incheckentry xwait()" from changed.files
440- fixed minor bug in find_cdrom_device()
441- fixed bug in friendly_sizestr...
442- insist on tape #1 when start verifying
443- added internal buffering, replacing the external 'buffer' exe
444- if differential backup then don't permit formatting or fdisking,
445 whether Interactive or Nuke mode
446- if mondorestore is run on live filesystem (or from ramdisk) without
447 parameters then mondorestore will ask which backup media (tape, CD, etc.)
448 was used; it will read the config file from the media and proceed from there
449- if tape streamer is softlink then resolve it first
450- incorporate post-nuke tarball
451- if user doesn't specify tape size, proceed anyway; behave intelligently
452 in the event of end-of-tape
453- prefix bkpinfo->restore_path to biggiefile fname before generating
454 checksum & comparing to archived biggiefile
455- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
456 then create a softlink from the former to the latter, to work
457 around RH7.3's b0rken LILO support
458- LFS support (mharris, michele, hugo)
459- fixed verify bug --- CD#1 was being verified again & again & ...
460- differential mode fixed; supported again
461- ask user for boot loader + device if not detectible
462- list up to 512 files in file selection window at once (was 128)
463- better handling of bigfiles' checksums, perms and owns
464- delete final filelist if <=2 bytes long
465- if kernel not found and mondo in graphics mode then popup and ask
466 for kernel path+filename
467
468* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
469- 1.5x branch forked off from 1.4x branch
470
471
472
473
Note: See TracBrowser for help on using the repository browser.