source: MondoRescue/branches/2.0.9/mondo-doc/distributions/gentoo/mondo.ebuild@ 750

Last change on this file since 750 was 572, checked in by bcornec, 18 years ago

gentoo build continued
mindi bug found due to a previous bug corrected (5.6 MB disks generated systematically):

  • when a disk less than 2.8 MB can be built, not enough modules are put on it to support SCSI cds (use of FLOPPY_MODS only). I added most CDROMs modules in order to support them.
File size: 1.7 KB
Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7inherit libtool
8
9DESCRIPTION="The premier GPL disaster recovery solution."
10HOMEPAGE="http://www.mondorescue.org"
11SRC_URI="ftp://ftp.mondorecue.org/src/${PN/-rescue/}-${PV}.tgz"
12
13LICENSE="GPL-2"
14SLOT="0"
15KEYWORDS="-* ~x86"
16IUSE=""
17
18DEPEND="virtual/libc
19 >=sys-libs/slang-1.4.1
20 >=dev-libs/newt-0.50"
21RDEPEND="app-arch/afio
22 sys-block/buffer
23 sys-devel/binutils
24 >=app-arch/bzip2-0.9
25 app-cdr/cdrtools
26 >=sys-apps/mindi-1.0.7
27 >=dev-libs/newt-0.50
28 >=sys-libs/slang-1.4.1
29 >=sys-boot/syslinux-1.52"
30
31S=${WORKDIR}/${PN/-rescue/}-${PV}
32
33src_unpack() {
34 unpack ${A}
35 cd ${S}
36 chmod 750 configure
37}
38
39src_compile() {
40 elibtoolize
41 econf || die "Configuration failed"
42 emake || die "Make failed"
43 #make VERSION=VVV CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
44}
45
46src_install() {
47 #make install DESTDIR=${D} || die "make install failed"
48 einstall || die "Install failed"
49 exeinto /usr/share/mondo
50 doexe mondo/autorun
51}
52
53pkg_postinst() {
54 einfo "${P} was successfully installed."
55 einfo "Please read the associated docs for help."
56 einfo "Or visit the website @ ${HOMEPAGE}"
57 echo
58 ewarn "This package is still in unstable."
59 ewarn "Please report bugs to http://bugs.gentoo.org/"
60 ewarn "However, please do an advanced query to search for bugs"
61 ewarn "before reporting. This will keep down on duplicates."
62 echo
63 einfo "Prior to running mondo, ensure /boot is mounted."
64 ewarn "Grub users need to have a symlink like this:"
65 ewarn "ln -s /boot/grub/menu.lst /etc/grub.conf"
66 einfo "Unless you want to have mondo backup your distfiles,"
67 einfo "append \"-E ${DISTDIR}\" to your mondoarchive command."
68 echo
69}
Note: See TracBrowser for help on using the repository browser.