source: MondoRescue/branches/2.0.7/mindi/distributions/rpm/mindi.spec@ 455

Last change on this file since 455 was 455, checked in by bcornec, 18 years ago
  • Fix install pb for SuSE based distro around doc location (/usr/share/doc/packages)
  • Introduces Epoch for easier updates and Obsoleted packages (on Mandriva for now)
  • Property svn:keywords set to Id
File size: 1.8 KB
Line 
1#
2# $Id: mindi.spec 455 2006-04-02 14:34:36Z bcornec $
3#
4%define name mindi
5%define version VVV
6%define mrel RRR
7%define src SSS
8%define grp GRP
9%define addreqb bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools
10%define addreq DDD
11%define rel %{mrel}
12
13Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
14Name: %name
15Version: %version
16Release: %rel
17License: GPL
18Group: %{grp}
19Url: http://mondorescue.berlios.de
20Source: %{src}
21BuildRoot: %{_tmppath}/%{name}-%{version}
22Requires: %{addreq}
23Epoch: %(echo %%{mrel} | cut -d- -f1 | sed "s~M~~")
24# Not on all systems
25#Conflicts: bonnie++
26
27%description
28Mindi takes your kernel, modules, tools and libraries, and puts them on N
29bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
30and do system maintenance - e.g. format partitions, backup/restore data,
31verify packages, etc.
32
33%prep
34%{__rm} -rf $RPM_BUILD_ROOT
35%setup -n %name-%{version}
36
37%build
38%ifarch ia64
39%{__make} -f Makefile.parted2fdisk clean
40%{__make} -f Makefile.parted2fdisk
41%endif
42
43%install
44export DONT_RELINK=1
45
46%{__rm} -rf $RPM_BUILD_ROOT
47export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
48export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
49export RPMBUILDMINDI="true"
50
51./install.sh
52
53%clean
54%{__rm} -rf $RPM_BUILD_ROOT
55
56%post
57if [ -f /usr/local/sbin/mindi ]; then
58 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
59fi
60
61%files
62%defattr(644,root,root,755)
63%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
64%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
65%{_mandir}/man8/*
66%{_libdir}/mindi
67%attr(755,root,root) %{_sbindir}/*
68%attr(755,root,root) %{_libdir}/mindi/aux-tools/sbin/*
69%attr(755,root,root) %{_libdir}/mindi/rootfs/bin/*
70%attr(755,root,root) %{_libdir}/mindi/rootfs/sbin/*
71
72%changelog
Note: See TracBrowser for help on using the repository browser.