source: MondoRescue/trunk/mondo/mondo.spec@ 181

Last change on this file since 181 was 181, checked in by bcornec, 18 years ago

merge -r177:180 $SVN_M/branches/2.05

  • Property svn:keywords set to Id
File size: 18.3 KB
Line 
1#
2# $Id: mondo.spec 181 2005-12-13 00:35:27Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mondo
11%define version 2.04_berlios
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32
33Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
34Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
35Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
36Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
37<<<<<<< .working
38Name: mondo
39Version: 2.05_berlios
40Release: 1
41=======
42
43Name: %{name}
44Version: %{version}
45Release: %{mrel}
46>>>>>>> .merge-right.r54
47License: GPL
48Url: http://mondorescue.berlios.de
49Source: %{src}
50BuildRoot: %{_tmppath}/%{name}-%{version}
51BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
52%ifarch ia64
53Requires: mindi >= 1.04_berlios, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
54%else
55Requires: mindi >= 1.04_berlios, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, cdrecord, buffer
56%endif
57
58#%package %{name}-devel
59#Summary: Header files for building against Mondo
60#%if %is_mandrake
61#Group: Development/Libraries
62#%endif
63#if %is_redhat
64#Group: Development/Other
65#%endif
66#Provides: libmondo-devel mondo-devel
67#Obsoletes: libmondo-devel
68#
69#%description -n %{name}-devel
70#Mondo libraries and includes
71
72%description
73Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
74
75%description -l fr
76Objectif
77""""""""
78Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
79
80%description -l it
81Scopo
82"""""
83Mondo e' un programma che permette a qualsiasi utente Linux
84di creare un cd di rescue/restore (o piu' cd qualora l'installazione
85dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
86nastro, ed il NFS, anche.
87
88%description -l sp
89Objectivo
90"""""""""
91Mondo es un programa que permite cualquier usuario de Linux a crear una CD
92de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
93con cintas y NFS, tambien.
94
95%prep
96%setup -q -n %name-%{version}
97
98%build
99%configure
100%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
101
102%install
103%{__rm} -rf $RPM_BUILD_ROOT
104%makeinstall
105
106%post
107/sbin/ldconfig
108
109%postun
110/sbin/ldconfig
111
112%clean
113%{__rm} -rf $RPM_BUILD_ROOT
114
115%files
116%defattr(644,root,root,755)
117%doc ChangeLog mondo/docs/en/1.6x-howto/*
118%doc INSTALL COPYING README TODO AUTHORS NEWS
119
120%attr(755,root,root) %{_sbindir}/*
121%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}
122%{_libdir}/%{name}
123%{_mandir}/*
124%{_libdir}/*
125
126%changelog
127* Tue Oct 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.05_berlios
128- Memory management revision
129- use libdir instead of datadir
130
131* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
132- Merge of patches mentionned on mondo ML + ia64 updates
133- Option -p added
134
135* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
136- made mondo more clever about finding its home. Avoids mondo considering
137 directories like '/usr/share/doc/momdo' as its home.
138
139* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
140- test sanity of user-specified tempdir
141- better SLES8 support
142
143* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
144- instead of using 'dd' to erase partition table, delete existing
145 partitions w/ the same call to fdisk that is used to create the
146 new partitions; this should avoids locking up the partition table
147- set bootable partition in the above same call to fdisk, for
148 the same reason (avoids locking up the partition table)
149- better software RAID support
150- mount ext3 partitions as ext2 when restoring - better for Debian
151- better star, ACL support
152- added ACL, xattr support for afio users
153
154* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
155- fixed cvs for SuSE systems
156- fixed NTFS backup/restore bug relating to partimagehack
157 log file overflow and NTFS v non-NTFS differentiation
158- more reliable extraction of config info from CDs, floppies
159- better support of ISO dirs at restore-time (Conor Daly)
160- fixed spec file for SuSE users
161- added ldconfig to install section
162
163* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
164- first 2.0 release
165- updated grub-install.patched to support SuSE and Red Hat
166- call 'mt' to set block size to 32K before opening in/out tape
167- updated mondo-prep.c to create each disk's partitions all at once
168 (one call per drive) instead of one call to fdisk per partition
169- when extracting cfg file and mountlist from all.tar.gz (tape copy),
170 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
171- added star and rudimentary SELinux support
172- fixed lots of bugs
173- all logging now goes to /var/log/mondo-archive.log, with symlink
174 to /tmp/mondo-restore.log for restore-time log-tracking
175- added grub-install.patched
176- removed embleer & other binaries
177- added '-b' to specify block size
178- added '-R' for star support
179
180* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
181- ia64 fixes
182
183* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
184- fixed symbolic links for libraries
185- added support for boot/root multi floppies
186
187- added kdelibs as xmondo dependency
188- added xmondo pixmap installation
189- better find_cdrom_device(), to cope w/ multiple CD writers
190- fixed -m and -Vc flags
191- fixed NTFS support!
192- bootable CD uses native, not El Torito, support now
193- removed mondo-makefilelist
194- added 2.6 kernel support
195- if 2.6 kernel, insist that the user specify CD device
196- drop Embleer; insist on ms-sys and parted if Windows partition
197
198* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
199- added -devel package
200
201* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
202- made xmondo a second package
203- added ability to specify --without xmondo at build time
204
205* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
206- Clean up, added spanish translation
207- Set prefix to be /usr
208- added/fixed Requires
209- remove CVS directories prior to building
210
211* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
212- nothing yet
213
214* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
215- fixed chmod/chown bug (Jens Richter)
216- ask user to confirm NFS mountpoint in Interactive Mode
217- rewritten format_everything() to make sure LVMs, RAIDs and
218 regular partitions are prepped in the correct order
219- better magicdev support
220- rewritten external binary caller subroutine
221- DVD support added
222- better backup-time control gui; offer to exclude nfs if appl.
223- fixed multi-tape support
224- re-implemented -D and -J
225- fixed bug in extract_config_file_from_ramdisk() which
226 affected tape+floppy users
227- updated is_incoming_block_valid() to make it
228 return end-of-tape if >300 flotsam blocks
229- unmount CD-ROM before burning (necessary for RH8/9)
230- fixed some stray assert()'s
231- fixed bug in grub-MR (Christian)
232- make user remove floppy/CD before restoring interactively from tape
233- fixed bug in am_I_in_disaster_recovery_mode()
234- added code to nuke_mode() to make sure NFS
235 (backup) share is mounted in Nuke Mode
236- improved tape device detection code
237- better GRUB support
238- better logging of changed bigfiles at compare-time
239- better NTFS support, thanks to partimagehack-static
240- better logging
241- rewrote tape-handling code, breaking compatibility w/ previous versions
242- fixed ISO/CD biggiefile verification bug in mondoarchive
243- fixed bug which stopped boot/compare-time changelist from popping up
244- replaced mondo-makefilelist with C code - faster, cleaner
245- tweaked GUI - better feedback
246
247* Wed May 28 2003 Anonymous <root@rohan> 1.74
248- misc fixes (Michael Hanscho's friend)
249- added rudimentary support for SME
250- added better label support
251- fixed biggietime atime/ctime restoration bug 73
252- fixed 'default boot loader' detection bug (Joshua Oreman)
253- use single-threaded make_afioballs_and_images() if FreeBSD
254- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
255- superior get_phys_size_of_drive() (Joshua Oreman)
256- fixed RAID-related bug in where_is_root_mounted()
257- ISO tweaks
258- fixed silly bug in load_filelist() which stopped
259 funny German filenames from being handled properly
260- fixed various calls to popup_and_get_string()
261- fixed spec file
262- reject -E /
263- added partimagehack to the mix
264
265* Tue May 20 2003 Anonymous <root@rohan> 1.73
266- mark devices as bootable _after_ unmounting them
267- resolve boot device (-f) if softlink
268- post_param_configuration() --- store iso-dev and isodir
269- added post-nuke-sample.tgz to package
270- Nuke Mode now checks mountlist against hardware; offer user
271 opportunity to edit mountlist if insane; if user declines, abort
272- added lots of assert()'s and other checks
273- ran code thru Valgrind to catch & fix some memory leaks
274- made mondo-restore.c smaller by moving some subroutines to
275 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
276- added '-Q' to let user test mondoarchive's ability to find
277 their boot loader and type
278- improved which_boot_loader()
279- when burning or comparing to a CD, defeat autorun if it is
280 running, to avoid confusing mondoarchive and the user
281- if original backup media no longer available at boot-time
282 then offer user chance to choose another media source
283- when booting, type 'nuke noresize' to nuke w/o resizing
284 mountlist to fill your drives
285- add 'textonly' when booting, to avoid using Newt gui
286- run nice(20) to prioritize mondoarchive at start
287- don't pause and wait for next blank CD at backup-time
288 unless necessary (e.g. previous CD has not been removed)
289- get_phys_size_of_drive() --- better support of older drives
290- don't eject if "donteject" is in kernel's command line
291- cleaned up segfault-handling
292- added Conor's strip_path() to improve file list display
293- added Herman Kuster's multi-level bkp patch
294- better boot-time screen/message
295- added Joshua Oreman's FreeBSD patches x3
296- fixed interactive/textonly support
297- fixed support for subdir-within-NFS-mount
298- fixed "Can't backup if ramdisk not mounted" bug
299- try to work around eccentricities of multi-CD drive PCs
300- misc clean-ups (Steve Hindle)
301
302* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
303- LVM/RAID bugs fixed (Brian Borgeson)
304- major clean-up of code (Stan Benoit)
305- make-me-bootable fix (Juraj Ziegler)
306- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
307- removed duplicate entry from makefile
308- if root is /dev/root then assume not a ramdisk
309- reject relative paths if -d flag (Alessandro Polverini)
310- fixed potentially infinite loop in log_to_screen (Tom Mortell)
311- add '/' to custom filelist as workaround for obscure bug
312- ask user speed of CDRW if writing to CD
313- find_cdrom_device() --- if nonexistent/not found then
314 make sure to return '' as dev str and 1 as res
315- tweaked restore scripts tgz
316- cleaned up find_cdrom_device()
317- if user creates /usr/share/mondo/payload.tgz then untar
318 payload to CD at backup-time
319- fixed insist_on_this_cd_number()
320- fixed am_i_in_disaster_recovery_mode()
321- misc clean-up (Tom Mortell)
322- made code more legible
323- fixed post-nuke support
324- added -e support
325- fixed nfs support
326- fixed iso support
327- at restore-time, only sort mountlist internally,
328 in mount_all_devices() and unmount_all_devices()
329- fixed cosmetic bug in label-partitions-as-necessary
330- updated documentation
331- fixed fstab-hacking scripts
332
333* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
334- log newt, slang, ncurses info
335- updated man page
336- handle %% chars in issue.net properly (Heiko Schlittermann)
337- fixed serious NFS restore bug
338- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
339- changed various strcpy() calls to strncpy() calls
340- added mondo-makefilelist to makefile (Mikael Hultgren)
341- mount_cdrom() better at handling multiple CD drives
342- exclude /media/cdrom,cdrecorder,floppy
343- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
344- better logging by eval_call_to_make_ISO()
345- accept -J <fname> to let user provide their own fs catalog
346 instead of -I <paths> to backup
347- if dir excluded with -E or included with -I and dir is actually
348 a softlink then exclude/include the dir pointed to, as well
349- better location for manpage
350- adjusted block size of tarball at start of tape, to help
351 users w/ broken tape driver firmware
352- sort -u fstab after modifying it
353- if backup type is nfs then don't estimate noof media
354- fixed Makefile (Mikael Hultgren)
355- updated manpage
356
357* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
358- new devel branch opened
359
360* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
361- fixed bug in multithreading
362- use new grub-MR instead of grub-install
363- wipe only the partition table (not the MBR) when partitioning drives
364- ignore lilo.conf.anaconda when looking for lilo.conf file
365- accepts '-l RAW' to backup/restore original boot sector instead
366 of running grub or lilo to init it after restoring
367- fixed&updated stabgrub-me script; software RAID + GRUB work now
368- mount/unmount /boot partition for Gentoo 1.2 users
369- re-enabled extra tape checksums
370- disabled spurious warnings
371- unmount/remount supermounts at start/end of live restore, if nec.
372- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
373 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
374- added Makefile
375- added -l RAW, to backup and restore original MBR
376- cleaned up iso_mode() and nfs restoring
377- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
378- made mondorestore CD bootable for ArkLinux users
379- if user runs as 'su' not 'su -' then work around
380
381* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
382- pop-up list of changed files, at end of verification phase
383- better handling of changed.files list at restore-time
384- lots of CD-related fixes
385- added '-N' flag --- to let user exclude all NFS-related mounts&devices
386- better handling of 'kill'
387- restructuring of code to ease integration of mondo w/XMondo
388- fixed obscure bug in find_and_mount_actual_cd()
389- if / or /root has <50MB free then abort & complain
390- fixed install.sh
391- fixed .spec file
392- updated documentation
393- commented code
394- updated man page
395- added -v / --version flag
396- replace convoluted grep with wc (KP)
397- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
398- fixed BurnProof-related bug
399- better at figuring out which is the best partition for temp/scratchdir
400- added do-not-compress-these (text file) to RPM
401- do not compress files of types listed in do-not-compress-these
402- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
403- added Cosgrove's do-not-compress-these list
404- included various patches from KP
405- chmod tmpdir, scratchdir to 700 before using
406- restore from specified backup device, even if its own cfg file disagrees
407- fixed multi-tape bug
408- fixed "Can't find first ISO when verifying nonbootable ISO" bug
409- multithreaded make_afioballs_and_images()
410- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
411 command-line parameters or not
412- fixed bug in strip_spaces() which stopped it from handling
413 small strings correctly - affected mountlist editor
414- create a repaired copy of grub-install which is RAID-friendly;
415 use it when initializing boot sector with run_grub()
416- fixed bug in mondo-makefilelist
417
418* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
419- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
420- during selective restore, skip filesets which don't contain relevant archives
421- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
422- remove /var/run/*.pid after restoring
423- move spurious lockfiles from /home/* to /home/*/.disabled
424- ask user to confirm the tape/CD device name
425- lots of multitape-related fixes
426- added code to autodetect the hardware of the user, if possible
427- if isodir does not exist then abort
428- more sanity-checking for -d flag
429- doubled 'biggiefile' threshold... to 32MB
430- exclude /root/images/mindi
431- fixed multi-imagedev bug (Emmanuel Druon)
432- unmount/remount /mnt/floppy before/after backing up, if Mandrake
433- restructured the source files
434- fixed serious bug in line 1546 - should have been !=, not ==; stopped
435 mondorestore from correctly restoring big files
436- added '#include <signal.h>' to my-stuff.h
437- exclude "incheckentry xwait()" from changed.files
438- fixed minor bug in find_cdrom_device()
439- fixed bug in friendly_sizestr...
440- insist on tape #1 when start verifying
441- added internal buffering, replacing the external 'buffer' exe
442- if differential backup then don't permit formatting or fdisking,
443 whether Interactive or Nuke mode
444- if mondorestore is run on live filesystem (or from ramdisk) without
445 parameters then mondorestore will ask which backup media (tape, CD, etc.)
446 was used; it will read the config file from the media and proceed from there
447- if tape streamer is softlink then resolve it first
448- incorporate post-nuke tarball
449- if user doesn't specify tape size, proceed anyway; behave intelligently
450 in the event of end-of-tape
451- prefix bkpinfo->restore_path to biggiefile fname before generating
452 checksum & comparing to archived biggiefile
453- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
454 then create a softlink from the former to the latter, to work
455 around RH7.3's b0rken LILO support
456- LFS support (mharris, michele, hugo)
457- fixed verify bug --- CD#1 was being verified again & again & ...
458- differential mode fixed; supported again
459- ask user for boot loader + device if not detectible
460- list up to 512 files in file selection window at once (was 128)
461- better handling of bigfiles' checksums, perms and owns
462- delete final filelist if <=2 bytes long
463- if kernel not found and mondo in graphics mode then popup and ask
464 for kernel path+filename
465
466* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
467- 1.5x branch forked off from 1.4x branch
468
469
470
471
Note: See TracBrowser for help on using the repository browser.