source: MondoRescue/trunk/mindi/mindi.spec@ 8

Last change on this file since 8 was 8, checked in by bcornec, 19 years ago

Handles http://qa.mandriva.com/show_bug.cgi?id=16862

File size: 11.5 KB
Line 
1%define _prefix /usr
2Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
3Name: mindi
4Version: 1.04_cvs_20050503
5Release: 1
6License: GPL
7Group: System/Kernel and hardware
8Url: http://www.mondorescue.org
9Source: %{name}-%{version}.tgz
10BuildRoot: %{_tmppath}/%{name}-%{version}
11Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk
12Conflicts: bonnie++
13Prefix: %{_prefix}
14Autoreq: 0
15
16%description
17Mindi takes your kernel, modules, tools and libraries, and puts them on N
18bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
19and do system maintenance - e.g. format partitions, backup/restore data,
20verify packages, etc.
21
22%prep
23%setup
24
25%build
26%ifarch ia64
27make -f Makefile.parted2fdisk clean
28make -f Makefile.parted2fdisk
29%endif
30
31%install
32%{__rm} -Rf /usr/local/share/mindi
33%{__rm} -rf $RPM_BUILD_ROOT
34MINDIDIR=$RPM_BUILD_ROOT%{_datadir}/mindi
35%{__mkdir_p} $MINDIDIR $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_sysconfdir}/mindi
36%{__mv} deplist.txt $RPM_BUILD_ROOT%{_sysconfdir}/mindi/
37%{__cp} -af * $MINDIDIR
38%ifarch ia64
39 make -f Makefile.parted2fdisk DEST=${MINDIDIR}/ install
40 %{__mv} $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/bin/busybox
41 %{__mv} $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk
42%else
43 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox
44 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386.net $MINDIDIR/rootfs/bin/busybox.net
45 %{__ln_s} fdisk $MINDIDIR/rootfs/sbin/parted2fdisk
46%endif
47%{__rm} -f $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox-i386.net
48#
49# These are installed twice if not removed here
50( cd $MINDIDIR
51%{__rm} -f CHANGES INSTALL COPYING README TODO README.ia64
52)
53cd $RPM_BUILD_ROOT%{_bindir}
54%{__ln_s} -f %{_datadir}/mindi/mindi .
55%{__ln_s} -f %{_datadir}/mindi/parted2fdisk.pl .
56%{__ln_s} -f %{_datadir}/mindi/analyze-my-lvm .
57chmod +x $MINDIDIR/mindi
58
59%clean
60%{__rm} -rf $RPM_BUILD_ROOT
61
62%post
63%ifarch ia64
64 %{__mkdir_p} /usr/local/bin
65 if [ "`file /sbin/fdisk |grep 'LF 64-bit LSB executable'`" ] ; then
66 %{__cp} /sbin/fdisk /sbin/fdisk.mondosav
67 %{__mv} /sbin/fdisk /usr/local/bin/fdisk
68 %{__ln_s} -f /usr/share/mindi/parted2fdisk.pl /sbin/fdisk
69 echo "Warning: you fdisk binary is now under /usr/local/bin"
70 fi
71%endif
72
73%files
74%defattr(-,root,root,-)
75%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
76%doc CHANGES INSTALL COPYING README TODO README.ia64
77#%attr(755,root,root) %{_datadir}/mindi/mindi
78
79%{_datadir}/mindi
80%{_bindir}/analyze-my-lvm
81%{_bindir}/mindi
82%{_bindir}/parted2fdisk.pl
83
84%changelog
85* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
86- supports exec-shield
87
88* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
89- better support of SLES 8
90
91* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
92- better kernel-level logging
93- added ACL, xattr binaries to deplist.txt
94- fixed obscure bug which occasionally stopped mindi from correctly finding
95 and documenting all LVM2 LVM-on-RAID volumes
96
97* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
98- added ide_tape and other modules to mindi's config detection
99- unmount errant ramdisk ($mtpt) if fail to create boot floppy
100- better support of ISO dirs at restore-time (Conor Daly)
101
102* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
103- first 1.0x release
104- busybox now static
105- trap Ctrl-Alt-Del; trigger soft reset
106- better SuSE 9.1 support
107- added parted2fdisk.pl (IA64) (Bruno Cornec)
108- add LVM2 support for kernel 2.6 (Takeru Komoriya)
109- better detection of multiple Mindis (Martin Fürstenau)
110- don't complain if just a Mindi boot CD & not a platform for Mondo
111- updated busybox to 1.0.0pre10
112- removed uClibc
113- add memtest support
114- 2.6 kernel support
115- removed Embleer files (Andree Leidenfrost)
116- added kernel-only floppy support, to accommodate really big kernels
117- updated+rebuilt busybox
118- added star support
119- mount /sys at boot-time
120- better 64-bit and 2.6 kernel support
121- better LVM, failsafe kernel support (Jim Richard)
122- use LILO, not raw kernel, on 1.4MB boot floppy
123- record names of unsaved modules, for future reference
124- enlarged ramdisk by 8MB
125
126* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
127- changed some '==' to '=' --- now more RH6-friendly
128- allow absolute pathnames again in deplist
129- disable multifunc cd thing
130- better Gentoo support (Bill)
131- better OnStream support
132- better Slackware support (Laurenz)
133- added partimagehack-static to deplist.txt
134- recompiled Busybox - now 10k smaller; better stack-handling
135- fixed boot screen typo
136- added support for 'auto' fs format
137- better devfs support for Mandrake users
138- better Debian+LVM support (Ralph Grewe)
139- updated analyze-my-lvm to handle floating-point gigabyte -L values
140
141* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
142- altered rootfs's /dev entry to stop cvs from becoming confused
143- tweaked MAX_COMPRESSED_SIZE
144- added multi-function CD support to mindi and sbin/post-init
145- re-mount root as rw just in case
146- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
147- added support for 5th column in mountlist.txt for labels
148- added symlinks.tgz
149- suppress erroneous error msgs re: failsafe kernel
150
151* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
152- added cciss.o to SCSI_MODS
153- if format type is (e.g.) ext3,ext2 then use 1st entry
154- re-enabled fsck*
155- if cciss in use the enable it at boot-time
156- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
157- better ISO support
158- tweaked Mindi to use 10-15% fewer floppies
159- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
160 to be run by Mindi before it bootstraps to aux data disks;
161 e.g. 'echo engage > /proc/scsi/something'
162- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
163 to be run by Mindi after it boots but before it runs mondorestore
164- allow for Debian & other Stiefkinder that use 'none', not 'swap'
165 as the mountpoint of the swap partition
166- removed afio dependency
167- re-worked install.sh and tarball not to use tgz's
168- cleared up the boot msg
169- updated busybox to 0.60.5; updated uClibc to 0.9.19
170- add #!/bin/sh to start of insert-all-my-modules
171- fixed obscure bug in install-additional-tools
172- changed grep -m to grep | head -n1 for Debian users
173- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
174
175* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
176- fixed LVM/RAID bugs (Brian Borgeson)
177- if bad lilo, give more verbose error before quitting
178- added mt and perl to deplist.txt
179- insist on gawk being present
180- insmod ide-cd, cdrom, isofs, just in case
181- boot-time tmpfs ramdisk is now 40m (was 34m)
182- cleaned up logs
183- iso mode now calls Interactive
184- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
185- clean up some calls to grep, esp. partition_mountpt=...
186- corrected some bashisms, to suit Debian ped- er, users
187- made first line refer to bash, not sh, to make sure
188 the Debian people know Mindi requires bash, not hs
189- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
190- disabled code which would have made Mindi use sfdisk instead of fdisk
191 if it looked as if Debian's fdisk would misbehave
192
193* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
194- new devel branch
195- EXTRA_SPACE=16384
196- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
197- patched analyze-my-lvm (Benjamin Mampaey)
198- detect built-in boot.b files in lilo
199- cleaned up spec file a bit, more use of macros (Jesse Keating)
200- return w/err, don't abort, if Matt Nelson's RH8 system is farked
201- better at finding isolinux.bin
202- better at analyzing dependencies when running on broken distributions
203- try harder to boot from CD, even if tape fails
204- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
205- better resolution of relative softlinks, leading to fewer
206 duplicates on data disks and therefore fewer data disks
207- detect Debian+devfs; use sfdisk instead of fdisk in that
208 eventuality, to work around yet another of Debian's warts
209- removed /lib/libuuid.* from rootfs.tgz
210- fixed vi
211- mindi now uses gawk --traditional (making gawk behave in a functionally
212 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
213- removed / from list of dirs accessed when trying to resolve deplist entry
214- spinner bugfix; handle odd LABELs properly (Tom Mortell)
215- fixed LVM/RAID bugs (Brian Borgeson)
216
217* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
218- misc code clean-up
219- save boot device's boot sector
220- detect and beware Compaq diagnostic partitions
221- better handling of devfs V non-devfs kernels and boot devs
222- trimmed busybox 0.60.3 binary on boot disk
223- mindi now resides in /usr/local/bin
224- removed lilo from dependencies
225- more Gentoo-friendly
226
227* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
228- if your kernel's builddate doesn't match any of the kernels in
229 your /boot directory then fudge the issue & find the closest
230 match (*grumble* Debian)
231- scan tape & CD at start, to force inclusion of modules on boot device
232- double EXTRA_SPACE if >7 disks
233- slimmer, more lithesome logfile
234- now accepts --findkernel
235- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
236- better handling of non-Linux partitions on DevFS-enabled kernels
237- misc clean-ups
238- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
239- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
240- updated kernel to 2.4.18-mdk6
241- generate mountlist in dev-abetical order ;)
242- fixed minor bug in .spec file
243- better at finding /boot/boot.b if your distro breaks the de facto standard
244- fixed minor bug in MakeMountlist
245- fixed install.sh
246- cleaned up deplist.txt
247- added rudimentary -v / --version flag
248- line 1180 or so --- duplicate mindi.iso entries --- fixed
249- added /bin/[ - a softlink to /bin/sh
250- ListAllPartitions() - sanity fix (KP)
251- fixed .spec bug
252- better feedback
253- added Markus's RAID patch
254- ListAllPartitions() - include /mnt/win* (Hugo)
255
256* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
257- better logging by dependency-calculating code
258- better handling of dependencies, specifically softlinks
259- if called by mondo then use mondo's temp dir as our temp dir too
260- changed gawk to $AWK in a few places, to allow for Debian
261- added host* config files to deplist
262- added tftp, ifconfig to busybox
263- added RPC support to uClibc
264- cleaned up creation of Mondo-Mindi configuration file
265- fixed bug in TryToFindKernelPath which stopped it from handling
266 multiple, same-version kernels gracefully
267- cleaned up deplist.txt
268- receive 'DIFFERENTIAL' variable from Mondo
269- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
270- better devfs support; call fgrep in places instead of grep (Andrew Korn)
271- fixed analyze-my-lvm (Ralph Gruwe)
272- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
273- added x11-tools.tgz option
274- updated /dev/console and /dev/tty0 (Paul Stevens)
275- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
276- catch sigint, sighup, etc.
277- fixed LILO-related message.txt mistake
278- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
279- better devfs support (Andrew Korn)
280
281* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
282- fixed RH7.3 readonly bug
283- improved nfs config file creation
284- search more locations for isolinux.bin
285- added isonuke option
286- faster data disk creation
287- better DevFS support (Hector Alvarez, DuckX)
288- nfs-related fix (Hans Lie)
289- abort if vfat filesystem present but mkfs.vfat missing
290- removed softlink to pico
291- allow Mondo to say no compression will be used
292- added [ to ramdisk
293- tar data disks with -b [block size] of 32k
294- don't autoboot to 'RESTORE' screen - it's scary!
295- let user choose lilo or syslinux as boot loader
296- added syslinux support
297- cleaned up message screens
298
Note: See TracBrowser for help on using the repository browser.