source: MondoRescue/trunk/mindi/mindi.spec@ 219

Last change on this file since 219 was 219, checked in by bcornec, 18 years ago

merge -r176:218 $SVN_M/branches/2.05

  • Property svn:keywords set to Id
File size: 11.8 KB
Line 
1#
2# $Id: mindi.spec 219 2005-12-15 01:54:19Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mindi
11%define version 1.04_berlios
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
33Name: %name
34Version: %version
35Release: %mrel
36License: GPL
37Group: System/Kernel and hardware
38Url: http://mondorescue.berlios.de
39Source: %{src}
40BuildRoot: %{_tmppath}/%{name}-%{version}
41Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools, afio, which
42# Not on all systems
43#Conflicts: bonnie++
44
45%description
46Mindi takes your kernel, modules, tools and libraries, and puts them on N
47bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
48and do system maintenance - e.g. format partitions, backup/restore data,
49verify packages, etc.
50
51%prep
52%{__rm} -rf $RPM_BUILD_ROOT
53%setup -n %name-%{version}
54
55%build
56%ifarch ia64
57%{__make} -f Makefile.parted2fdisk clean
58%{__make} -f Makefile.parted2fdisk
59%endif
60
61%install
62export DONT_RELINK=1
63
64%{__rm} -rf $RPM_BUILD_ROOT
65MINDIDIR=$RPM_BUILD_ROOT%{_libdir}/mindi
66export PREFIX=${RPM_BUILD_ROOT}
67export RPMBUILDMINDI="true"
68
69./install.sh
70
71%{__rm} -f $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox-i386.net
72
73%clean
74%{__rm} -rf $RPM_BUILD_ROOT
75
76%post
77%{__chmod} 755 %{_libdir}/mindi/aux-tools/sbin/* %{_libdir}/mindi/rootfs/bin/* %{_libdir}/mindi/rootfs/sbin/*
78if [ -f /usr/local/sbin/mindi ]; then
79 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
80fi
81
82%files
83%defattr(644,root,root,755)
84%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
85%doc CHANGES INSTALL COPYING README TODO README.ia64 README.pxe README.busybox
86%{_mandir}
87%{_libdir}/mindi
88#%attr(755,root,root) %{_libdir}/mindi/aux-tools/sbin/*
89#%attr(755,root,root) %{_libdir}/mindi/rootfs/bin/*
90#%attr(755,root,root) %{_libdir}/mindi/rootfs/sbin/*
91%attr(755,root,root) %{_sbindir}/*
92
93%changelog
94* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
95- ia64 is now working
96- use install.sh script
97- use libdir for binary data
98
99* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
100- Merge of patches mentionned on mondo ML + ia64 updates
101- Fix bugs when called alone
102
103* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
104- supports exec-shield
105
106* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
107- better support of SLES 8
108
109* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
110- better kernel-level logging
111- added ACL, xattr binaries to deplist.txt
112- fixed obscure bug which occasionally stopped mindi from correctly finding
113 and documenting all LVM2 LVM-on-RAID volumes
114
115* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
116- added ide_tape and other modules to mindi's config detection
117- unmount errant ramdisk ($mtpt) if fail to create boot floppy
118- better support of ISO dirs at restore-time (Conor Daly)
119
120* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
121- first 1.0x release
122- busybox now static
123- trap Ctrl-Alt-Del; trigger soft reset
124- better SuSE 9.1 support
125- added parted2fdisk.pl (IA64) (Bruno Cornec)
126- add LVM2 support for kernel 2.6 (Takeru Komoriya)
127- better detection of multiple Mindis (Martin Fürstenau)
128- don't complain if just a Mindi boot CD & not a platform for Mondo
129- updated busybox to 1.0.0pre10
130- removed uClibc
131- add memtest support
132- 2.6 kernel support
133- removed Embleer files (Andree Leidenfrost)
134- added kernel-only floppy support, to accommodate really big kernels
135- updated+rebuilt busybox
136- added star support
137- mount /sys at boot-time
138- better 64-bit and 2.6 kernel support
139- better LVM, failsafe kernel support (Jim Richard)
140- use LILO, not raw kernel, on 1.4MB boot floppy
141- record names of unsaved modules, for future reference
142- enlarged ramdisk by 8MB
143
144* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
145- changed some '==' to '=' --- now more RH6-friendly
146- allow absolute pathnames again in deplist
147- disable multifunc cd thing
148- better Gentoo support (Bill)
149- better OnStream support
150- better Slackware support (Laurenz)
151- added partimagehack-static to deplist.txt
152- recompiled Busybox - now 10k smaller; better stack-handling
153- fixed boot screen typo
154- added support for 'auto' fs format
155- better devfs support for Mandrake users
156- better Debian+LVM support (Ralph Grewe)
157- updated analyze-my-lvm to handle floating-point gigabyte -L values
158
159* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
160- altered rootfs's /dev entry to stop cvs from becoming confused
161- tweaked MAX_COMPRESSED_SIZE
162- added multi-function CD support to mindi and sbin/post-init
163- re-mount root as rw just in case
164- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
165- added support for 5th column in mountlist.txt for labels
166- added symlinks.tgz
167- suppress erroneous error msgs re: failsafe kernel
168
169* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
170- added cciss.o to SCSI_MODS
171- if format type is (e.g.) ext3,ext2 then use 1st entry
172- re-enabled fsck*
173- if cciss in use the enable it at boot-time
174- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
175- better ISO support
176- tweaked Mindi to use 10-15% fewer floppies
177- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
178 to be run by Mindi before it bootstraps to aux data disks;
179 e.g. 'echo engage > /proc/scsi/something'
180- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
181 to be run by Mindi after it boots but before it runs mondorestore
182- allow for Debian & other Stiefkinder that use 'none', not 'swap'
183 as the mountpoint of the swap partition
184- removed afio dependency
185- re-worked install.sh and tarball not to use tgz's
186- cleared up the boot msg
187- updated busybox to 0.60.5; updated uClibc to 0.9.19
188- add #!/bin/sh to start of insert-all-my-modules
189- fixed obscure bug in install-additional-tools
190- changed grep -m to grep | head -n1 for Debian users
191- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
192
193* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
194- fixed LVM/RAID bugs (Brian Borgeson)
195- if bad lilo, give more verbose error before quitting
196- added mt and perl to deplist.txt
197- insist on gawk being present
198- insmod ide-cd, cdrom, isofs, just in case
199- boot-time tmpfs ramdisk is now 40m (was 34m)
200- cleaned up logs
201- iso mode now calls Interactive
202- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
203- clean up some calls to grep, esp. partition_mountpt=...
204- corrected some bashisms, to suit Debian ped- er, users
205- made first line refer to bash, not sh, to make sure
206 the Debian people know Mindi requires bash, not hs
207- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
208- disabled code which would have made Mindi use sfdisk instead of fdisk
209 if it looked as if Debian's fdisk would misbehave
210
211* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
212- new devel branch
213- EXTRA_SPACE=16384
214- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
215- patched analyze-my-lvm (Benjamin Mampaey)
216- detect built-in boot.b files in lilo
217- cleaned up spec file a bit, more use of macros (Jesse Keating)
218- return w/err, don't abort, if Matt Nelson's RH8 system is farked
219- better at finding isolinux.bin
220- better at analyzing dependencies when running on broken distributions
221- try harder to boot from CD, even if tape fails
222- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
223- better resolution of relative softlinks, leading to fewer
224 duplicates on data disks and therefore fewer data disks
225- detect Debian+devfs; use sfdisk instead of fdisk in that
226 eventuality, to work around yet another of Debian's warts
227- removed /lib/libuuid.* from rootfs.tgz
228- fixed vi
229- mindi now uses gawk --traditional (making gawk behave in a functionally
230 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
231- removed / from list of dirs accessed when trying to resolve deplist entry
232- spinner bugfix; handle odd LABELs properly (Tom Mortell)
233- fixed LVM/RAID bugs (Brian Borgeson)
234
235* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
236- misc code clean-up
237- save boot device's boot sector
238- detect and beware Compaq diagnostic partitions
239- better handling of devfs V non-devfs kernels and boot devs
240- trimmed busybox 0.60.3 binary on boot disk
241- mindi now resides in /usr/local/bin
242- removed lilo from dependencies
243- more Gentoo-friendly
244
245* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
246- if your kernel's builddate doesn't match any of the kernels in
247 your /boot directory then fudge the issue & find the closest
248 match (*grumble* Debian)
249- scan tape & CD at start, to force inclusion of modules on boot device
250- double EXTRA_SPACE if >7 disks
251- slimmer, more lithesome logfile
252- now accepts --findkernel
253- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
254- better handling of non-Linux partitions on DevFS-enabled kernels
255- misc clean-ups
256- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
257- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
258- updated kernel to 2.4.18-mdk6
259- generate mountlist in dev-abetical order ;)
260- fixed minor bug in .spec file
261- better at finding /boot/boot.b if your distro breaks the de facto standard
262- fixed minor bug in MakeMountlist
263- fixed install.sh
264- cleaned up deplist.txt
265- added rudimentary -v / --version flag
266- line 1180 or so --- duplicate mindi.iso entries --- fixed
267- added /bin/[ - a softlink to /bin/sh
268- ListAllPartitions() - sanity fix (KP)
269- fixed .spec bug
270- better feedback
271- added Markus's RAID patch
272- ListAllPartitions() - include /mnt/win* (Hugo)
273
274* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
275- better logging by dependency-calculating code
276- better handling of dependencies, specifically softlinks
277- if called by mondo then use mondo's temp dir as our temp dir too
278- changed gawk to $AWK in a few places, to allow for Debian
279- added host* config files to deplist
280- added tftp, ifconfig to busybox
281- added RPC support to uClibc
282- cleaned up creation of Mondo-Mindi configuration file
283- fixed bug in TryToFindKernelPath which stopped it from handling
284 multiple, same-version kernels gracefully
285- cleaned up deplist.txt
286- receive 'DIFFERENTIAL' variable from Mondo
287- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
288- better devfs support; call fgrep in places instead of grep (Andrew Korn)
289- fixed analyze-my-lvm (Ralph Gruwe)
290- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
291- added x11-tools.tgz option
292- updated /dev/console and /dev/tty0 (Paul Stevens)
293- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
294- catch sigint, sighup, etc.
295- fixed LILO-related message.txt mistake
296- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
297- better devfs support (Andrew Korn)
298
299* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
300- fixed RH7.3 readonly bug
301- improved nfs config file creation
302- search more locations for isolinux.bin
303- added isonuke option
304- faster data disk creation
305- better DevFS support (Hector Alvarez, DuckX)
306- nfs-related fix (Hans Lie)
307- abort if vfat filesystem present but mkfs.vfat missing
308- removed softlink to pico
309- allow Mondo to say no compression will be used
310- added [ to ramdisk
311- tar data disks with -b [block size] of 32k
312- don't autoboot to 'RESTORE' screen - it's scary!
313- let user choose lilo or syslinux as boot loader
314- added syslinux support
315- cleaned up message screens
316
Note: See TracBrowser for help on using the repository browser.