source: MondoRescue/trunk/mindi/mindi.spec@ 20

Last change on this file since 20 was 20, checked in by bcornec, 19 years ago

-p option added

File size: 11.7 KB
Line 
1%define _prefix /usr
2Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
3Name: mindi
4Version: 1.04_berlios
5Release: 1
6License: GPL
7Group: System/Kernel and hardware
8Url: http://www.mondorescue.org
9Source: %{name}-%{version}.tgz
10BuildRoot: %{_tmppath}/%{name}-%{version}
11Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools
12# Not on all systems
13#Conflicts: bonnie++
14Prefix: %{_prefix}
15Autoreq: 0
16
17%description
18Mindi takes your kernel, modules, tools and libraries, and puts them on N
19bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
20and do system maintenance - e.g. format partitions, backup/restore data,
21verify packages, etc.
22
23%prep
24%setup
25
26%build
27%ifarch ia64
28make -f Makefile.parted2fdisk clean
29make -f Makefile.parted2fdisk
30%endif
31
32%install
33%{__rm} -Rf /usr/local/share/mindi
34%{__rm} -rf $RPM_BUILD_ROOT
35MINDIDIR=$RPM_BUILD_ROOT%{_datadir}/mindi
36%{__mkdir_p} $MINDIDIR $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_sysconfdir}/mindi
37%{__mv} deplist.txt $RPM_BUILD_ROOT%{_sysconfdir}/mindi/
38%{__cp} -af * $MINDIDIR
39%ifarch ia64
40 make -f Makefile.parted2fdisk DEST=${MINDIDIR}/ install
41 %{__mv} $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/bin/busybox
42 %{__mv} $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk
43%else
44 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox
45 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386.net $MINDIDIR/rootfs/bin/busybox.net
46 %{__ln_s} fdisk $MINDIDIR/rootfs/sbin/parted2fdisk
47%endif
48%{__rm} -f $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox-i386.net
49#
50# These are installed twice if not removed here
51( cd $MINDIDIR
52%{__rm} -f CHANGES INSTALL COPYING README TODO README.ia64 README.pxe
53)
54cd $RPM_BUILD_ROOT%{_bindir}
55%{__ln_s} -f %{_datadir}/mindi/mindi .
56%{__ln_s} -f %{_datadir}/mindi/parted2fdisk.pl .
57%{__ln_s} -f %{_datadir}/mindi/analyze-my-lvm .
58chmod +x $MINDIDIR/mindi
59
60%clean
61%{__rm} -rf $RPM_BUILD_ROOT
62
63%post
64%ifarch ia64
65 %{__mkdir_p} /usr/local/bin
66 if [ "`file /sbin/fdisk |grep 'LF 64-bit LSB executable'`" ] ; then
67 %{__cp} /sbin/fdisk /sbin/fdisk.mondosav
68 %{__mv} /sbin/fdisk /usr/local/bin/fdisk
69 %{__ln_s} -f /usr/share/mindi/parted2fdisk.pl /sbin/fdisk
70 echo "Warning: you fdisk binary is now under /usr/local/bin"
71 fi
72%endif
73
74%files
75%defattr(-,root,root,-)
76%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
77%doc CHANGES INSTALL COPYING README TODO README.ia64 README.pxe
78#%attr(755,root,root) %{_datadir}/mindi/mindi
79
80%{_datadir}/mindi
81%{_bindir}/analyze-my-lvm
82%{_bindir}/mindi
83%{_bindir}/parted2fdisk.pl
84
85%changelog
86* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
87- Merge of patches mentionned on mondo ML + ia64 updates
88
89* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
90- supports exec-shield
91
92* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
93- better support of SLES 8
94
95* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
96- better kernel-level logging
97- added ACL, xattr binaries to deplist.txt
98- fixed obscure bug which occasionally stopped mindi from correctly finding
99 and documenting all LVM2 LVM-on-RAID volumes
100
101* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
102- added ide_tape and other modules to mindi's config detection
103- unmount errant ramdisk ($mtpt) if fail to create boot floppy
104- better support of ISO dirs at restore-time (Conor Daly)
105
106* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
107- first 1.0x release
108- busybox now static
109- trap Ctrl-Alt-Del; trigger soft reset
110- better SuSE 9.1 support
111- added parted2fdisk.pl (IA64) (Bruno Cornec)
112- add LVM2 support for kernel 2.6 (Takeru Komoriya)
113- better detection of multiple Mindis (Martin Fürstenau)
114- don't complain if just a Mindi boot CD & not a platform for Mondo
115- updated busybox to 1.0.0pre10
116- removed uClibc
117- add memtest support
118- 2.6 kernel support
119- removed Embleer files (Andree Leidenfrost)
120- added kernel-only floppy support, to accommodate really big kernels
121- updated+rebuilt busybox
122- added star support
123- mount /sys at boot-time
124- better 64-bit and 2.6 kernel support
125- better LVM, failsafe kernel support (Jim Richard)
126- use LILO, not raw kernel, on 1.4MB boot floppy
127- record names of unsaved modules, for future reference
128- enlarged ramdisk by 8MB
129
130* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
131- changed some '==' to '=' --- now more RH6-friendly
132- allow absolute pathnames again in deplist
133- disable multifunc cd thing
134- better Gentoo support (Bill)
135- better OnStream support
136- better Slackware support (Laurenz)
137- added partimagehack-static to deplist.txt
138- recompiled Busybox - now 10k smaller; better stack-handling
139- fixed boot screen typo
140- added support for 'auto' fs format
141- better devfs support for Mandrake users
142- better Debian+LVM support (Ralph Grewe)
143- updated analyze-my-lvm to handle floating-point gigabyte -L values
144
145* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
146- altered rootfs's /dev entry to stop cvs from becoming confused
147- tweaked MAX_COMPRESSED_SIZE
148- added multi-function CD support to mindi and sbin/post-init
149- re-mount root as rw just in case
150- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
151- added support for 5th column in mountlist.txt for labels
152- added symlinks.tgz
153- suppress erroneous error msgs re: failsafe kernel
154
155* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
156- added cciss.o to SCSI_MODS
157- if format type is (e.g.) ext3,ext2 then use 1st entry
158- re-enabled fsck*
159- if cciss in use the enable it at boot-time
160- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
161- better ISO support
162- tweaked Mindi to use 10-15% fewer floppies
163- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
164 to be run by Mindi before it bootstraps to aux data disks;
165 e.g. 'echo engage > /proc/scsi/something'
166- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
167 to be run by Mindi after it boots but before it runs mondorestore
168- allow for Debian & other Stiefkinder that use 'none', not 'swap'
169 as the mountpoint of the swap partition
170- removed afio dependency
171- re-worked install.sh and tarball not to use tgz's
172- cleared up the boot msg
173- updated busybox to 0.60.5; updated uClibc to 0.9.19
174- add #!/bin/sh to start of insert-all-my-modules
175- fixed obscure bug in install-additional-tools
176- changed grep -m to grep | head -n1 for Debian users
177- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
178
179* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
180- fixed LVM/RAID bugs (Brian Borgeson)
181- if bad lilo, give more verbose error before quitting
182- added mt and perl to deplist.txt
183- insist on gawk being present
184- insmod ide-cd, cdrom, isofs, just in case
185- boot-time tmpfs ramdisk is now 40m (was 34m)
186- cleaned up logs
187- iso mode now calls Interactive
188- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
189- clean up some calls to grep, esp. partition_mountpt=...
190- corrected some bashisms, to suit Debian ped- er, users
191- made first line refer to bash, not sh, to make sure
192 the Debian people know Mindi requires bash, not hs
193- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
194- disabled code which would have made Mindi use sfdisk instead of fdisk
195 if it looked as if Debian's fdisk would misbehave
196
197* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
198- new devel branch
199- EXTRA_SPACE=16384
200- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
201- patched analyze-my-lvm (Benjamin Mampaey)
202- detect built-in boot.b files in lilo
203- cleaned up spec file a bit, more use of macros (Jesse Keating)
204- return w/err, don't abort, if Matt Nelson's RH8 system is farked
205- better at finding isolinux.bin
206- better at analyzing dependencies when running on broken distributions
207- try harder to boot from CD, even if tape fails
208- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
209- better resolution of relative softlinks, leading to fewer
210 duplicates on data disks and therefore fewer data disks
211- detect Debian+devfs; use sfdisk instead of fdisk in that
212 eventuality, to work around yet another of Debian's warts
213- removed /lib/libuuid.* from rootfs.tgz
214- fixed vi
215- mindi now uses gawk --traditional (making gawk behave in a functionally
216 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
217- removed / from list of dirs accessed when trying to resolve deplist entry
218- spinner bugfix; handle odd LABELs properly (Tom Mortell)
219- fixed LVM/RAID bugs (Brian Borgeson)
220
221* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
222- misc code clean-up
223- save boot device's boot sector
224- detect and beware Compaq diagnostic partitions
225- better handling of devfs V non-devfs kernels and boot devs
226- trimmed busybox 0.60.3 binary on boot disk
227- mindi now resides in /usr/local/bin
228- removed lilo from dependencies
229- more Gentoo-friendly
230
231* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
232- if your kernel's builddate doesn't match any of the kernels in
233 your /boot directory then fudge the issue & find the closest
234 match (*grumble* Debian)
235- scan tape & CD at start, to force inclusion of modules on boot device
236- double EXTRA_SPACE if >7 disks
237- slimmer, more lithesome logfile
238- now accepts --findkernel
239- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
240- better handling of non-Linux partitions on DevFS-enabled kernels
241- misc clean-ups
242- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
243- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
244- updated kernel to 2.4.18-mdk6
245- generate mountlist in dev-abetical order ;)
246- fixed minor bug in .spec file
247- better at finding /boot/boot.b if your distro breaks the de facto standard
248- fixed minor bug in MakeMountlist
249- fixed install.sh
250- cleaned up deplist.txt
251- added rudimentary -v / --version flag
252- line 1180 or so --- duplicate mindi.iso entries --- fixed
253- added /bin/[ - a softlink to /bin/sh
254- ListAllPartitions() - sanity fix (KP)
255- fixed .spec bug
256- better feedback
257- added Markus's RAID patch
258- ListAllPartitions() - include /mnt/win* (Hugo)
259
260* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
261- better logging by dependency-calculating code
262- better handling of dependencies, specifically softlinks
263- if called by mondo then use mondo's temp dir as our temp dir too
264- changed gawk to $AWK in a few places, to allow for Debian
265- added host* config files to deplist
266- added tftp, ifconfig to busybox
267- added RPC support to uClibc
268- cleaned up creation of Mondo-Mindi configuration file
269- fixed bug in TryToFindKernelPath which stopped it from handling
270 multiple, same-version kernels gracefully
271- cleaned up deplist.txt
272- receive 'DIFFERENTIAL' variable from Mondo
273- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
274- better devfs support; call fgrep in places instead of grep (Andrew Korn)
275- fixed analyze-my-lvm (Ralph Gruwe)
276- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
277- added x11-tools.tgz option
278- updated /dev/console and /dev/tty0 (Paul Stevens)
279- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
280- catch sigint, sighup, etc.
281- fixed LILO-related message.txt mistake
282- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
283- better devfs support (Andrew Korn)
284
285* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
286- fixed RH7.3 readonly bug
287- improved nfs config file creation
288- search more locations for isolinux.bin
289- added isonuke option
290- faster data disk creation
291- better DevFS support (Hector Alvarez, DuckX)
292- nfs-related fix (Hans Lie)
293- abort if vfat filesystem present but mkfs.vfat missing
294- removed softlink to pico
295- allow Mondo to say no compression will be used
296- added [ to ramdisk
297- tar data disks with -b [block size] of 32k
298- don't autoboot to 'RESTORE' screen - it's scary!
299- let user choose lilo or syslinux as boot loader
300- added syslinux support
301- cleaned up message screens
302
Note: See TracBrowser for help on using the repository browser.