source: MondoRescue/trunk/mindi/mindi.spec@ 1

Last change on this file since 1 was 1, checked in by bcornec, 19 years ago

Initial import from latest mondo-2.04_cvs_20050503/mindi-1.04_cvs_20050503 on http://www.mondorescue.org

File size: 11.5 KB
Line 
1%define _prefix /usr
2Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
3Name: mindi
4Version: 1.04_cvs_20050503
5Release: 1
6License: GPL
7Group: System/Kernel and hardware
8Url: http://www.mondorescue.org
9Source: %{name}-%{version}.tgz
10BuildRoot: %{_tmppath}/%{name}-%{version}
11Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk
12Prefix: %{_prefix}
13Autoreq: 0
14
15%description
16Mindi takes your kernel, modules, tools and libraries, and puts them on N
17bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
18and do system maintenance - e.g. format partitions, backup/restore data,
19verify packages, etc.
20
21%prep
22%setup
23
24%build
25%ifarch ia64
26make -f Makefile.parted2fdisk clean
27make -f Makefile.parted2fdisk
28%endif
29
30%install
31%{__rm} -Rf /usr/local/share/mindi
32%{__rm} -rf $RPM_BUILD_ROOT
33MINDIDIR=$RPM_BUILD_ROOT%{_datadir}/mindi
34%{__mkdir_p} $MINDIDIR $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_sysconfdir}/mindi
35%{__mv} deplist.txt $RPM_BUILD_ROOT%{_sysconfdir}/mindi/
36%{__cp} -af * $MINDIDIR
37%ifarch ia64
38 make -f Makefile.parted2fdisk DEST=${MINDIDIR}/ install
39 %{__mv} $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/bin/busybox
40 %{__mv} $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk
41%else
42 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox
43 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386.net $MINDIDIR/rootfs/bin/busybox.net
44 %{__ln_s} fdisk $MINDIDIR/rootfs/sbin/parted2fdisk
45%endif
46%{__rm} -f $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox-i386.net
47#
48# These are installed twice if not removed here
49( cd $MINDIDIR
50%{__rm} -f CHANGES INSTALL COPYING README TODO README.ia64
51)
52cd $RPM_BUILD_ROOT%{_bindir}
53%{__ln_s} -f %{_datadir}/mindi/mindi .
54%{__ln_s} -f %{_datadir}/mindi/parted2fdisk.pl .
55%{__ln_s} -f %{_datadir}/mindi/analyze-my-lvm .
56chmod +x $MINDIDIR/mindi
57
58%clean
59%{__rm} -rf $RPM_BUILD_ROOT
60
61%post
62%ifarch ia64
63 %{__mkdir_p} /usr/local/bin
64 if [ "`file /sbin/fdisk |grep 'LF 64-bit LSB executable'`" ] ; then
65 %{__cp} /sbin/fdisk /sbin/fdisk.mondosav
66 %{__mv} /sbin/fdisk /usr/local/bin/fdisk
67 %{__ln_s} -f /usr/share/mindi/parted2fdisk.pl /sbin/fdisk
68 echo "Warning: you fdisk binary is now under /usr/local/bin"
69 fi
70%endif
71
72%files
73%defattr(-,root,root,-)
74%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
75%doc CHANGES INSTALL COPYING README TODO README.ia64
76#%attr(755,root,root) %{_datadir}/mindi/mindi
77
78%{_datadir}/mindi
79%{_bindir}/analyze-my-lvm
80%{_bindir}/mindi
81%{_bindir}/parted2fdisk.pl
82
83%changelog
84* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
85- supports exec-shield
86
87* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
88- better support of SLES 8
89
90* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
91- better kernel-level logging
92- added ACL, xattr binaries to deplist.txt
93- fixed obscure bug which occasionally stopped mindi from correctly finding
94 and documenting all LVM2 LVM-on-RAID volumes
95
96* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
97- added ide_tape and other modules to mindi's config detection
98- unmount errant ramdisk ($mtpt) if fail to create boot floppy
99- better support of ISO dirs at restore-time (Conor Daly)
100
101* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
102- first 1.0x release
103- busybox now static
104- trap Ctrl-Alt-Del; trigger soft reset
105- better SuSE 9.1 support
106- added parted2fdisk.pl (IA64) (Bruno Cornec)
107- add LVM2 support for kernel 2.6 (Takeru Komoriya)
108- better detection of multiple Mindis (Martin Fürstenau)
109- don't complain if just a Mindi boot CD & not a platform for Mondo
110- updated busybox to 1.0.0pre10
111- removed uClibc
112- add memtest support
113- 2.6 kernel support
114- removed Embleer files (Andree Leidenfrost)
115- added kernel-only floppy support, to accommodate really big kernels
116- updated+rebuilt busybox
117- added star support
118- mount /sys at boot-time
119- better 64-bit and 2.6 kernel support
120- better LVM, failsafe kernel support (Jim Richard)
121- use LILO, not raw kernel, on 1.4MB boot floppy
122- record names of unsaved modules, for future reference
123- enlarged ramdisk by 8MB
124
125* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
126- changed some '==' to '=' --- now more RH6-friendly
127- allow absolute pathnames again in deplist
128- disable multifunc cd thing
129- better Gentoo support (Bill)
130- better OnStream support
131- better Slackware support (Laurenz)
132- added partimagehack-static to deplist.txt
133- recompiled Busybox - now 10k smaller; better stack-handling
134- fixed boot screen typo
135- added support for 'auto' fs format
136- better devfs support for Mandrake users
137- better Debian+LVM support (Ralph Grewe)
138- updated analyze-my-lvm to handle floating-point gigabyte -L values
139
140* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
141- altered rootfs's /dev entry to stop cvs from becoming confused
142- tweaked MAX_COMPRESSED_SIZE
143- added multi-function CD support to mindi and sbin/post-init
144- re-mount root as rw just in case
145- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
146- added support for 5th column in mountlist.txt for labels
147- added symlinks.tgz
148- suppress erroneous error msgs re: failsafe kernel
149
150* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
151- added cciss.o to SCSI_MODS
152- if format type is (e.g.) ext3,ext2 then use 1st entry
153- re-enabled fsck*
154- if cciss in use the enable it at boot-time
155- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
156- better ISO support
157- tweaked Mindi to use 10-15% fewer floppies
158- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
159 to be run by Mindi before it bootstraps to aux data disks;
160 e.g. 'echo engage > /proc/scsi/something'
161- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
162 to be run by Mindi after it boots but before it runs mondorestore
163- allow for Debian & other Stiefkinder that use 'none', not 'swap'
164 as the mountpoint of the swap partition
165- removed afio dependency
166- re-worked install.sh and tarball not to use tgz's
167- cleared up the boot msg
168- updated busybox to 0.60.5; updated uClibc to 0.9.19
169- add #!/bin/sh to start of insert-all-my-modules
170- fixed obscure bug in install-additional-tools
171- changed grep -m to grep | head -n1 for Debian users
172- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
173
174* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
175- fixed LVM/RAID bugs (Brian Borgeson)
176- if bad lilo, give more verbose error before quitting
177- added mt and perl to deplist.txt
178- insist on gawk being present
179- insmod ide-cd, cdrom, isofs, just in case
180- boot-time tmpfs ramdisk is now 40m (was 34m)
181- cleaned up logs
182- iso mode now calls Interactive
183- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
184- clean up some calls to grep, esp. partition_mountpt=...
185- corrected some bashisms, to suit Debian ped- er, users
186- made first line refer to bash, not sh, to make sure
187 the Debian people know Mindi requires bash, not hs
188- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
189- disabled code which would have made Mindi use sfdisk instead of fdisk
190 if it looked as if Debian's fdisk would misbehave
191
192* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
193- new devel branch
194- EXTRA_SPACE=16384
195- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
196- patched analyze-my-lvm (Benjamin Mampaey)
197- detect built-in boot.b files in lilo
198- cleaned up spec file a bit, more use of macros (Jesse Keating)
199- return w/err, don't abort, if Matt Nelson's RH8 system is farked
200- better at finding isolinux.bin
201- better at analyzing dependencies when running on broken distributions
202- try harder to boot from CD, even if tape fails
203- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
204- better resolution of relative softlinks, leading to fewer
205 duplicates on data disks and therefore fewer data disks
206- detect Debian+devfs; use sfdisk instead of fdisk in that
207 eventuality, to work around yet another of Debian's warts
208- removed /lib/libuuid.* from rootfs.tgz
209- fixed vi
210- mindi now uses gawk --traditional (making gawk behave in a functionally
211 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
212- removed / from list of dirs accessed when trying to resolve deplist entry
213- spinner bugfix; handle odd LABELs properly (Tom Mortell)
214- fixed LVM/RAID bugs (Brian Borgeson)
215
216* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
217- misc code clean-up
218- save boot device's boot sector
219- detect and beware Compaq diagnostic partitions
220- better handling of devfs V non-devfs kernels and boot devs
221- trimmed busybox 0.60.3 binary on boot disk
222- mindi now resides in /usr/local/bin
223- removed lilo from dependencies
224- more Gentoo-friendly
225
226* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
227- if your kernel's builddate doesn't match any of the kernels in
228 your /boot directory then fudge the issue & find the closest
229 match (*grumble* Debian)
230- scan tape & CD at start, to force inclusion of modules on boot device
231- double EXTRA_SPACE if >7 disks
232- slimmer, more lithesome logfile
233- now accepts --findkernel
234- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
235- better handling of non-Linux partitions on DevFS-enabled kernels
236- misc clean-ups
237- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
238- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
239- updated kernel to 2.4.18-mdk6
240- generate mountlist in dev-abetical order ;)
241- fixed minor bug in .spec file
242- better at finding /boot/boot.b if your distro breaks the de facto standard
243- fixed minor bug in MakeMountlist
244- fixed install.sh
245- cleaned up deplist.txt
246- added rudimentary -v / --version flag
247- line 1180 or so --- duplicate mindi.iso entries --- fixed
248- added /bin/[ - a softlink to /bin/sh
249- ListAllPartitions() - sanity fix (KP)
250- fixed .spec bug
251- better feedback
252- added Markus's RAID patch
253- ListAllPartitions() - include /mnt/win* (Hugo)
254
255* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
256- better logging by dependency-calculating code
257- better handling of dependencies, specifically softlinks
258- if called by mondo then use mondo's temp dir as our temp dir too
259- changed gawk to $AWK in a few places, to allow for Debian
260- added host* config files to deplist
261- added tftp, ifconfig to busybox
262- added RPC support to uClibc
263- cleaned up creation of Mondo-Mindi configuration file
264- fixed bug in TryToFindKernelPath which stopped it from handling
265 multiple, same-version kernels gracefully
266- cleaned up deplist.txt
267- receive 'DIFFERENTIAL' variable from Mondo
268- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
269- better devfs support; call fgrep in places instead of grep (Andrew Korn)
270- fixed analyze-my-lvm (Ralph Gruwe)
271- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
272- added x11-tools.tgz option
273- updated /dev/console and /dev/tty0 (Paul Stevens)
274- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
275- catch sigint, sighup, etc.
276- fixed LILO-related message.txt mistake
277- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
278- better devfs support (Andrew Korn)
279
280* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
281- fixed RH7.3 readonly bug
282- improved nfs config file creation
283- search more locations for isolinux.bin
284- added isonuke option
285- faster data disk creation
286- better DevFS support (Hector Alvarez, DuckX)
287- nfs-related fix (Hans Lie)
288- abort if vfat filesystem present but mkfs.vfat missing
289- removed softlink to pico
290- allow Mondo to say no compression will be used
291- added [ to ramdisk
292- tar data disks with -b [block size] of 32k
293- don't autoboot to 'RESTORE' screen - it's scary!
294- let user choose lilo or syslinux as boot loader
295- added syslinux support
296- cleaned up message screens
297
Note: See TracBrowser for help on using the repository browser.