source: MondoRescue/trunk/mindi/mindi.spec@ 70

Last change on this file since 70 was 70, checked in by bcornec, 19 years ago

mindi depends on which

  • Property svn:keywords set to Id
File size: 12.7 KB
RevLine 
[35]1#
2# $Id: mindi.spec 70 2005-10-19 15:14:59Z bcornec $
3#
[51]4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mindi
11%define version 1.04_berlios
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
[65]16Group: Applications/Archiving
[51]17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
[65]22Group: Archiving/Backup
[51]23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
[65]28Group: Archiving/Backup
[51]29Autoreqprov: no
30%endif
31
[1]32Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
[51]33Name: %name
34Version: %version
[65]35Release: %mrel
[1]36License: GPL
37Group: System/Kernel and hardware
[51]38Url: http://mondorescue.berlios.de
39Source: %{src}
[1]40BuildRoot: %{_tmppath}/%{name}-%{version}
[70]41Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools, afio, which
[20]42# Not on all systems
43#Conflicts: bonnie++
[1]44
45%description
46Mindi takes your kernel, modules, tools and libraries, and puts them on N
47bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
48and do system maintenance - e.g. format partitions, backup/restore data,
49verify packages, etc.
50
51%prep
[51]52%{__rm} -rf $RPM_BUILD_ROOT
53%setup -n %name-%{version}
[1]54
55%build
56%ifarch ia64
[51]57%{__make} -f Makefile.parted2fdisk clean
58%{__make} -f Makefile.parted2fdisk
[1]59%endif
60
61%install
[51]62export DONT_RELINK=1
63
[1]64%{__rm} -rf $RPM_BUILD_ROOT
65MINDIDIR=$RPM_BUILD_ROOT%{_datadir}/mindi
[51]66
67%{__mkdir_p} $MINDIDIR $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_sysconfdir}/mindi $RPM_BUILD_ROOT%{_sbindir}
[1]68%{__mv} deplist.txt $RPM_BUILD_ROOT%{_sysconfdir}/mindi/
69%{__cp} -af * $MINDIDIR
[51]70
[1]71%ifarch ia64
[51]72 %{__make} -f Makefile.parted2fdisk DEST=${MINDIDIR}/ install
[1]73 %{__mv} $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/bin/busybox
74 %{__mv} $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk
75%else
76 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox
77 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386.net $MINDIDIR/rootfs/bin/busybox.net
78 %{__ln_s} fdisk $MINDIDIR/rootfs/sbin/parted2fdisk
79%endif
80%{__rm} -f $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox-i386.net
[51]81
[1]82#
83# These are installed twice if not removed here
[51]84#
[1]85( cd $MINDIDIR
[12]86%{__rm} -f CHANGES INSTALL COPYING README TODO README.ia64 README.pxe
[1]87)
88
[51]89# Symlinks
90
91cd $RPM_BUILD_ROOT%{_sbindir}
92%{__ln_s} -f ${_sbindir}/mindi/mindi .
93%{__ln_s} -f ${_sbindir}/mindi/analyze-my-lvm .
94%ifarch ia64
95%{__ln_s} -f ${_sbindir}/mindi/parted2fdisk.pl .
96%endif
97
[1]98%clean
99%{__rm} -rf $RPM_BUILD_ROOT
100
101%post
102%ifarch ia64
103 %{__mkdir_p} /usr/local/bin
104 if [ "`file /sbin/fdisk |grep 'LF 64-bit LSB executable'`" ] ; then
105 %{__cp} /sbin/fdisk /sbin/fdisk.mondosav
106 %{__mv} /sbin/fdisk /usr/local/bin/fdisk
107 %{__ln_s} -f /usr/share/mindi/parted2fdisk.pl /sbin/fdisk
108 echo "Warning: you fdisk binary is now under /usr/local/bin"
109 fi
110%endif
111
112%files
[51]113%defattr(644,root,root,755)
[1]114%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
[12]115%doc CHANGES INSTALL COPYING README TODO README.ia64 README.pxe
[51]116%attr(755,-,-) %{_sbindir}/mindi
117%attr(755,-,-) %{_sbindir}/analyze-my-lvm
[1]118%{_datadir}/mindi
[51]119%attr(755,-,-) %{_datadir}/mindi/analyze-my-lvm
120%attr(755,-,-) %{_datadir}/mindi/mindi
121%ifarch ia64
122%attr(755,-,-) %{_datadir}/mindi/parted2fdisk.pl
123%endif
124%attr(755,-,-) %{_datadir}/mindi/aux-tools/sbin/*
125%attr(755,-,-) %{_datadir}/mindi/rootfs/bin/*
126%attr(755,-,-) %{_datadir}/mindi/rootfs/sbin/*
[1]127
128%changelog
[15]129* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
[12]130- Merge of patches mentionned on mondo ML + ia64 updates
[51]131- Fix bugs when called alone
[12]132
[1]133* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
134- supports exec-shield
135
136* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
137- better support of SLES 8
138
139* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
140- better kernel-level logging
141- added ACL, xattr binaries to deplist.txt
142- fixed obscure bug which occasionally stopped mindi from correctly finding
143 and documenting all LVM2 LVM-on-RAID volumes
144
145* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
146- added ide_tape and other modules to mindi's config detection
147- unmount errant ramdisk ($mtpt) if fail to create boot floppy
148- better support of ISO dirs at restore-time (Conor Daly)
149
150* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
151- first 1.0x release
152- busybox now static
153- trap Ctrl-Alt-Del; trigger soft reset
154- better SuSE 9.1 support
155- added parted2fdisk.pl (IA64) (Bruno Cornec)
156- add LVM2 support for kernel 2.6 (Takeru Komoriya)
157- better detection of multiple Mindis (Martin Fürstenau)
158- don't complain if just a Mindi boot CD & not a platform for Mondo
159- updated busybox to 1.0.0pre10
160- removed uClibc
161- add memtest support
162- 2.6 kernel support
163- removed Embleer files (Andree Leidenfrost)
164- added kernel-only floppy support, to accommodate really big kernels
165- updated+rebuilt busybox
166- added star support
167- mount /sys at boot-time
168- better 64-bit and 2.6 kernel support
169- better LVM, failsafe kernel support (Jim Richard)
170- use LILO, not raw kernel, on 1.4MB boot floppy
171- record names of unsaved modules, for future reference
172- enlarged ramdisk by 8MB
173
174* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
175- changed some '==' to '=' --- now more RH6-friendly
176- allow absolute pathnames again in deplist
177- disable multifunc cd thing
178- better Gentoo support (Bill)
179- better OnStream support
180- better Slackware support (Laurenz)
181- added partimagehack-static to deplist.txt
182- recompiled Busybox - now 10k smaller; better stack-handling
183- fixed boot screen typo
184- added support for 'auto' fs format
185- better devfs support for Mandrake users
186- better Debian+LVM support (Ralph Grewe)
187- updated analyze-my-lvm to handle floating-point gigabyte -L values
188
189* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
190- altered rootfs's /dev entry to stop cvs from becoming confused
191- tweaked MAX_COMPRESSED_SIZE
192- added multi-function CD support to mindi and sbin/post-init
193- re-mount root as rw just in case
194- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
195- added support for 5th column in mountlist.txt for labels
196- added symlinks.tgz
197- suppress erroneous error msgs re: failsafe kernel
198
199* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
200- added cciss.o to SCSI_MODS
201- if format type is (e.g.) ext3,ext2 then use 1st entry
202- re-enabled fsck*
203- if cciss in use the enable it at boot-time
204- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
205- better ISO support
206- tweaked Mindi to use 10-15% fewer floppies
207- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
208 to be run by Mindi before it bootstraps to aux data disks;
209 e.g. 'echo engage > /proc/scsi/something'
210- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
211 to be run by Mindi after it boots but before it runs mondorestore
212- allow for Debian & other Stiefkinder that use 'none', not 'swap'
213 as the mountpoint of the swap partition
214- removed afio dependency
215- re-worked install.sh and tarball not to use tgz's
216- cleared up the boot msg
217- updated busybox to 0.60.5; updated uClibc to 0.9.19
218- add #!/bin/sh to start of insert-all-my-modules
219- fixed obscure bug in install-additional-tools
220- changed grep -m to grep | head -n1 for Debian users
221- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
222
223* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
224- fixed LVM/RAID bugs (Brian Borgeson)
225- if bad lilo, give more verbose error before quitting
226- added mt and perl to deplist.txt
227- insist on gawk being present
228- insmod ide-cd, cdrom, isofs, just in case
229- boot-time tmpfs ramdisk is now 40m (was 34m)
230- cleaned up logs
231- iso mode now calls Interactive
232- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
233- clean up some calls to grep, esp. partition_mountpt=...
234- corrected some bashisms, to suit Debian ped- er, users
235- made first line refer to bash, not sh, to make sure
236 the Debian people know Mindi requires bash, not hs
237- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
238- disabled code which would have made Mindi use sfdisk instead of fdisk
239 if it looked as if Debian's fdisk would misbehave
240
241* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
242- new devel branch
243- EXTRA_SPACE=16384
244- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
245- patched analyze-my-lvm (Benjamin Mampaey)
246- detect built-in boot.b files in lilo
247- cleaned up spec file a bit, more use of macros (Jesse Keating)
248- return w/err, don't abort, if Matt Nelson's RH8 system is farked
249- better at finding isolinux.bin
250- better at analyzing dependencies when running on broken distributions
251- try harder to boot from CD, even if tape fails
252- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
253- better resolution of relative softlinks, leading to fewer
254 duplicates on data disks and therefore fewer data disks
255- detect Debian+devfs; use sfdisk instead of fdisk in that
256 eventuality, to work around yet another of Debian's warts
257- removed /lib/libuuid.* from rootfs.tgz
258- fixed vi
259- mindi now uses gawk --traditional (making gawk behave in a functionally
260 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
261- removed / from list of dirs accessed when trying to resolve deplist entry
262- spinner bugfix; handle odd LABELs properly (Tom Mortell)
263- fixed LVM/RAID bugs (Brian Borgeson)
264
265* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
266- misc code clean-up
267- save boot device's boot sector
268- detect and beware Compaq diagnostic partitions
269- better handling of devfs V non-devfs kernels and boot devs
270- trimmed busybox 0.60.3 binary on boot disk
271- mindi now resides in /usr/local/bin
272- removed lilo from dependencies
273- more Gentoo-friendly
274
275* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
276- if your kernel's builddate doesn't match any of the kernels in
277 your /boot directory then fudge the issue & find the closest
278 match (*grumble* Debian)
279- scan tape & CD at start, to force inclusion of modules on boot device
280- double EXTRA_SPACE if >7 disks
281- slimmer, more lithesome logfile
282- now accepts --findkernel
283- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
284- better handling of non-Linux partitions on DevFS-enabled kernels
285- misc clean-ups
286- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
287- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
288- updated kernel to 2.4.18-mdk6
289- generate mountlist in dev-abetical order ;)
290- fixed minor bug in .spec file
291- better at finding /boot/boot.b if your distro breaks the de facto standard
292- fixed minor bug in MakeMountlist
293- fixed install.sh
294- cleaned up deplist.txt
295- added rudimentary -v / --version flag
296- line 1180 or so --- duplicate mindi.iso entries --- fixed
297- added /bin/[ - a softlink to /bin/sh
298- ListAllPartitions() - sanity fix (KP)
299- fixed .spec bug
300- better feedback
301- added Markus's RAID patch
302- ListAllPartitions() - include /mnt/win* (Hugo)
303
304* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
305- better logging by dependency-calculating code
306- better handling of dependencies, specifically softlinks
307- if called by mondo then use mondo's temp dir as our temp dir too
308- changed gawk to $AWK in a few places, to allow for Debian
309- added host* config files to deplist
310- added tftp, ifconfig to busybox
311- added RPC support to uClibc
312- cleaned up creation of Mondo-Mindi configuration file
313- fixed bug in TryToFindKernelPath which stopped it from handling
314 multiple, same-version kernels gracefully
315- cleaned up deplist.txt
316- receive 'DIFFERENTIAL' variable from Mondo
317- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
318- better devfs support; call fgrep in places instead of grep (Andrew Korn)
319- fixed analyze-my-lvm (Ralph Gruwe)
320- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
321- added x11-tools.tgz option
322- updated /dev/console and /dev/tty0 (Paul Stevens)
323- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
324- catch sigint, sighup, etc.
325- fixed LILO-related message.txt mistake
326- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
327- better devfs support (Andrew Korn)
328
329* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
330- fixed RH7.3 readonly bug
331- improved nfs config file creation
332- search more locations for isolinux.bin
333- added isonuke option
334- faster data disk creation
335- better DevFS support (Hector Alvarez, DuckX)
336- nfs-related fix (Hans Lie)
337- abort if vfat filesystem present but mkfs.vfat missing
338- removed softlink to pico
339- allow Mondo to say no compression will be used
340- added [ to ramdisk
341- tar data disks with -b [block size] of 32k
342- don't autoboot to 'RESTORE' screen - it's scary!
343- let user choose lilo or syslinux as boot loader
344- added syslinux support
345- cleaned up message screens
346
Note: See TracBrowser for help on using the repository browser.