source: MondoRescue/trunk/mindi/distributions/rpm/mindi.spec@ 600

Last change on this file since 600 was 600, checked in by bcornec, 18 years ago

merge -r 591:599 $SVN_M/branches/stable

  • Property svn:keywords set to Id
File size: 1.5 KB
Line 
1#
2# $Id: mindi.spec 600 2006-05-30 22:22:14Z bcornec $
3#
4%define mrel RRR
5%define tag TTT
6
7Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
8Name: mindi
9Version: VVV
10Release: %mrel
11License: GPL
12Group: GRP
13Url: http://www.mondorescue.org
14Source: SSS
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
16Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools DDD
17# Not on all systems
18#Conflicts: bonnie++
19
20%description
21Mindi takes your kernel, modules, tools and libraries, and puts them on N
22bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
23and do system maintenance - e.g. format partitions, backup/restore data,
24verify packages, etc.
25
26%prep
27%setup -n %name-%{version}-%{tag}
28
29%build
30%ifarch ia64
31%{__make} -f Makefile.parted2fdisk clean
32%{__make} -f Makefile.parted2fdisk
33%endif
34
35%install
36%{__rm} -rf $RPM_BUILD_ROOT
37export DONT_RELINK=1
38
39export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
40export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
41export RPMBUILDMINDI="true"
42
43./install.sh
44
45%clean
46%{__rm} -rf $RPM_BUILD_ROOT
47
48%post
49if [ -f /usr/local/sbin/mindi ]; then
50 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
51fi
52
53%files
54%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
55%config(noreplace) %{_sysconfdir}/mindi/deplist.d/*
56%config(noreplace) %{_sysconfdir}/mindi/mindi.conf
57%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
58%{_mandir}/man8/*
59%{_libdir}/mindi
60%{_sysconfdir}/mindi/mindi.conf
61%{_sbindir}/*
62
63%changelog
Note: See TracBrowser for help on using the repository browser.