source: MondoRescue/trunk/mindi-kernel/distributions/gentoo/mindi.ebuild@ 782

Last change on this file since 782 was 782, checked in by Bruno Cornec, 18 years ago

merge -r763:781 $SVN_M/branches/stable

File size: 1.1 KB
Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tgz"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="~x86 -*"
14IUSE=""
15
16DEPEND="virtual/libc"
17RDEPEND=">=app-arch/bzip2-0.9
18 >=sys-apps/mindi-kernel-1.0-r1
19 sys-libs/ncurses
20 sys-devel/binutils
21 sys-fs/dosfstools
22 sys-apps/gawk"
23
24src_unpack() {
25 unpack "${A}" || die "Failed to unpack ${A}"
26}
27
28src_install() {
29 export PREFIX="/usr"
30 export CONFDIR="/etc"
31 export RPMBUILDMINDI="true"
32 ./install.sh
33}
34
35pkg_postinst() {
36 einfo "${P} was successfully installed."
37 einfo "Please read the associated docs for help."
38 einfo "Or visit the website @ ${HOMEPAGE}"
39 echo
40 ewarn "This package is still in unstable."
41 ewarn "Please report bugs to http://bugs.gentoo.org/"
42 ewarn "However, please do an advanced query to search for bugs"
43 ewarn "before reporting. This will keep down on duplicates."
44 echo
45}
Note: See TracBrowser for help on using the repository browser.