source: MondoRescue/trunk/mindi-busybox/distributions/gentoo/mindi-busybox.ebuild@ 1043

Last change on this file since 1043 was 1043, checked in by Bruno Cornec, 17 years ago

merge -r978:1042 $SVN_M/branches/stable

File size: 814 bytes
RevLine 
[932]1# Copyright 1999-2006 Gentoo Foundation
[823]2# Distributed under the terms of the GNU General Public License v2
3# $Id$
4
[932]5inherit eutils flag-o-matic
6
7DESCRIPTION="The rescue part of a program that creates emergency boot disks/CDs using your kernel, tools and modules."
[823]8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
10LICENSE="GPL-2"
11SLOT="0"
[932]12KEYWORDS="~x86 ia64 -*"
[823]13DEPEND="virtual/libc"
14RDEPEND=">=app-arch/bzip2-0.9
15 sys-devel/binutils"
16
17src_unpack() {
18 unpack ${A} || die "Failed to unpack ${A}"
[932]19 make oldconfig > /dev/null
[823]20}
21
[932]22src_compile() {
23 # work around broken ass powerpc compilers
24 emake EXTRA_CFLAGS="${CFLAGS}" busybox || die "build failed"
25}
26
[823]27src_install() {
[932]28 # bundle up the symlink files for use later
[1043]29 emake PREFIX="${D}/usr/share/mindi/rootfs" install || die
[823]30}
Note: See TracBrowser for help on using the repository browser.