source: MondoRescue/branches/stable/mondo/distributions/rpm/mondo.spec@ 402

Last change on this file since 402 was 402, checked in by bcornec, 18 years ago
  • RPM build for mondo doc recoded
  • Tag for documentation, man pages
  • Include a patch from SuSE RPMs for mondo
  • Property svn:keywords set to Id
File size: 17.6 KB
Line 
1#
2# $Id: mondo.spec 402 2006-02-17 18:05:06Z bcornec $
3#
4
5%define name mondo
6%define version VVV
7%define mrel RRR
8# if mandriva official build (rpm --with is_official)
9%{?is_official:%define rel %{mkrel} %{mrel}}%{!?is_official:%define rel %{mrel}}
10%define src SSS
11%define grp GRP
12%define addreqb mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, newt >= 0.50, slang >= 1.4.1
13%define addreq DDD
14
15Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
16Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
17Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
18Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
19
20Name: %{name}
21Version: %{version}
22Release: %{mrel}
23License: GPL
24Group: %{grp}
25Url: http://mondorescue.berlios.de
26Source: %{src}
27BuildRoot: %{_tmppath}/%{name}-%{version}
28BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
29%ifarch ia64
30Requires: %{addreq}, elilo, parted
31%else
32Requires: %{addreq}, syslinux >= 1.52
33%endif
34
35%description
36Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
37
38%description -l fr
39Objectif
40""""""""
41Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
42
43%description -l it
44Scopo
45"""""
46Mondo e' un programma che permette a qualsiasi utente Linux
47di creare un cd di rescue/restore (o piu' cd qualora l'installazione
48dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
49nastro, ed il NFS, anche.
50
51%description -l sp
52Objectivo
53"""""""""
54Mondo es un programa que permite cualquier usuario de Linux a crear una CD
55de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
56con cintas y NFS, tambien.
57
58%debug_package
59%prep
60%setup -q -n %name-%{version}
61
62%build
63%configure
64%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
65
66%install
67%{__rm} -rf $RPM_BUILD_ROOT
68%makeinstall
69
70%post
71/sbin/ldconfig
72%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
73
74%postun
75/sbin/ldconfig
76
77%clean
78%{__rm} -rf $RPM_BUILD_ROOT
79
80%files
81%defattr(644,root,root,755)
82%doc ChangeLog svn.log
83%doc INSTALL COPYING README TODO AUTHORS NEWS
84%doc docs/en/mondorescue-howto.html docs/en/mondorescue-howto.pdf
85
86%attr(755,root,root) %{_sbindir}/*
87#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
88%{_libdir}
89%{_mandir}
90
91%changelog
92* Fri Feb 17 2006 Bruno Cornec <bcornec@users.berlios.de> 2.0.7
93- Updated to 2.0.7
94- RPM sepc files are now generated
95
96* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
97- ia64 is now working
98- -p option related bug fixed
99- use libdir instead of datadir
100
101* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
102- Merge of patches mentionned on mondo ML + ia64 updates
103- Add -p option
104
105* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
106- made mondo more clever about finding its home. Avoids mondo considering
107 directories like '/usr/share/doc/momdo' as its home.
108
109* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
110- test sanity of user-specified tempdir
111- better SLES8 support
112
113* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
114- instead of using 'dd' to erase partition table, delete existing
115 partitions w/ the same call to fdisk that is used to create the
116 new partitions; this should avoids locking up the partition table
117- set bootable partition in the above same call to fdisk, for
118 the same reason (avoids locking up the partition table)
119- better software RAID support
120- mount ext3 partitions as ext2 when restoring - better for Debian
121- better star, ACL support
122- added ACL, xattr support for afio users
123
124* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
125- fixed cvs for SuSE systems
126- fixed NTFS backup/restore bug relating to partimagehack
127 log file overflow and NTFS v non-NTFS differentiation
128- more reliable extraction of config info from CDs, floppies
129- better support of ISO dirs at restore-time (Conor Daly)
130- fixed spec file for SuSE users
131- added ldconfig to install section
132
133* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
134- first 2.0 release
135- updated grub-install.patched to support SuSE and Red Hat
136- call 'mt' to set block size to 32K before opening in/out tape
137- updated mondo-prep.c to create each disk's partitions all at once
138 (one call per drive) instead of one call to fdisk per partition
139- when extracting cfg file and mountlist from all.tar.gz (tape copy),
140 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
141- added star and rudimentary SELinux support
142- fixed lots of bugs
143- all logging now goes to /var/log/mondo-archive.log, with symlink
144 to /tmp/mondo-restore.log for restore-time log-tracking
145- added grub-install.patched
146- removed embleer & other binaries
147- added '-b' to specify block size
148- added '-R' for star support
149
150* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
151- ia64 fixes
152
153* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
154- fixed symbolic links for libraries
155- added support for boot/root multi floppies
156
157- added kdelibs as xmondo dependency
158- added xmondo pixmap installation
159- better find_cdrom_device(), to cope w/ multiple CD writers
160- fixed -m and -Vc flags
161- fixed NTFS support!
162- bootable CD uses native, not El Torito, support now
163- removed mondo-makefilelist
164- added 2.6 kernel support
165- if 2.6 kernel, insist that the user specify CD device
166- drop Embleer; insist on ms-sys and parted if Windows partition
167
168* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
169- added -devel package
170
171* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
172- made xmondo a second package
173- added ability to specify --without xmondo at build time
174
175* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
176- Clean up, added spanish translation
177- Set prefix to be /usr
178- added/fixed Requires
179- remove CVS directories prior to building
180
181* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
182- nothing yet
183
184* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
185- fixed chmod/chown bug (Jens Richter)
186- ask user to confirm NFS mountpoint in Interactive Mode
187- rewritten format_everything() to make sure LVMs, RAIDs and
188 regular partitions are prepped in the correct order
189- better magicdev support
190- rewritten external binary caller subroutine
191- DVD support added
192- better backup-time control gui; offer to exclude nfs if appl.
193- fixed multi-tape support
194- re-implemented -D and -J
195- fixed bug in extract_config_file_from_ramdisk() which
196 affected tape+floppy users
197- updated is_incoming_block_valid() to make it
198 return end-of-tape if >300 flotsam blocks
199- unmount CD-ROM before burning (necessary for RH8/9)
200- fixed some stray assert()'s
201- fixed bug in grub-MR (Christian)
202- make user remove floppy/CD before restoring interactively from tape
203- fixed bug in am_I_in_disaster_recovery_mode()
204- added code to nuke_mode() to make sure NFS
205 (backup) share is mounted in Nuke Mode
206- improved tape device detection code
207- better GRUB support
208- better logging of changed bigfiles at compare-time
209- better NTFS support, thanks to partimagehack-static
210- better logging
211- rewrote tape-handling code, breaking compatibility w/ previous versions
212- fixed ISO/CD biggiefile verification bug in mondoarchive
213- fixed bug which stopped boot/compare-time changelist from popping up
214- replaced mondo-makefilelist with C code - faster, cleaner
215- tweaked GUI - better feedback
216
217* Wed May 28 2003 Anonymous <root@rohan> 1.74
218- misc fixes (Michael Hanscho's friend)
219- added rudimentary support for SME
220- added better label support
221- fixed biggietime atime/ctime restoration bug 73
222- fixed 'default boot loader' detection bug (Joshua Oreman)
223- use single-threaded make_afioballs_and_images() if FreeBSD
224- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
225- superior get_phys_size_of_drive() (Joshua Oreman)
226- fixed RAID-related bug in where_is_root_mounted()
227- ISO tweaks
228- fixed silly bug in load_filelist() which stopped
229 funny German filenames from being handled properly
230- fixed various calls to popup_and_get_string()
231- fixed spec file
232- reject -E /
233- added partimagehack to the mix
234
235* Tue May 20 2003 Anonymous <root@rohan> 1.73
236- mark devices as bootable _after_ unmounting them
237- resolve boot device (-f) if softlink
238- post_param_configuration() --- store iso-dev and isodir
239- added post-nuke-sample.tgz to package
240- Nuke Mode now checks mountlist against hardware; offer user
241 opportunity to edit mountlist if insane; if user declines, abort
242- added lots of assert()'s and other checks
243- ran code thru Valgrind to catch & fix some memory leaks
244- made mondo-restore.c smaller by moving some subroutines to
245 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
246- added '-Q' to let user test mondoarchive's ability to find
247 their boot loader and type
248- improved which_boot_loader()
249- when burning or comparing to a CD, defeat autorun if it is
250 running, to avoid confusing mondoarchive and the user
251- if original backup media no longer available at boot-time
252 then offer user chance to choose another media source
253- when booting, type 'nuke noresize' to nuke w/o resizing
254 mountlist to fill your drives
255- add 'textonly' when booting, to avoid using Newt gui
256- run nice(20) to prioritize mondoarchive at start
257- don't pause and wait for next blank CD at backup-time
258 unless necessary (e.g. previous CD has not been removed)
259- get_phys_size_of_drive() --- better support of older drives
260- don't eject if "donteject" is in kernel's command line
261- cleaned up segfault-handling
262- added Conor's strip_path() to improve file list display
263- added Herman Kuster's multi-level bkp patch
264- better boot-time screen/message
265- added Joshua Oreman's FreeBSD patches x3
266- fixed interactive/textonly support
267- fixed support for subdir-within-NFS-mount
268- fixed "Can't backup if ramdisk not mounted" bug
269- try to work around eccentricities of multi-CD drive PCs
270- misc clean-ups (Steve Hindle)
271
272* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
273- LVM/RAID bugs fixed (Brian Borgeson)
274- major clean-up of code (Stan Benoit)
275- make-me-bootable fix (Juraj Ziegler)
276- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
277- removed duplicate entry from makefile
278- if root is /dev/root then assume not a ramdisk
279- reject relative paths if -d flag (Alessandro Polverini)
280- fixed potentially infinite loop in log_to_screen (Tom Mortell)
281- add '/' to custom filelist as workaround for obscure bug
282- ask user speed of CDRW if writing to CD
283- find_cdrom_device() --- if nonexistent/not found then
284 make sure to return '' as dev str and 1 as res
285- tweaked restore scripts tgz
286- cleaned up find_cdrom_device()
287- if user creates /usr/share/mondo/payload.tgz then untar
288 payload to CD at backup-time
289- fixed insist_on_this_cd_number()
290- fixed am_i_in_disaster_recovery_mode()
291- misc clean-up (Tom Mortell)
292- made code more legible
293- fixed post-nuke support
294- added -e support
295- fixed nfs support
296- fixed iso support
297- at restore-time, only sort mountlist internally,
298 in mount_all_devices() and unmount_all_devices()
299- fixed cosmetic bug in label-partitions-as-necessary
300- updated documentation
301- fixed fstab-hacking scripts
302
303* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
304- log newt, slang, ncurses info
305- updated man page
306- handle %% chars in issue.net properly (Heiko Schlittermann)
307- fixed serious NFS restore bug
308- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
309- changed various strcpy() calls to strncpy() calls
310- added mondo-makefilelist to makefile (Mikael Hultgren)
311- mount_cdrom() better at handling multiple CD drives
312- exclude /media/cdrom,cdrecorder,floppy
313- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
314- better logging by eval_call_to_make_ISO()
315- accept -J <fname> to let user provide their own fs catalog
316 instead of -I <paths> to backup
317- if dir excluded with -E or included with -I and dir is actually
318 a softlink then exclude/include the dir pointed to, as well
319- better location for manpage
320- adjusted block size of tarball at start of tape, to help
321 users w/ broken tape driver firmware
322- sort -u fstab after modifying it
323- if backup type is nfs then don't estimate noof media
324- fixed Makefile (Mikael Hultgren)
325- updated manpage
326
327* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
328- new devel branch opened
329
330* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
331- fixed bug in multithreading
332- use new grub-MR instead of grub-install
333- wipe only the partition table (not the MBR) when partitioning drives
334- ignore lilo.conf.anaconda when looking for lilo.conf file
335- accepts '-l RAW' to backup/restore original boot sector instead
336 of running grub or lilo to init it after restoring
337- fixed&updated stabgrub-me script; software RAID + GRUB work now
338- mount/unmount /boot partition for Gentoo 1.2 users
339- re-enabled extra tape checksums
340- disabled spurious warnings
341- unmount/remount supermounts at start/end of live restore, if nec.
342- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
343 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
344- added Makefile
345- added -l RAW, to backup and restore original MBR
346- cleaned up iso_mode() and nfs restoring
347- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
348- made mondorestore CD bootable for ArkLinux users
349- if user runs as 'su' not 'su -' then work around
350
351* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
352- pop-up list of changed files, at end of verification phase
353- better handling of changed.files list at restore-time
354- lots of CD-related fixes
355- added '-N' flag --- to let user exclude all NFS-related mounts&devices
356- better handling of 'kill'
357- restructuring of code to ease integration of mondo w/XMondo
358- fixed obscure bug in find_and_mount_actual_cd()
359- if / or /root has <50MB free then abort & complain
360- fixed install.sh
361- fixed .spec file
362- updated documentation
363- commented code
364- updated man page
365- added -v / --version flag
366- replace convoluted grep with wc (KP)
367- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
368- fixed BurnProof-related bug
369- better at figuring out which is the best partition for temp/scratchdir
370- added do-not-compress-these (text file) to RPM
371- do not compress files of types listed in do-not-compress-these
372- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
373- added Cosgrove's do-not-compress-these list
374- included various patches from KP
375- chmod tmpdir, scratchdir to 700 before using
376- restore from specified backup device, even if its own cfg file disagrees
377- fixed multi-tape bug
378- fixed "Can't find first ISO when verifying nonbootable ISO" bug
379- multithreaded make_afioballs_and_images()
380- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
381 command-line parameters or not
382- fixed bug in strip_spaces() which stopped it from handling
383 small strings correctly - affected mountlist editor
384- create a repaired copy of grub-install which is RAID-friendly;
385 use it when initializing boot sector with run_grub()
386- fixed bug in mondo-makefilelist
387
388* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
389- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
390- during selective restore, skip filesets which don't contain relevant archives
391- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
392- remove /var/run/*.pid after restoring
393- move spurious lockfiles from /home/* to /home/*/.disabled
394- ask user to confirm the tape/CD device name
395- lots of multitape-related fixes
396- added code to autodetect the hardware of the user, if possible
397- if isodir does not exist then abort
398- more sanity-checking for -d flag
399- doubled 'biggiefile' threshold... to 32MB
400- exclude /root/images/mindi
401- fixed multi-imagedev bug (Emmanuel Druon)
402- unmount/remount /mnt/floppy before/after backing up, if Mandrake
403- restructured the source files
404- fixed serious bug in line 1546 - should have been !=, not ==; stopped
405 mondorestore from correctly restoring big files
406- added '#include <signal.h>' to my-stuff.h
407- exclude "incheckentry xwait()" from changed.files
408- fixed minor bug in find_cdrom_device()
409- fixed bug in friendly_sizestr...
410- insist on tape #1 when start verifying
411- added internal buffering, replacing the external 'buffer' exe
412- if differential backup then don't permit formatting or fdisking,
413 whether Interactive or Nuke mode
414- if mondorestore is run on live filesystem (or from ramdisk) without
415 parameters then mondorestore will ask which backup media (tape, CD, etc.)
416 was used; it will read the config file from the media and proceed from there
417- if tape streamer is softlink then resolve it first
418- incorporate post-nuke tarball
419- if user doesn't specify tape size, proceed anyway; behave intelligently
420 in the event of end-of-tape
421- prefix bkpinfo->restore_path to biggiefile fname before generating
422 checksum & comparing to archived biggiefile
423- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
424 then create a softlink from the former to the latter, to work
425 around RH7.3's b0rken LILO support
426- LFS support (mharris, michele, hugo)
427- fixed verify bug --- CD#1 was being verified again & again & ...
428- differential mode fixed; supported again
429- ask user for boot loader + device if not detectible
430- list up to 512 files in file selection window at once (was 128)
431- better handling of bigfiles' checksums, perms and owns
432- delete final filelist if <=2 bytes long
433- if kernel not found and mondo in graphics mode then popup and ask
434 for kernel path+filename
435
436* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
437- 1.5x branch forked off from 1.4x branch
438
439
440
441
Note: See TracBrowser for help on using the repository browser.