source: MondoRescue/branches/stable/mondo-doc/distributions/debian/rules@ 580

Last change on this file since 580 was 580, checked in by bcornec, 18 years ago

Debian configuration files added (Andree Leidenfrost)

  • Property svn:executable set to *
File size: 2.1 KB
Line 
1#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# GNU copyright 1997 to 1999 by Joey Hess.
5
6# Uncomment this to turn on verbose mode.
7#export DH_VERBOSE=1
8
9# Define package name variable for a one-stop change.
10PACKAGE_NAME = mondo-doc
11
12# These are used for cross-compiling and for saving the configure script
13# from having to guess our platform (since we know it already)
14DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
15DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
16
17ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
18 INSTALL_PROGRAM += -s
19endif
20
21# Build both architecture dependent and independent
22build: build-indep
23
24# Build architecture independent
25build-indep: build-indep-stamp
26 # Nothing to do, the only indep item is the manual which is available as html in original source
27 touch build-indep-stamp
28
29# Clean up
30clean:
31 dh_testdir
32 dh_testroot
33 rm -f build-arch-stamp build-indep-stamp #CONFIGURE-STAMP#
34 # Clean temporary document directory
35 rm -rf debian/doc-temp
36 # Clean up.
37 -$(MAKE) distclean
38 rm -f config.log
39ifneq "$(wildcard /usr/share/misc/config.sub)" ""
40 cp -f /usr/share/misc/config.sub config.sub
41endif
42ifneq "$(wildcard /usr/share/misc/config.guess)" ""
43 cp -f /usr/share/misc/config.guess config.guess
44endif
45
46 dh_clean
47
48# Install architecture dependent and independent
49install: install-indep
50
51# Install architecture independent
52install-indep: build-indep
53 dh_testdir
54 dh_testroot
55 dh_clean -k -i
56 dh_installdirs -i
57 dh_install -i
58
59# Must not depend on anything. This is to be called by
60# binary-arch/binary-indep
61# in another 'make' thread.
62binary-common:
63 dh_testdir
64 dh_testroot
65 dh_installchangelogs ChangeLog
66 dh_installdocs
67 dh_installman
68 dh_link
69 dh_strip
70 dh_compress
71 dh_fixperms
72 dh_installdeb
73 dh_shlibdeps
74 dh_gencontrol
75 dh_md5sums
76 dh_builddeb
77
78# Build architecture independant packages using the common target.
79binary-indep: build-indep install-indep
80 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
81
82# Build architecture depdendent and independent packages
83binary: binary-indep
84.PHONY: clean binary
Note: See TracBrowser for help on using the repository browser.