source: MondoRescue/branches/stable/mindi/distributions/rpm/mindi.spec@ 449

Last change on this file since 449 was 449, checked in by bcornec, 18 years ago

mindi.conf created and use in mindi + install.sh + rpm

  • Property svn:keywords set to Id
File size: 1.8 KB
RevLine 
[35]1#
2# $Id: mindi.spec 449 2006-03-20 22:41:31Z bcornec $
3#
[50]4%define name mindi
[237]5%define version VVV
[313]6%define mrel RRR
[388]7%define src SSS
8%define grp GRP
9%define addreqb bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools
10%define addreq DDD
[423]11%define rel %{mrel}
[388]12
[1]13Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
[50]14Name: %name
15Version: %version
[316]16Release: %rel
[1]17License: GPL
[313]18Group: %{grp}
[50]19Url: http://mondorescue.berlios.de
20Source: %{src}
[1]21BuildRoot: %{_tmppath}/%{name}-%{version}
[314]22Requires: %{addreq}
[20]23# Not on all systems
24#Conflicts: bonnie++
[1]25
26%description
27Mindi takes your kernel, modules, tools and libraries, and puts them on N
28bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
29and do system maintenance - e.g. format partitions, backup/restore data,
30verify packages, etc.
31
32%prep
[50]33%{__rm} -rf $RPM_BUILD_ROOT
34%setup -n %name-%{version}
[1]35
36%build
37%ifarch ia64
[50]38%{__make} -f Makefile.parted2fdisk clean
39%{__make} -f Makefile.parted2fdisk
[1]40%endif
41
42%install
[50]43export DONT_RELINK=1
44
[1]45%{__rm} -rf $RPM_BUILD_ROOT
[235]46export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
47export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
[179]48export RPMBUILDMINDI="true"
[50]49
[179]50./install.sh
[50]51
[1]52%clean
53%{__rm} -rf $RPM_BUILD_ROOT
54
55%post
[179]56if [ -f /usr/local/sbin/mindi ]; then
57 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
58fi
59
[1]60%files
[50]61%defattr(644,root,root,755)
[449]62%config(noreplace) %{_sysconfdir}/mindi/deplist.txt %{_sysconfdir}/mindi/mindi.conf
[315]63%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
[423]64%{_mandir}/man8/*
[200]65%{_libdir}/mindi
[449]66%attr(755,root,root) %{_sysconfdir}/mindi/mindi.conf
[189]67%attr(755,root,root) %{_sbindir}/*
[423]68%attr(755,root,root) %{_libdir}/mindi/aux-tools/sbin/*
69%attr(755,root,root) %{_libdir}/mindi/rootfs/bin/*
70%attr(755,root,root) %{_libdir}/mindi/rootfs/sbin/*
[1]71
72%changelog
Note: See TracBrowser for help on using the repository browser.