source: MondoRescue/branches/stable/mindi/distributions/gentoo/mindi.ebuild@ 572

Last change on this file since 572 was 572, checked in by bcornec, 18 years ago

gentoo build continued
mindi bug found due to a previous bug corrected (5.6 MB disks generated systematically):

  • when a disk less than 2.8 MB can be built, not enough modules are put on it to support SCSI cds (use of FLOPPY_MODS only). I added most CDROMs modules in order to support them.
File size: 1.1 KB
Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorescue.org/src/${PVR}.tar.gz"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="~x86 -*"
14IUSE=""
15
16DEPEND="virtual/libc"
17RDEPEND=">=app-arch/bzip2-0.9
18 sys-libs/ncurses
19 sys-devel/binutils
20 sys-fs/dosfstools
21 sys-apps/gawk"
22
23src_unpack() {
24 unpack ${A} || die "Failed to unpack ${A}"
25}
26
27src_install() {
28 export PREFIX="/usr"
29 export CONFDIR="/etc"
30 export DONT_RELINK=1
31 export RPMBUILDMINDI="true"
32 ./install.sh
33}
34
35pkg_postinst() {
36 einfo "${P} was successfully installed."
37 einfo "Please read the associated docs for help."
38 einfo "Or visit the website @ ${HOMEPAGE}"
39 echo
40 ewarn "This package is still in unstable."
41 ewarn "Please report bugs to http://bugs.gentoo.org/"
42 ewarn "However, please do an advanced query to search for bugs"
43 ewarn "before reporting. This will keep down on duplicates."
44 echo
45}
Note: See TracBrowser for help on using the repository browser.