source: MondoRescue/branches/2.2.2/mindi-busybox/distributions/gentoo/mindi-busybox.ebuild@ 1236

Last change on this file since 1236 was 1236, checked in by Bruno Cornec, 17 years ago

Port from stable important patches for 2.2.2:
mindi-busybox:

  • Improve Gentoo packaging

mindi:

  • Better messages for analyze-my-lvm
  • Add support for newer Qlogic drivers (qla2300 & 2400), mpt, dm and ohci
  • Fix a bug in mindi for the FAILSAFE support
  • PATH fixed for init in restore (/usr/games added for petris)
  • Fiw a bug where restore failing because no archive files are found when -G is used
  • /media is now completely excluded as per StandardsCompliance

mondo:

  • Handle no compression + verify correctly
  • various HOWTO fixes
  • Fix temporarily a bug when a biggiefile > 32MB was compressed below the size

of a slice (16MB)

  • Better module loading in insmod_crucial_modules
  • Improve Gentoo packaging
  • Small typo fix for mondorestore man page
  • Small memory management improvements
  • Store NFS config only once
  • Fix a flaw in libmondo-mountlist.c (there since rev [1] !!)
  • Increased MAX_STR_LEN to 384 to make it divisible without remainder by eight

for 64 bits platforms

  • Fix a bug where no bzip2 format file would be found when supporting gzip
  • CentOS fixes
File size: 812 bytes
Line 
1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Id$
4
5inherit eutils flag-o-matic
6
7DESCRIPTION="The rescue part of a program that creates emergency boot disks/CDs using your kernel, tools and modules."
8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
10LICENSE="GPL-2"
11SLOT="0"
12KEYWORDS="~x86 ia64 -*"
13DEPEND="virtual/libc"
14RDEPEND=">=app-arch/bzip2-0.9
15 sys-devel/binutils"
16
17src_unpack() {
18 unpack ${A} || die "Failed to unpack ${A}"
19 make oldconfig > /dev/null
20}
21
22src_compile() {
23 # work around broken ass powerpc compilers
24 emake EXTRA_CFLAGS="${CFLAGS}" busybox || die "build failed"
25}
26
27src_install() {
28 # bundle up the symlink files for use later
29 emake PREFIX="${D}/usr/lib/mindi/rootfs" install || die
30}
Note: See TracBrowser for help on using the repository browser.