source: MondoRescue/branches/2.06/mondo/mondo.spec@ 316

Last change on this file since 316 was 316, checked in by bcornec, 18 years ago

Preparation to support official mandriva builds

  • Property svn:keywords set to Id
File size: 19.1 KB
Line 
1#
2# $Id: mondo.spec 316 2006-01-13 19:44:05Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mondo
11%define version VVV
12%define mrel RRR
13# if mandriva official build (rpm --with is_official)
14%{?is_official:%define rel %{mkrel} %{mrel}}%{!?is_official:%define rel %{mrel}}
15%define src %{name}-%{version}.tgz
16%define grp Archiving/Backup
17%define addreqb mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, newt >= 0.50, slang >= 1.4.1
18
19%if %is_redhat
20%define grp Applications/Archiving
21%define addreq %{addreqb}
22Autoreq: 0
23%endif
24
25%if %is_mandrake
26%define src %{name}-%{version}.tar.bz2
27%define addreq %{addreqb}
28Autoreqprov: no
29%endif
30
31%if %is_mandriva
32%define src %{name}-%{version}.tar.bz2
33%define addreq %{addreqb}
34Autoreqprov: no
35%endif
36
37%if %is_suse
38%define addreq %{addreqb}
39%endif
40
41Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
42Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
43Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
44Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
45
46Name: %{name}
47Version: %{version}
48Release: %{mrel}
49License: GPL
50Group: %{grp}
51Url: http://mondorescue.berlios.de
52Source: %{src}
53BuildRoot: %{_tmppath}/%{name}-%{version}
54BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
55%ifarch ia64
56Requires: %{addreq}, elilo, parted
57%else
58Requires: %{addreq}, syslinux >= 1.52
59%endif
60
61#%package xmondo
62#Summary: A QT based graphical front end for %{name}
63#Group: Applications/Archiving
64#Requires: %{name} = %{version}-${release}, qt, kdelibs
65#
66#%package %{name}-devel
67#Summary: Header files for building against Mondo
68#%if %is_mandrake
69#Group: Development/Libraries
70#%endif
71#if %is_redhat
72#Group: Development/Other
73#%endif
74#Provides: libmondo-devel mondo-devel
75#Obsoletes: libmondo-devel
76#
77#%description -n %{name}-devel
78#Mondo libraries and includes
79
80%description
81Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
82
83%description -l fr
84Objectif
85""""""""
86Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
87
88%description -l it
89Scopo
90"""""
91Mondo e' un programma che permette a qualsiasi utente Linux
92di creare un cd di rescue/restore (o piu' cd qualora l'installazione
93dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
94nastro, ed il NFS, anche.
95
96%description -l sp
97Objectivo
98"""""""""
99Mondo es un programa que permite cualquier usuario de Linux a crear una CD
100de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
101con cintas y NFS, tambien.
102
103#%description xmondo
104#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
105#set up a backup by following onscreen prompts.
106
107%prep
108%setup -q -n %name-%{version}
109
110%build
111%configure %{!?_without_xmondo:--with-x11}
112%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
113
114%install
115%{__rm} -rf $RPM_BUILD_ROOT
116%makeinstall
117%if %is_suse
118%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/doc/%name-%{version}
119%endif
120
121%post
122/sbin/ldconfig
123%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
124
125%postun
126/sbin/ldconfig
127
128%clean
129%{__rm} -rf $RPM_BUILD_ROOT
130
131%files
132%defattr(644,root,root,755)
133%doc ChangeLog svn.log mondo/docs/en/1.6x-howto/*
134%doc INSTALL COPYING README TODO AUTHORS NEWS
135
136%attr(755,root,root) %{_sbindir}/*
137#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
138%{_libdir}
139%{_mandir}
140
141#%{!?_without_xmondo:%files xmondo}
142#%{!?_without_xmondo:%{_sbindir}/xmondo}
143#%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
144#%{!?_without_xmondo:%{_libdir}/libXmondo.so}
145#%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
146
147%changelog
148* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
149- ia64 is now working
150- -p option related bug fixed
151- use libdir instead of datadir
152
153* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
154- Merge of patches mentionned on mondo ML + ia64 updates
155- Add -p option
156
157* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
158- made mondo more clever about finding its home. Avoids mondo considering
159 directories like '/usr/share/doc/momdo' as its home.
160
161* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
162- test sanity of user-specified tempdir
163- better SLES8 support
164
165* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
166- instead of using 'dd' to erase partition table, delete existing
167 partitions w/ the same call to fdisk that is used to create the
168 new partitions; this should avoids locking up the partition table
169- set bootable partition in the above same call to fdisk, for
170 the same reason (avoids locking up the partition table)
171- better software RAID support
172- mount ext3 partitions as ext2 when restoring - better for Debian
173- better star, ACL support
174- added ACL, xattr support for afio users
175
176* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
177- fixed cvs for SuSE systems
178- fixed NTFS backup/restore bug relating to partimagehack
179 log file overflow and NTFS v non-NTFS differentiation
180- more reliable extraction of config info from CDs, floppies
181- better support of ISO dirs at restore-time (Conor Daly)
182- fixed spec file for SuSE users
183- added ldconfig to install section
184
185* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
186- first 2.0 release
187- updated grub-install.patched to support SuSE and Red Hat
188- call 'mt' to set block size to 32K before opening in/out tape
189- updated mondo-prep.c to create each disk's partitions all at once
190 (one call per drive) instead of one call to fdisk per partition
191- when extracting cfg file and mountlist from all.tar.gz (tape copy),
192 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
193- added star and rudimentary SELinux support
194- fixed lots of bugs
195- all logging now goes to /var/log/mondo-archive.log, with symlink
196 to /tmp/mondo-restore.log for restore-time log-tracking
197- added grub-install.patched
198- removed embleer & other binaries
199- added '-b' to specify block size
200- added '-R' for star support
201
202* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
203- ia64 fixes
204
205* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
206- fixed symbolic links for libraries
207- added support for boot/root multi floppies
208
209- added kdelibs as xmondo dependency
210- added xmondo pixmap installation
211- better find_cdrom_device(), to cope w/ multiple CD writers
212- fixed -m and -Vc flags
213- fixed NTFS support!
214- bootable CD uses native, not El Torito, support now
215- removed mondo-makefilelist
216- added 2.6 kernel support
217- if 2.6 kernel, insist that the user specify CD device
218- drop Embleer; insist on ms-sys and parted if Windows partition
219
220* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
221- added -devel package
222
223* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
224- made xmondo a second package
225- added ability to specify --without xmondo at build time
226
227* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
228- Clean up, added spanish translation
229- Set prefix to be /usr
230- added/fixed Requires
231- remove CVS directories prior to building
232
233* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
234- nothing yet
235
236* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
237- fixed chmod/chown bug (Jens Richter)
238- ask user to confirm NFS mountpoint in Interactive Mode
239- rewritten format_everything() to make sure LVMs, RAIDs and
240 regular partitions are prepped in the correct order
241- better magicdev support
242- rewritten external binary caller subroutine
243- DVD support added
244- better backup-time control gui; offer to exclude nfs if appl.
245- fixed multi-tape support
246- re-implemented -D and -J
247- fixed bug in extract_config_file_from_ramdisk() which
248 affected tape+floppy users
249- updated is_incoming_block_valid() to make it
250 return end-of-tape if >300 flotsam blocks
251- unmount CD-ROM before burning (necessary for RH8/9)
252- fixed some stray assert()'s
253- fixed bug in grub-MR (Christian)
254- make user remove floppy/CD before restoring interactively from tape
255- fixed bug in am_I_in_disaster_recovery_mode()
256- added code to nuke_mode() to make sure NFS
257 (backup) share is mounted in Nuke Mode
258- improved tape device detection code
259- better GRUB support
260- better logging of changed bigfiles at compare-time
261- better NTFS support, thanks to partimagehack-static
262- better logging
263- rewrote tape-handling code, breaking compatibility w/ previous versions
264- fixed ISO/CD biggiefile verification bug in mondoarchive
265- fixed bug which stopped boot/compare-time changelist from popping up
266- replaced mondo-makefilelist with C code - faster, cleaner
267- tweaked GUI - better feedback
268
269* Wed May 28 2003 Anonymous <root@rohan> 1.74
270- misc fixes (Michael Hanscho's friend)
271- added rudimentary support for SME
272- added better label support
273- fixed biggietime atime/ctime restoration bug 73
274- fixed 'default boot loader' detection bug (Joshua Oreman)
275- use single-threaded make_afioballs_and_images() if FreeBSD
276- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
277- superior get_phys_size_of_drive() (Joshua Oreman)
278- fixed RAID-related bug in where_is_root_mounted()
279- ISO tweaks
280- fixed silly bug in load_filelist() which stopped
281 funny German filenames from being handled properly
282- fixed various calls to popup_and_get_string()
283- fixed spec file
284- reject -E /
285- added partimagehack to the mix
286
287* Tue May 20 2003 Anonymous <root@rohan> 1.73
288- mark devices as bootable _after_ unmounting them
289- resolve boot device (-f) if softlink
290- post_param_configuration() --- store iso-dev and isodir
291- added post-nuke-sample.tgz to package
292- Nuke Mode now checks mountlist against hardware; offer user
293 opportunity to edit mountlist if insane; if user declines, abort
294- added lots of assert()'s and other checks
295- ran code thru Valgrind to catch & fix some memory leaks
296- made mondo-restore.c smaller by moving some subroutines to
297 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
298- added '-Q' to let user test mondoarchive's ability to find
299 their boot loader and type
300- improved which_boot_loader()
301- when burning or comparing to a CD, defeat autorun if it is
302 running, to avoid confusing mondoarchive and the user
303- if original backup media no longer available at boot-time
304 then offer user chance to choose another media source
305- when booting, type 'nuke noresize' to nuke w/o resizing
306 mountlist to fill your drives
307- add 'textonly' when booting, to avoid using Newt gui
308- run nice(20) to prioritize mondoarchive at start
309- don't pause and wait for next blank CD at backup-time
310 unless necessary (e.g. previous CD has not been removed)
311- get_phys_size_of_drive() --- better support of older drives
312- don't eject if "donteject" is in kernel's command line
313- cleaned up segfault-handling
314- added Conor's strip_path() to improve file list display
315- added Herman Kuster's multi-level bkp patch
316- better boot-time screen/message
317- added Joshua Oreman's FreeBSD patches x3
318- fixed interactive/textonly support
319- fixed support for subdir-within-NFS-mount
320- fixed "Can't backup if ramdisk not mounted" bug
321- try to work around eccentricities of multi-CD drive PCs
322- misc clean-ups (Steve Hindle)
323
324* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
325- LVM/RAID bugs fixed (Brian Borgeson)
326- major clean-up of code (Stan Benoit)
327- make-me-bootable fix (Juraj Ziegler)
328- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
329- removed duplicate entry from makefile
330- if root is /dev/root then assume not a ramdisk
331- reject relative paths if -d flag (Alessandro Polverini)
332- fixed potentially infinite loop in log_to_screen (Tom Mortell)
333- add '/' to custom filelist as workaround for obscure bug
334- ask user speed of CDRW if writing to CD
335- find_cdrom_device() --- if nonexistent/not found then
336 make sure to return '' as dev str and 1 as res
337- tweaked restore scripts tgz
338- cleaned up find_cdrom_device()
339- if user creates /usr/share/mondo/payload.tgz then untar
340 payload to CD at backup-time
341- fixed insist_on_this_cd_number()
342- fixed am_i_in_disaster_recovery_mode()
343- misc clean-up (Tom Mortell)
344- made code more legible
345- fixed post-nuke support
346- added -e support
347- fixed nfs support
348- fixed iso support
349- at restore-time, only sort mountlist internally,
350 in mount_all_devices() and unmount_all_devices()
351- fixed cosmetic bug in label-partitions-as-necessary
352- updated documentation
353- fixed fstab-hacking scripts
354
355* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
356- log newt, slang, ncurses info
357- updated man page
358- handle %% chars in issue.net properly (Heiko Schlittermann)
359- fixed serious NFS restore bug
360- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
361- changed various strcpy() calls to strncpy() calls
362- added mondo-makefilelist to makefile (Mikael Hultgren)
363- mount_cdrom() better at handling multiple CD drives
364- exclude /media/cdrom,cdrecorder,floppy
365- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
366- better logging by eval_call_to_make_ISO()
367- accept -J <fname> to let user provide their own fs catalog
368 instead of -I <paths> to backup
369- if dir excluded with -E or included with -I and dir is actually
370 a softlink then exclude/include the dir pointed to, as well
371- better location for manpage
372- adjusted block size of tarball at start of tape, to help
373 users w/ broken tape driver firmware
374- sort -u fstab after modifying it
375- if backup type is nfs then don't estimate noof media
376- fixed Makefile (Mikael Hultgren)
377- updated manpage
378
379* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
380- new devel branch opened
381
382* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
383- fixed bug in multithreading
384- use new grub-MR instead of grub-install
385- wipe only the partition table (not the MBR) when partitioning drives
386- ignore lilo.conf.anaconda when looking for lilo.conf file
387- accepts '-l RAW' to backup/restore original boot sector instead
388 of running grub or lilo to init it after restoring
389- fixed&updated stabgrub-me script; software RAID + GRUB work now
390- mount/unmount /boot partition for Gentoo 1.2 users
391- re-enabled extra tape checksums
392- disabled spurious warnings
393- unmount/remount supermounts at start/end of live restore, if nec.
394- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
395 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
396- added Makefile
397- added -l RAW, to backup and restore original MBR
398- cleaned up iso_mode() and nfs restoring
399- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
400- made mondorestore CD bootable for ArkLinux users
401- if user runs as 'su' not 'su -' then work around
402
403* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
404- pop-up list of changed files, at end of verification phase
405- better handling of changed.files list at restore-time
406- lots of CD-related fixes
407- added '-N' flag --- to let user exclude all NFS-related mounts&devices
408- better handling of 'kill'
409- restructuring of code to ease integration of mondo w/XMondo
410- fixed obscure bug in find_and_mount_actual_cd()
411- if / or /root has <50MB free then abort & complain
412- fixed install.sh
413- fixed .spec file
414- updated documentation
415- commented code
416- updated man page
417- added -v / --version flag
418- replace convoluted grep with wc (KP)
419- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
420- fixed BurnProof-related bug
421- better at figuring out which is the best partition for temp/scratchdir
422- added do-not-compress-these (text file) to RPM
423- do not compress files of types listed in do-not-compress-these
424- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
425- added Cosgrove's do-not-compress-these list
426- included various patches from KP
427- chmod tmpdir, scratchdir to 700 before using
428- restore from specified backup device, even if its own cfg file disagrees
429- fixed multi-tape bug
430- fixed "Can't find first ISO when verifying nonbootable ISO" bug
431- multithreaded make_afioballs_and_images()
432- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
433 command-line parameters or not
434- fixed bug in strip_spaces() which stopped it from handling
435 small strings correctly - affected mountlist editor
436- create a repaired copy of grub-install which is RAID-friendly;
437 use it when initializing boot sector with run_grub()
438- fixed bug in mondo-makefilelist
439
440* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
441- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
442- during selective restore, skip filesets which don't contain relevant archives
443- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
444- remove /var/run/*.pid after restoring
445- move spurious lockfiles from /home/* to /home/*/.disabled
446- ask user to confirm the tape/CD device name
447- lots of multitape-related fixes
448- added code to autodetect the hardware of the user, if possible
449- if isodir does not exist then abort
450- more sanity-checking for -d flag
451- doubled 'biggiefile' threshold... to 32MB
452- exclude /root/images/mindi
453- fixed multi-imagedev bug (Emmanuel Druon)
454- unmount/remount /mnt/floppy before/after backing up, if Mandrake
455- restructured the source files
456- fixed serious bug in line 1546 - should have been !=, not ==; stopped
457 mondorestore from correctly restoring big files
458- added '#include <signal.h>' to my-stuff.h
459- exclude "incheckentry xwait()" from changed.files
460- fixed minor bug in find_cdrom_device()
461- fixed bug in friendly_sizestr...
462- insist on tape #1 when start verifying
463- added internal buffering, replacing the external 'buffer' exe
464- if differential backup then don't permit formatting or fdisking,
465 whether Interactive or Nuke mode
466- if mondorestore is run on live filesystem (or from ramdisk) without
467 parameters then mondorestore will ask which backup media (tape, CD, etc.)
468 was used; it will read the config file from the media and proceed from there
469- if tape streamer is softlink then resolve it first
470- incorporate post-nuke tarball
471- if user doesn't specify tape size, proceed anyway; behave intelligently
472 in the event of end-of-tape
473- prefix bkpinfo->restore_path to biggiefile fname before generating
474 checksum & comparing to archived biggiefile
475- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
476 then create a softlink from the former to the latter, to work
477 around RH7.3's b0rken LILO support
478- LFS support (mharris, michele, hugo)
479- fixed verify bug --- CD#1 was being verified again & again & ...
480- differential mode fixed; supported again
481- ask user for boot loader + device if not detectible
482- list up to 512 files in file selection window at once (was 128)
483- better handling of bigfiles' checksums, perms and owns
484- delete final filelist if <=2 bytes long
485- if kernel not found and mondo in graphics mode then popup and ask
486 for kernel path+filename
487
488* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
489- 1.5x branch forked off from 1.4x branch
490
491
492
493
Note: See TracBrowser for help on using the repository browser.