source: MondoRescue/branches/2.06/mindi/mindi.spec@ 314

Last change on this file since 314 was 314, checked in by bcornec, 18 years ago

which is not a requirement for SuSE as a separate rpm package

  • Property svn:keywords set to Id
File size: 11.7 KB
Line 
1#
2# $Id: mindi.spec 314 2006-01-13 18:39:20Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mindi
11%define version VVV
12%define mrel RRR
13%define src %{name}-%{version}.tgz
14%define grp Archiving/Backup
15%define addreqb bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools, afio
16
17%if %is_redhat
18%define grp Applications/Archiving
19%define addreq %{addreqb}, which
20Autoreq: 0
21%endif
22
23%if %is_mandrake
24%define src %{name}-%{version}.tar.bz2
25%define addreq %{addreqb}, which
26Autoreqprov: no
27%endif
28
29%if %is_mandriva
30%define src %{name}-%{version}.tar.bz2
31%define addreq %{addreqb}, which
32Autoreqprov: no
33%endif
34
35%if %is_suse
36%define addreq %{addreqb}
37%endif
38
39Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
40Name: %name
41Version: %version
42Release: %mrel
43License: GPL
44Group: %{grp}
45Url: http://mondorescue.berlios.de
46Source: %{src}
47BuildRoot: %{_tmppath}/%{name}-%{version}
48Requires: %{addreq}
49# Not on all systems
50#Conflicts: bonnie++
51
52%description
53Mindi takes your kernel, modules, tools and libraries, and puts them on N
54bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
55and do system maintenance - e.g. format partitions, backup/restore data,
56verify packages, etc.
57
58%prep
59%{__rm} -rf $RPM_BUILD_ROOT
60%setup -n %name-%{version}
61
62%build
63%ifarch ia64
64%{__make} -f Makefile.parted2fdisk clean
65%{__make} -f Makefile.parted2fdisk
66%endif
67
68%install
69export DONT_RELINK=1
70
71%{__rm} -rf $RPM_BUILD_ROOT
72export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
73export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
74export RPMBUILDMINDI="true"
75
76./install.sh
77
78%if %is_suse
79%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/doc/%name-%{version}
80%endif
81
82%clean
83%{__rm} -rf $RPM_BUILD_ROOT
84
85%post
86for i in %{_libdir}/mindi/aux-tools/sbin/* %{_libdir}/mindi/rootfs/bin/* %{_libdir}/mindi/rootfs/sbin/* ; do
87 if [ ! -h $i ]; then
88 %{__chmod} 755 $i
89 fi
90done
91if [ -f /usr/local/sbin/mindi ]; then
92 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
93fi
94
95%files
96%defattr(644,root,root,755)
97%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
98%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox
99%{_mandir}
100%{_libdir}/mindi
101%attr(755,root,root) %{_sbindir}/*
102
103%changelog
104* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
105- ia64 is now working
106- use install.sh script
107- use libdir for binary data
108
109* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
110- Merge of patches mentionned on mondo ML + ia64 updates
111- Fix bugs when called alone
112
113* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
114- supports exec-shield
115
116* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
117- better support of SLES 8
118
119* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
120- better kernel-level logging
121- added ACL, xattr binaries to deplist.txt
122- fixed obscure bug which occasionally stopped mindi from correctly finding
123 and documenting all LVM2 LVM-on-RAID volumes
124
125* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
126- added ide_tape and other modules to mindi's config detection
127- unmount errant ramdisk ($mtpt) if fail to create boot floppy
128- better support of ISO dirs at restore-time (Conor Daly)
129
130* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
131- first 1.0x release
132- busybox now static
133- trap Ctrl-Alt-Del; trigger soft reset
134- better SuSE 9.1 support
135- added parted2fdisk.pl (IA64) (Bruno Cornec)
136- add LVM2 support for kernel 2.6 (Takeru Komoriya)
137- better detection of multiple Mindis (Martin Fürstenau)
138- don't complain if just a Mindi boot CD & not a platform for Mondo
139- updated busybox to 1.0.0pre10
140- removed uClibc
141- add memtest support
142- 2.6 kernel support
143- removed Embleer files (Andree Leidenfrost)
144- added kernel-only floppy support, to accommodate really big kernels
145- updated+rebuilt busybox
146- added star support
147- mount /sys at boot-time
148- better 64-bit and 2.6 kernel support
149- better LVM, failsafe kernel support (Jim Richard)
150- use LILO, not raw kernel, on 1.4MB boot floppy
151- record names of unsaved modules, for future reference
152- enlarged ramdisk by 8MB
153
154* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
155- changed some '==' to '=' --- now more RH6-friendly
156- allow absolute pathnames again in deplist
157- disable multifunc cd thing
158- better Gentoo support (Bill)
159- better OnStream support
160- better Slackware support (Laurenz)
161- added partimagehack-static to deplist.txt
162- recompiled Busybox - now 10k smaller; better stack-handling
163- fixed boot screen typo
164- added support for 'auto' fs format
165- better devfs support for Mandrake users
166- better Debian+LVM support (Ralph Grewe)
167- updated analyze-my-lvm to handle floating-point gigabyte -L values
168
169* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
170- altered rootfs's /dev entry to stop cvs from becoming confused
171- tweaked MAX_COMPRESSED_SIZE
172- added multi-function CD support to mindi and sbin/post-init
173- re-mount root as rw just in case
174- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
175- added support for 5th column in mountlist.txt for labels
176- added symlinks.tgz
177- suppress erroneous error msgs re: failsafe kernel
178
179* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
180- added cciss.o to SCSI_MODS
181- if format type is (e.g.) ext3,ext2 then use 1st entry
182- re-enabled fsck*
183- if cciss in use the enable it at boot-time
184- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
185- better ISO support
186- tweaked Mindi to use 10-15% fewer floppies
187- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
188 to be run by Mindi before it bootstraps to aux data disks;
189 e.g. 'echo engage > /proc/scsi/something'
190- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
191 to be run by Mindi after it boots but before it runs mondorestore
192- allow for Debian & other Stiefkinder that use 'none', not 'swap'
193 as the mountpoint of the swap partition
194- removed afio dependency
195- re-worked install.sh and tarball not to use tgz's
196- cleared up the boot msg
197- updated busybox to 0.60.5; updated uClibc to 0.9.19
198- add #!/bin/sh to start of insert-all-my-modules
199- fixed obscure bug in install-additional-tools
200- changed grep -m to grep | head -n1 for Debian users
201- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
202
203* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
204- fixed LVM/RAID bugs (Brian Borgeson)
205- if bad lilo, give more verbose error before quitting
206- added mt and perl to deplist.txt
207- insist on gawk being present
208- insmod ide-cd, cdrom, isofs, just in case
209- boot-time tmpfs ramdisk is now 40m (was 34m)
210- cleaned up logs
211- iso mode now calls Interactive
212- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
213- clean up some calls to grep, esp. partition_mountpt=...
214- corrected some bashisms, to suit Debian ped- er, users
215- made first line refer to bash, not sh, to make sure
216 the Debian people know Mindi requires bash, not hs
217- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
218- disabled code which would have made Mindi use sfdisk instead of fdisk
219 if it looked as if Debian's fdisk would misbehave
220
221* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
222- new devel branch
223- EXTRA_SPACE=16384
224- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
225- patched analyze-my-lvm (Benjamin Mampaey)
226- detect built-in boot.b files in lilo
227- cleaned up spec file a bit, more use of macros (Jesse Keating)
228- return w/err, don't abort, if Matt Nelson's RH8 system is farked
229- better at finding isolinux.bin
230- better at analyzing dependencies when running on broken distributions
231- try harder to boot from CD, even if tape fails
232- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
233- better resolution of relative softlinks, leading to fewer
234 duplicates on data disks and therefore fewer data disks
235- detect Debian+devfs; use sfdisk instead of fdisk in that
236 eventuality, to work around yet another of Debian's warts
237- removed /lib/libuuid.* from rootfs.tgz
238- fixed vi
239- mindi now uses gawk --traditional (making gawk behave in a functionally
240 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
241- removed / from list of dirs accessed when trying to resolve deplist entry
242- spinner bugfix; handle odd LABELs properly (Tom Mortell)
243- fixed LVM/RAID bugs (Brian Borgeson)
244
245* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
246- misc code clean-up
247- save boot device's boot sector
248- detect and beware Compaq diagnostic partitions
249- better handling of devfs V non-devfs kernels and boot devs
250- trimmed busybox 0.60.3 binary on boot disk
251- mindi now resides in /usr/local/bin
252- removed lilo from dependencies
253- more Gentoo-friendly
254
255* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
256- if your kernel's builddate doesn't match any of the kernels in
257 your /boot directory then fudge the issue & find the closest
258 match (*grumble* Debian)
259- scan tape & CD at start, to force inclusion of modules on boot device
260- double EXTRA_SPACE if >7 disks
261- slimmer, more lithesome logfile
262- now accepts --findkernel
263- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
264- better handling of non-Linux partitions on DevFS-enabled kernels
265- misc clean-ups
266- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
267- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
268- updated kernel to 2.4.18-mdk6
269- generate mountlist in dev-abetical order ;)
270- fixed minor bug in .spec file
271- better at finding /boot/boot.b if your distro breaks the de facto standard
272- fixed minor bug in MakeMountlist
273- fixed install.sh
274- cleaned up deplist.txt
275- added rudimentary -v / --version flag
276- line 1180 or so --- duplicate mindi.iso entries --- fixed
277- added /bin/[ - a softlink to /bin/sh
278- ListAllPartitions() - sanity fix (KP)
279- fixed .spec bug
280- better feedback
281- added Markus's RAID patch
282- ListAllPartitions() - include /mnt/win* (Hugo)
283
284* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
285- better logging by dependency-calculating code
286- better handling of dependencies, specifically softlinks
287- if called by mondo then use mondo's temp dir as our temp dir too
288- changed gawk to $AWK in a few places, to allow for Debian
289- added host* config files to deplist
290- added tftp, ifconfig to busybox
291- added RPC support to uClibc
292- cleaned up creation of Mondo-Mindi configuration file
293- fixed bug in TryToFindKernelPath which stopped it from handling
294 multiple, same-version kernels gracefully
295- cleaned up deplist.txt
296- receive 'DIFFERENTIAL' variable from Mondo
297- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
298- better devfs support; call fgrep in places instead of grep (Andrew Korn)
299- fixed analyze-my-lvm (Ralph Gruwe)
300- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
301- added x11-tools.tgz option
302- updated /dev/console and /dev/tty0 (Paul Stevens)
303- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
304- catch sigint, sighup, etc.
305- fixed LILO-related message.txt mistake
306- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
307- better devfs support (Andrew Korn)
308
309* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
310- fixed RH7.3 readonly bug
311- improved nfs config file creation
312- search more locations for isolinux.bin
313- added isonuke option
314- faster data disk creation
315- better DevFS support (Hector Alvarez, DuckX)
316- nfs-related fix (Hans Lie)
317- abort if vfat filesystem present but mkfs.vfat missing
318- removed softlink to pico
319- allow Mondo to say no compression will be used
320- added [ to ramdisk
321- tar data disks with -b [block size] of 32k
322- don't autoboot to 'RESTORE' screen - it's scary!
323- let user choose lilo or syslinux as boot loader
324- added syslinux support
325- cleaned up message screens
326
Note: See TracBrowser for help on using the repository browser.