source: MondoRescue/branches/2.06/mindi/mindi.spec@ 313

Last change on this file since 313 was 313, checked in by bcornec, 18 years ago

spec file generation adapted (RRR used for revision, suffix now has the '.', Group is now a variable)

  • Property svn:keywords set to Id
File size: 11.6 KB
RevLine 
[35]1#
2# $Id: mindi.spec 313 2006-01-13 18:31:32Z bcornec $
3#
[50]4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mindi
[237]11%define version VVV
[313]12%define mrel RRR
[242]13%define src %{name}-%{version}.tgz
[313]14%define grp Archiving/Backup
[50]15
16%if %is_redhat
[313]17%define grp Applications/Archiving
[50]18Autoreq: 0
19%endif
20
21%if %is_mandrake
22%define src %{name}-%{version}.tar.bz2
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Autoreqprov: no
29%endif
30
[233]31%if %is_suse
32%endif
33
[1]34Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
[50]35Name: %name
36Version: %version
[64]37Release: %mrel
[1]38License: GPL
[313]39Group: %{grp}
[50]40Url: http://mondorescue.berlios.de
41Source: %{src}
[1]42BuildRoot: %{_tmppath}/%{name}-%{version}
[69]43Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools, afio, which
[20]44# Not on all systems
45#Conflicts: bonnie++
[1]46
47%description
48Mindi takes your kernel, modules, tools and libraries, and puts them on N
49bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
50and do system maintenance - e.g. format partitions, backup/restore data,
51verify packages, etc.
52
53%prep
[50]54%{__rm} -rf $RPM_BUILD_ROOT
55%setup -n %name-%{version}
[1]56
57%build
58%ifarch ia64
[50]59%{__make} -f Makefile.parted2fdisk clean
60%{__make} -f Makefile.parted2fdisk
[1]61%endif
62
63%install
[50]64export DONT_RELINK=1
65
[1]66%{__rm} -rf $RPM_BUILD_ROOT
[235]67export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
68export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
[179]69export RPMBUILDMINDI="true"
[50]70
[179]71./install.sh
[50]72
[248]73%if %is_suse
74%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/doc/%name-%{version}
75%endif
76
[1]77%clean
78%{__rm} -rf $RPM_BUILD_ROOT
79
80%post
[241]81for i in %{_libdir}/mindi/aux-tools/sbin/* %{_libdir}/mindi/rootfs/bin/* %{_libdir}/mindi/rootfs/sbin/* ; do
82 if [ ! -h $i ]; then
83 %{__chmod} 755 $i
84 fi
85done
[179]86if [ -f /usr/local/sbin/mindi ]; then
87 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
88fi
89
[1]90%files
[50]91%defattr(644,root,root,755)
[1]92%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
[261]93%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox
[200]94%{_mandir}
95%{_libdir}/mindi
[189]96%attr(755,root,root) %{_sbindir}/*
[1]97
98%changelog
[102]99* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
100- ia64 is now working
[179]101- use install.sh script
102- use libdir for binary data
[102]103
[15]104* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
[12]105- Merge of patches mentionned on mondo ML + ia64 updates
[50]106- Fix bugs when called alone
[12]107
[1]108* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
109- supports exec-shield
110
111* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
112- better support of SLES 8
113
114* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
115- better kernel-level logging
116- added ACL, xattr binaries to deplist.txt
117- fixed obscure bug which occasionally stopped mindi from correctly finding
118 and documenting all LVM2 LVM-on-RAID volumes
119
120* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
121- added ide_tape and other modules to mindi's config detection
122- unmount errant ramdisk ($mtpt) if fail to create boot floppy
123- better support of ISO dirs at restore-time (Conor Daly)
124
125* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
126- first 1.0x release
127- busybox now static
128- trap Ctrl-Alt-Del; trigger soft reset
129- better SuSE 9.1 support
130- added parted2fdisk.pl (IA64) (Bruno Cornec)
131- add LVM2 support for kernel 2.6 (Takeru Komoriya)
132- better detection of multiple Mindis (Martin Fürstenau)
133- don't complain if just a Mindi boot CD & not a platform for Mondo
134- updated busybox to 1.0.0pre10
135- removed uClibc
136- add memtest support
137- 2.6 kernel support
138- removed Embleer files (Andree Leidenfrost)
139- added kernel-only floppy support, to accommodate really big kernels
140- updated+rebuilt busybox
141- added star support
142- mount /sys at boot-time
143- better 64-bit and 2.6 kernel support
144- better LVM, failsafe kernel support (Jim Richard)
145- use LILO, not raw kernel, on 1.4MB boot floppy
146- record names of unsaved modules, for future reference
147- enlarged ramdisk by 8MB
148
149* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
150- changed some '==' to '=' --- now more RH6-friendly
151- allow absolute pathnames again in deplist
152- disable multifunc cd thing
153- better Gentoo support (Bill)
154- better OnStream support
155- better Slackware support (Laurenz)
156- added partimagehack-static to deplist.txt
157- recompiled Busybox - now 10k smaller; better stack-handling
158- fixed boot screen typo
159- added support for 'auto' fs format
160- better devfs support for Mandrake users
161- better Debian+LVM support (Ralph Grewe)
162- updated analyze-my-lvm to handle floating-point gigabyte -L values
163
164* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
165- altered rootfs's /dev entry to stop cvs from becoming confused
166- tweaked MAX_COMPRESSED_SIZE
167- added multi-function CD support to mindi and sbin/post-init
168- re-mount root as rw just in case
169- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
170- added support for 5th column in mountlist.txt for labels
171- added symlinks.tgz
172- suppress erroneous error msgs re: failsafe kernel
173
174* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
175- added cciss.o to SCSI_MODS
176- if format type is (e.g.) ext3,ext2 then use 1st entry
177- re-enabled fsck*
178- if cciss in use the enable it at boot-time
179- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
180- better ISO support
181- tweaked Mindi to use 10-15% fewer floppies
182- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
183 to be run by Mindi before it bootstraps to aux data disks;
184 e.g. 'echo engage > /proc/scsi/something'
185- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
186 to be run by Mindi after it boots but before it runs mondorestore
187- allow for Debian & other Stiefkinder that use 'none', not 'swap'
188 as the mountpoint of the swap partition
189- removed afio dependency
190- re-worked install.sh and tarball not to use tgz's
191- cleared up the boot msg
192- updated busybox to 0.60.5; updated uClibc to 0.9.19
193- add #!/bin/sh to start of insert-all-my-modules
194- fixed obscure bug in install-additional-tools
195- changed grep -m to grep | head -n1 for Debian users
196- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
197
198* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
199- fixed LVM/RAID bugs (Brian Borgeson)
200- if bad lilo, give more verbose error before quitting
201- added mt and perl to deplist.txt
202- insist on gawk being present
203- insmod ide-cd, cdrom, isofs, just in case
204- boot-time tmpfs ramdisk is now 40m (was 34m)
205- cleaned up logs
206- iso mode now calls Interactive
207- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
208- clean up some calls to grep, esp. partition_mountpt=...
209- corrected some bashisms, to suit Debian ped- er, users
210- made first line refer to bash, not sh, to make sure
211 the Debian people know Mindi requires bash, not hs
212- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
213- disabled code which would have made Mindi use sfdisk instead of fdisk
214 if it looked as if Debian's fdisk would misbehave
215
216* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
217- new devel branch
218- EXTRA_SPACE=16384
219- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
220- patched analyze-my-lvm (Benjamin Mampaey)
221- detect built-in boot.b files in lilo
222- cleaned up spec file a bit, more use of macros (Jesse Keating)
223- return w/err, don't abort, if Matt Nelson's RH8 system is farked
224- better at finding isolinux.bin
225- better at analyzing dependencies when running on broken distributions
226- try harder to boot from CD, even if tape fails
227- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
228- better resolution of relative softlinks, leading to fewer
229 duplicates on data disks and therefore fewer data disks
230- detect Debian+devfs; use sfdisk instead of fdisk in that
231 eventuality, to work around yet another of Debian's warts
232- removed /lib/libuuid.* from rootfs.tgz
233- fixed vi
234- mindi now uses gawk --traditional (making gawk behave in a functionally
235 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
236- removed / from list of dirs accessed when trying to resolve deplist entry
237- spinner bugfix; handle odd LABELs properly (Tom Mortell)
238- fixed LVM/RAID bugs (Brian Borgeson)
239
240* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
241- misc code clean-up
242- save boot device's boot sector
243- detect and beware Compaq diagnostic partitions
244- better handling of devfs V non-devfs kernels and boot devs
245- trimmed busybox 0.60.3 binary on boot disk
246- mindi now resides in /usr/local/bin
247- removed lilo from dependencies
248- more Gentoo-friendly
249
250* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
251- if your kernel's builddate doesn't match any of the kernels in
252 your /boot directory then fudge the issue & find the closest
253 match (*grumble* Debian)
254- scan tape & CD at start, to force inclusion of modules on boot device
255- double EXTRA_SPACE if >7 disks
256- slimmer, more lithesome logfile
257- now accepts --findkernel
258- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
259- better handling of non-Linux partitions on DevFS-enabled kernels
260- misc clean-ups
261- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
262- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
263- updated kernel to 2.4.18-mdk6
264- generate mountlist in dev-abetical order ;)
265- fixed minor bug in .spec file
266- better at finding /boot/boot.b if your distro breaks the de facto standard
267- fixed minor bug in MakeMountlist
268- fixed install.sh
269- cleaned up deplist.txt
270- added rudimentary -v / --version flag
271- line 1180 or so --- duplicate mindi.iso entries --- fixed
272- added /bin/[ - a softlink to /bin/sh
273- ListAllPartitions() - sanity fix (KP)
274- fixed .spec bug
275- better feedback
276- added Markus's RAID patch
277- ListAllPartitions() - include /mnt/win* (Hugo)
278
279* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
280- better logging by dependency-calculating code
281- better handling of dependencies, specifically softlinks
282- if called by mondo then use mondo's temp dir as our temp dir too
283- changed gawk to $AWK in a few places, to allow for Debian
284- added host* config files to deplist
285- added tftp, ifconfig to busybox
286- added RPC support to uClibc
287- cleaned up creation of Mondo-Mindi configuration file
288- fixed bug in TryToFindKernelPath which stopped it from handling
289 multiple, same-version kernels gracefully
290- cleaned up deplist.txt
291- receive 'DIFFERENTIAL' variable from Mondo
292- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
293- better devfs support; call fgrep in places instead of grep (Andrew Korn)
294- fixed analyze-my-lvm (Ralph Gruwe)
295- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
296- added x11-tools.tgz option
297- updated /dev/console and /dev/tty0 (Paul Stevens)
298- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
299- catch sigint, sighup, etc.
300- fixed LILO-related message.txt mistake
301- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
302- better devfs support (Andrew Korn)
303
304* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
305- fixed RH7.3 readonly bug
306- improved nfs config file creation
307- search more locations for isolinux.bin
308- added isonuke option
309- faster data disk creation
310- better DevFS support (Hector Alvarez, DuckX)
311- nfs-related fix (Hans Lie)
312- abort if vfat filesystem present but mkfs.vfat missing
313- removed softlink to pico
314- allow Mondo to say no compression will be used
315- added [ to ramdisk
316- tar data disks with -b [block size] of 32k
317- don't autoboot to 'RESTORE' screen - it's scary!
318- let user choose lilo or syslinux as boot loader
319- added syslinux support
320- cleaned up message screens
321
Note: See TracBrowser for help on using the repository browser.