source: MondoRescue/branches/2.05/mondo/mondo.spec@ 179

Last change on this file since 179 was 179, checked in by bcornec, 18 years ago

New locations for mondo and mindi:

for distros for file base install


/usr/sbin/mindi /usr/local/sbin/mindi
/usr/sbin/analyze-my-lvm /usr/local/sbin/analyze-my-lvm
/usr/sbin/mondoarchive /usr/local/sbin/mondoarchive
/usr/sbin/mondorestore /usr/local/sbin/mondorestore
/etc/m?nd? /usr/local/etc/m?nd?
/usr/share/doc/m?nd?* /usr/local/share/doc/m?nd?*
/usr/share/man/man8/m?nd?*.8 /usr/local/share/man/man8/m?nd?*.8
/usr/lib/m?nd? /usr/local/lib/m?nd?

(mondo needs to be finished - untested yet)

  • Property svn:keywords set to Id
File size: 19.0 KB
Line 
1#
2# $Id: mondo.spec 179 2005-12-12 18:50:21Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mondo
11%define version 2.05
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32
33Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
34Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
35Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
36Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
37
38Name: %{name}
39Version: %{version}
40Release: %{mrel}
41License: GPL
42Url: http://mondorescue.berlios.de
43Source: %{src}
44BuildRoot: %{_tmppath}/%{name}-%{version}
45BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
46%ifarch ia64
47Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
48%{!?_without_xmondo:BuildRequires: gcc-c++, XFree86-devel, qt-devel, kdelibs-devel, libpng-devel}
49%else
50Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, cdrecord, buffer
51%{!?_without_xmondo:BuildRequires: gcc-c++, XFree86-devel, qt-devel, kdelibs-devel, arts-devel, libart_lgpl-devel, libpng-devel}
52%endif
53
54#%package xmondo
55#Summary: A QT based graphical front end for %{name}
56#Group: Applications/Archiving
57#Requires: %{name} = %{version}-${release}, qt, kdelibs
58#
59#%package %{name}-devel
60#Summary: Header files for building against Mondo
61#%if %is_mandrake
62#Group: Development/Libraries
63#%endif
64#if %is_redhat
65#Group: Development/Other
66#%endif
67#Provides: libmondo-devel mondo-devel
68#Obsoletes: libmondo-devel
69#
70#%description -n %{name}-devel
71#Mondo libraries and includes
72
73%description
74Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
75
76%description -l fr
77Objectif
78""""""""
79Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
80
81%description -l it
82Scopo
83"""""
84Mondo e' un programma che permette a qualsiasi utente Linux
85di creare un cd di rescue/restore (o piu' cd qualora l'installazione
86dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
87nastro, ed il NFS, anche.
88
89%description -l sp
90Objectivo
91"""""""""
92Mondo es un programa que permite cualquier usuario de Linux a crear una CD
93de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
94con cintas y NFS, tambien.
95
96#%description xmondo
97#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
98#set up a backup by following onscreen prompts.
99
100%prep
101%setup -q -n %name-%{version}
102
103%build
104%configure %{!?_without_xmondo:--with-x11}
105%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
106
107%install
108%{__rm} -rf $RPM_BUILD_ROOT
109%makeinstall
110
111%post
112/sbin/ldconfig
113
114%postun
115/sbin/ldconfig
116
117%clean
118%{__rm} -rf $RPM_BUILD_ROOT
119
120%files
121%defattr(644,root,root,755)
122%doc ChangeLog mondo/docs/en/1.6x-howto/*
123%doc INSTALL COPYING README TODO AUTHORS NEWS
124
125%attr(755,root,root) %{_sbindir}/*
126%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}
127%{_libdir}/%{name}
128%{_mandir}/*
129%{_libdir}/*
130
131#%{!?_without_xmondo:%files xmondo}
132#%{!?_without_xmondo:%{_sbindir}/xmondo}
133#%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
134#%{!?_without_xmondo:%{_libdir}/libXmondo.so}
135#%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
136
137%changelog
138* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
139- ia64 is now working
140- -p option related bug fixed
141- use libdir instead of datadir
142
143* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
144- Merge of patches mentionned on mondo ML + ia64 updates
145- Add -p option
146
147* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
148- made mondo more clever about finding its home. Avoids mondo considering
149 directories like '/usr/share/doc/momdo' as its home.
150
151* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
152- test sanity of user-specified tempdir
153- better SLES8 support
154
155* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
156- instead of using 'dd' to erase partition table, delete existing
157 partitions w/ the same call to fdisk that is used to create the
158 new partitions; this should avoids locking up the partition table
159- set bootable partition in the above same call to fdisk, for
160 the same reason (avoids locking up the partition table)
161- better software RAID support
162- mount ext3 partitions as ext2 when restoring - better for Debian
163- better star, ACL support
164- added ACL, xattr support for afio users
165
166* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
167- fixed cvs for SuSE systems
168- fixed NTFS backup/restore bug relating to partimagehack
169 log file overflow and NTFS v non-NTFS differentiation
170- more reliable extraction of config info from CDs, floppies
171- better support of ISO dirs at restore-time (Conor Daly)
172- fixed spec file for SuSE users
173- added ldconfig to install section
174
175* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
176- first 2.0 release
177- updated grub-install.patched to support SuSE and Red Hat
178- call 'mt' to set block size to 32K before opening in/out tape
179- updated mondo-prep.c to create each disk's partitions all at once
180 (one call per drive) instead of one call to fdisk per partition
181- when extracting cfg file and mountlist from all.tar.gz (tape copy),
182 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
183- added star and rudimentary SELinux support
184- fixed lots of bugs
185- all logging now goes to /var/log/mondo-archive.log, with symlink
186 to /tmp/mondo-restore.log for restore-time log-tracking
187- added grub-install.patched
188- removed embleer & other binaries
189- added '-b' to specify block size
190- added '-R' for star support
191
192* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
193- ia64 fixes
194
195* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
196- fixed symbolic links for libraries
197- added support for boot/root multi floppies
198
199- added kdelibs as xmondo dependency
200- added xmondo pixmap installation
201- better find_cdrom_device(), to cope w/ multiple CD writers
202- fixed -m and -Vc flags
203- fixed NTFS support!
204- bootable CD uses native, not El Torito, support now
205- removed mondo-makefilelist
206- added 2.6 kernel support
207- if 2.6 kernel, insist that the user specify CD device
208- drop Embleer; insist on ms-sys and parted if Windows partition
209
210* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
211- added -devel package
212
213* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
214- made xmondo a second package
215- added ability to specify --without xmondo at build time
216
217* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
218- Clean up, added spanish translation
219- Set prefix to be /usr
220- added/fixed Requires
221- remove CVS directories prior to building
222
223* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
224- nothing yet
225
226* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
227- fixed chmod/chown bug (Jens Richter)
228- ask user to confirm NFS mountpoint in Interactive Mode
229- rewritten format_everything() to make sure LVMs, RAIDs and
230 regular partitions are prepped in the correct order
231- better magicdev support
232- rewritten external binary caller subroutine
233- DVD support added
234- better backup-time control gui; offer to exclude nfs if appl.
235- fixed multi-tape support
236- re-implemented -D and -J
237- fixed bug in extract_config_file_from_ramdisk() which
238 affected tape+floppy users
239- updated is_incoming_block_valid() to make it
240 return end-of-tape if >300 flotsam blocks
241- unmount CD-ROM before burning (necessary for RH8/9)
242- fixed some stray assert()'s
243- fixed bug in grub-MR (Christian)
244- make user remove floppy/CD before restoring interactively from tape
245- fixed bug in am_I_in_disaster_recovery_mode()
246- added code to nuke_mode() to make sure NFS
247 (backup) share is mounted in Nuke Mode
248- improved tape device detection code
249- better GRUB support
250- better logging of changed bigfiles at compare-time
251- better NTFS support, thanks to partimagehack-static
252- better logging
253- rewrote tape-handling code, breaking compatibility w/ previous versions
254- fixed ISO/CD biggiefile verification bug in mondoarchive
255- fixed bug which stopped boot/compare-time changelist from popping up
256- replaced mondo-makefilelist with C code - faster, cleaner
257- tweaked GUI - better feedback
258
259* Wed May 28 2003 Anonymous <root@rohan> 1.74
260- misc fixes (Michael Hanscho's friend)
261- added rudimentary support for SME
262- added better label support
263- fixed biggietime atime/ctime restoration bug 73
264- fixed 'default boot loader' detection bug (Joshua Oreman)
265- use single-threaded make_afioballs_and_images() if FreeBSD
266- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
267- superior get_phys_size_of_drive() (Joshua Oreman)
268- fixed RAID-related bug in where_is_root_mounted()
269- ISO tweaks
270- fixed silly bug in load_filelist() which stopped
271 funny German filenames from being handled properly
272- fixed various calls to popup_and_get_string()
273- fixed spec file
274- reject -E /
275- added partimagehack to the mix
276
277* Tue May 20 2003 Anonymous <root@rohan> 1.73
278- mark devices as bootable _after_ unmounting them
279- resolve boot device (-f) if softlink
280- post_param_configuration() --- store iso-dev and isodir
281- added post-nuke-sample.tgz to package
282- Nuke Mode now checks mountlist against hardware; offer user
283 opportunity to edit mountlist if insane; if user declines, abort
284- added lots of assert()'s and other checks
285- ran code thru Valgrind to catch & fix some memory leaks
286- made mondo-restore.c smaller by moving some subroutines to
287 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
288- added '-Q' to let user test mondoarchive's ability to find
289 their boot loader and type
290- improved which_boot_loader()
291- when burning or comparing to a CD, defeat autorun if it is
292 running, to avoid confusing mondoarchive and the user
293- if original backup media no longer available at boot-time
294 then offer user chance to choose another media source
295- when booting, type 'nuke noresize' to nuke w/o resizing
296 mountlist to fill your drives
297- add 'textonly' when booting, to avoid using Newt gui
298- run nice(20) to prioritize mondoarchive at start
299- don't pause and wait for next blank CD at backup-time
300 unless necessary (e.g. previous CD has not been removed)
301- get_phys_size_of_drive() --- better support of older drives
302- don't eject if "donteject" is in kernel's command line
303- cleaned up segfault-handling
304- added Conor's strip_path() to improve file list display
305- added Herman Kuster's multi-level bkp patch
306- better boot-time screen/message
307- added Joshua Oreman's FreeBSD patches x3
308- fixed interactive/textonly support
309- fixed support for subdir-within-NFS-mount
310- fixed "Can't backup if ramdisk not mounted" bug
311- try to work around eccentricities of multi-CD drive PCs
312- misc clean-ups (Steve Hindle)
313
314* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
315- LVM/RAID bugs fixed (Brian Borgeson)
316- major clean-up of code (Stan Benoit)
317- make-me-bootable fix (Juraj Ziegler)
318- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
319- removed duplicate entry from makefile
320- if root is /dev/root then assume not a ramdisk
321- reject relative paths if -d flag (Alessandro Polverini)
322- fixed potentially infinite loop in log_to_screen (Tom Mortell)
323- add '/' to custom filelist as workaround for obscure bug
324- ask user speed of CDRW if writing to CD
325- find_cdrom_device() --- if nonexistent/not found then
326 make sure to return '' as dev str and 1 as res
327- tweaked restore scripts tgz
328- cleaned up find_cdrom_device()
329- if user creates /usr/share/mondo/payload.tgz then untar
330 payload to CD at backup-time
331- fixed insist_on_this_cd_number()
332- fixed am_i_in_disaster_recovery_mode()
333- misc clean-up (Tom Mortell)
334- made code more legible
335- fixed post-nuke support
336- added -e support
337- fixed nfs support
338- fixed iso support
339- at restore-time, only sort mountlist internally,
340 in mount_all_devices() and unmount_all_devices()
341- fixed cosmetic bug in label-partitions-as-necessary
342- updated documentation
343- fixed fstab-hacking scripts
344
345* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
346- log newt, slang, ncurses info
347- updated man page
348- handle %% chars in issue.net properly (Heiko Schlittermann)
349- fixed serious NFS restore bug
350- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
351- changed various strcpy() calls to strncpy() calls
352- added mondo-makefilelist to makefile (Mikael Hultgren)
353- mount_cdrom() better at handling multiple CD drives
354- exclude /media/cdrom,cdrecorder,floppy
355- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
356- better logging by eval_call_to_make_ISO()
357- accept -J <fname> to let user provide their own fs catalog
358 instead of -I <paths> to backup
359- if dir excluded with -E or included with -I and dir is actually
360 a softlink then exclude/include the dir pointed to, as well
361- better location for manpage
362- adjusted block size of tarball at start of tape, to help
363 users w/ broken tape driver firmware
364- sort -u fstab after modifying it
365- if backup type is nfs then don't estimate noof media
366- fixed Makefile (Mikael Hultgren)
367- updated manpage
368
369* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
370- new devel branch opened
371
372* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
373- fixed bug in multithreading
374- use new grub-MR instead of grub-install
375- wipe only the partition table (not the MBR) when partitioning drives
376- ignore lilo.conf.anaconda when looking for lilo.conf file
377- accepts '-l RAW' to backup/restore original boot sector instead
378 of running grub or lilo to init it after restoring
379- fixed&updated stabgrub-me script; software RAID + GRUB work now
380- mount/unmount /boot partition for Gentoo 1.2 users
381- re-enabled extra tape checksums
382- disabled spurious warnings
383- unmount/remount supermounts at start/end of live restore, if nec.
384- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
385 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
386- added Makefile
387- added -l RAW, to backup and restore original MBR
388- cleaned up iso_mode() and nfs restoring
389- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
390- made mondorestore CD bootable for ArkLinux users
391- if user runs as 'su' not 'su -' then work around
392
393* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
394- pop-up list of changed files, at end of verification phase
395- better handling of changed.files list at restore-time
396- lots of CD-related fixes
397- added '-N' flag --- to let user exclude all NFS-related mounts&devices
398- better handling of 'kill'
399- restructuring of code to ease integration of mondo w/XMondo
400- fixed obscure bug in find_and_mount_actual_cd()
401- if / or /root has <50MB free then abort & complain
402- fixed install.sh
403- fixed .spec file
404- updated documentation
405- commented code
406- updated man page
407- added -v / --version flag
408- replace convoluted grep with wc (KP)
409- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
410- fixed BurnProof-related bug
411- better at figuring out which is the best partition for temp/scratchdir
412- added do-not-compress-these (text file) to RPM
413- do not compress files of types listed in do-not-compress-these
414- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
415- added Cosgrove's do-not-compress-these list
416- included various patches from KP
417- chmod tmpdir, scratchdir to 700 before using
418- restore from specified backup device, even if its own cfg file disagrees
419- fixed multi-tape bug
420- fixed "Can't find first ISO when verifying nonbootable ISO" bug
421- multithreaded make_afioballs_and_images()
422- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
423 command-line parameters or not
424- fixed bug in strip_spaces() which stopped it from handling
425 small strings correctly - affected mountlist editor
426- create a repaired copy of grub-install which is RAID-friendly;
427 use it when initializing boot sector with run_grub()
428- fixed bug in mondo-makefilelist
429
430* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
431- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
432- during selective restore, skip filesets which don't contain relevant archives
433- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
434- remove /var/run/*.pid after restoring
435- move spurious lockfiles from /home/* to /home/*/.disabled
436- ask user to confirm the tape/CD device name
437- lots of multitape-related fixes
438- added code to autodetect the hardware of the user, if possible
439- if isodir does not exist then abort
440- more sanity-checking for -d flag
441- doubled 'biggiefile' threshold... to 32MB
442- exclude /root/images/mindi
443- fixed multi-imagedev bug (Emmanuel Druon)
444- unmount/remount /mnt/floppy before/after backing up, if Mandrake
445- restructured the source files
446- fixed serious bug in line 1546 - should have been !=, not ==; stopped
447 mondorestore from correctly restoring big files
448- added '#include <signal.h>' to my-stuff.h
449- exclude "incheckentry xwait()" from changed.files
450- fixed minor bug in find_cdrom_device()
451- fixed bug in friendly_sizestr...
452- insist on tape #1 when start verifying
453- added internal buffering, replacing the external 'buffer' exe
454- if differential backup then don't permit formatting or fdisking,
455 whether Interactive or Nuke mode
456- if mondorestore is run on live filesystem (or from ramdisk) without
457 parameters then mondorestore will ask which backup media (tape, CD, etc.)
458 was used; it will read the config file from the media and proceed from there
459- if tape streamer is softlink then resolve it first
460- incorporate post-nuke tarball
461- if user doesn't specify tape size, proceed anyway; behave intelligently
462 in the event of end-of-tape
463- prefix bkpinfo->restore_path to biggiefile fname before generating
464 checksum & comparing to archived biggiefile
465- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
466 then create a softlink from the former to the latter, to work
467 around RH7.3's b0rken LILO support
468- LFS support (mharris, michele, hugo)
469- fixed verify bug --- CD#1 was being verified again & again & ...
470- differential mode fixed; supported again
471- ask user for boot loader + device if not detectible
472- list up to 512 files in file selection window at once (was 128)
473- better handling of bigfiles' checksums, perms and owns
474- delete final filelist if <=2 bytes long
475- if kernel not found and mondo in graphics mode then popup and ask
476 for kernel path+filename
477
478* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
479- 1.5x branch forked off from 1.4x branch
480
481
482
483
Note: See TracBrowser for help on using the repository browser.