source: MondoRescue/branches/2.05/mindi/mindi.spec@ 196

Last change on this file since 196 was 196, checked in by bcornec, 18 years ago

Usage of parted2fdisk instead of fdisk everywhere.
on ia64 this is mandatory, and simplifies the infrastructure
on other archs, it doesn't change anything as parted2fdisk here is a link to fdisk

  • Property svn:keywords set to Id
File size: 11.5 KB
Line 
1#
2# $Id: mindi.spec 196 2005-12-13 23:04:21Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mindi
11%define version 1.05
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
33Name: %name
34Version: %version
35Release: %mrel
36License: GPL
37Group: System/Kernel and hardware
38Url: http://mondorescue.berlios.de
39Source: %{src}
40BuildRoot: %{_tmppath}/%{name}-%{version}
41Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools, afio, which
42# Not on all systems
43#Conflicts: bonnie++
44
45%description
46Mindi takes your kernel, modules, tools and libraries, and puts them on N
47bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
48and do system maintenance - e.g. format partitions, backup/restore data,
49verify packages, etc.
50
51%prep
52%{__rm} -rf $RPM_BUILD_ROOT
53%setup -n %name-%{version}
54
55%build
56%ifarch ia64
57%{__make} -f Makefile.parted2fdisk clean
58%{__make} -f Makefile.parted2fdisk
59%endif
60
61%install
62export DONT_RELINK=1
63
64%{__rm} -rf $RPM_BUILD_ROOT
65MINDIDIR=$RPM_BUILD_ROOT%{_libdir}/mindi
66export PREFIX=${RPM_BUILD_ROOT}
67export RPMBUILDMINDI="true"
68
69./install.sh
70
71%{__rm} -f $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox-i386.net
72
73%clean
74%{__rm} -rf $RPM_BUILD_ROOT
75
76%post
77if [ -f /usr/local/sbin/mindi ]; then
78 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
79fi
80
81%files
82%defattr(644,root,root,755)
83%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
84%doc CHANGES INSTALL COPYING README TODO README.ia64 README.pxe README.busybox
85%attr(755,root,root) %{_sbindir}/*
86%{_libdir}/mindi
87%{_mandir}
88
89%changelog
90* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
91- ia64 is now working
92- use install.sh script
93- use libdir for binary data
94
95* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
96- Merge of patches mentionned on mondo ML + ia64 updates
97- Fix bugs when called alone
98
99* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
100- supports exec-shield
101
102* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
103- better support of SLES 8
104
105* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
106- better kernel-level logging
107- added ACL, xattr binaries to deplist.txt
108- fixed obscure bug which occasionally stopped mindi from correctly finding
109 and documenting all LVM2 LVM-on-RAID volumes
110
111* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
112- added ide_tape and other modules to mindi's config detection
113- unmount errant ramdisk ($mtpt) if fail to create boot floppy
114- better support of ISO dirs at restore-time (Conor Daly)
115
116* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
117- first 1.0x release
118- busybox now static
119- trap Ctrl-Alt-Del; trigger soft reset
120- better SuSE 9.1 support
121- added parted2fdisk.pl (IA64) (Bruno Cornec)
122- add LVM2 support for kernel 2.6 (Takeru Komoriya)
123- better detection of multiple Mindis (Martin Fürstenau)
124- don't complain if just a Mindi boot CD & not a platform for Mondo
125- updated busybox to 1.0.0pre10
126- removed uClibc
127- add memtest support
128- 2.6 kernel support
129- removed Embleer files (Andree Leidenfrost)
130- added kernel-only floppy support, to accommodate really big kernels
131- updated+rebuilt busybox
132- added star support
133- mount /sys at boot-time
134- better 64-bit and 2.6 kernel support
135- better LVM, failsafe kernel support (Jim Richard)
136- use LILO, not raw kernel, on 1.4MB boot floppy
137- record names of unsaved modules, for future reference
138- enlarged ramdisk by 8MB
139
140* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
141- changed some '==' to '=' --- now more RH6-friendly
142- allow absolute pathnames again in deplist
143- disable multifunc cd thing
144- better Gentoo support (Bill)
145- better OnStream support
146- better Slackware support (Laurenz)
147- added partimagehack-static to deplist.txt
148- recompiled Busybox - now 10k smaller; better stack-handling
149- fixed boot screen typo
150- added support for 'auto' fs format
151- better devfs support for Mandrake users
152- better Debian+LVM support (Ralph Grewe)
153- updated analyze-my-lvm to handle floating-point gigabyte -L values
154
155* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
156- altered rootfs's /dev entry to stop cvs from becoming confused
157- tweaked MAX_COMPRESSED_SIZE
158- added multi-function CD support to mindi and sbin/post-init
159- re-mount root as rw just in case
160- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
161- added support for 5th column in mountlist.txt for labels
162- added symlinks.tgz
163- suppress erroneous error msgs re: failsafe kernel
164
165* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
166- added cciss.o to SCSI_MODS
167- if format type is (e.g.) ext3,ext2 then use 1st entry
168- re-enabled fsck*
169- if cciss in use the enable it at boot-time
170- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
171- better ISO support
172- tweaked Mindi to use 10-15% fewer floppies
173- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
174 to be run by Mindi before it bootstraps to aux data disks;
175 e.g. 'echo engage > /proc/scsi/something'
176- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
177 to be run by Mindi after it boots but before it runs mondorestore
178- allow for Debian & other Stiefkinder that use 'none', not 'swap'
179 as the mountpoint of the swap partition
180- removed afio dependency
181- re-worked install.sh and tarball not to use tgz's
182- cleared up the boot msg
183- updated busybox to 0.60.5; updated uClibc to 0.9.19
184- add #!/bin/sh to start of insert-all-my-modules
185- fixed obscure bug in install-additional-tools
186- changed grep -m to grep | head -n1 for Debian users
187- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
188
189* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
190- fixed LVM/RAID bugs (Brian Borgeson)
191- if bad lilo, give more verbose error before quitting
192- added mt and perl to deplist.txt
193- insist on gawk being present
194- insmod ide-cd, cdrom, isofs, just in case
195- boot-time tmpfs ramdisk is now 40m (was 34m)
196- cleaned up logs
197- iso mode now calls Interactive
198- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
199- clean up some calls to grep, esp. partition_mountpt=...
200- corrected some bashisms, to suit Debian ped- er, users
201- made first line refer to bash, not sh, to make sure
202 the Debian people know Mindi requires bash, not hs
203- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
204- disabled code which would have made Mindi use sfdisk instead of fdisk
205 if it looked as if Debian's fdisk would misbehave
206
207* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
208- new devel branch
209- EXTRA_SPACE=16384
210- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
211- patched analyze-my-lvm (Benjamin Mampaey)
212- detect built-in boot.b files in lilo
213- cleaned up spec file a bit, more use of macros (Jesse Keating)
214- return w/err, don't abort, if Matt Nelson's RH8 system is farked
215- better at finding isolinux.bin
216- better at analyzing dependencies when running on broken distributions
217- try harder to boot from CD, even if tape fails
218- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
219- better resolution of relative softlinks, leading to fewer
220 duplicates on data disks and therefore fewer data disks
221- detect Debian+devfs; use sfdisk instead of fdisk in that
222 eventuality, to work around yet another of Debian's warts
223- removed /lib/libuuid.* from rootfs.tgz
224- fixed vi
225- mindi now uses gawk --traditional (making gawk behave in a functionally
226 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
227- removed / from list of dirs accessed when trying to resolve deplist entry
228- spinner bugfix; handle odd LABELs properly (Tom Mortell)
229- fixed LVM/RAID bugs (Brian Borgeson)
230
231* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
232- misc code clean-up
233- save boot device's boot sector
234- detect and beware Compaq diagnostic partitions
235- better handling of devfs V non-devfs kernels and boot devs
236- trimmed busybox 0.60.3 binary on boot disk
237- mindi now resides in /usr/local/bin
238- removed lilo from dependencies
239- more Gentoo-friendly
240
241* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
242- if your kernel's builddate doesn't match any of the kernels in
243 your /boot directory then fudge the issue & find the closest
244 match (*grumble* Debian)
245- scan tape & CD at start, to force inclusion of modules on boot device
246- double EXTRA_SPACE if >7 disks
247- slimmer, more lithesome logfile
248- now accepts --findkernel
249- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
250- better handling of non-Linux partitions on DevFS-enabled kernels
251- misc clean-ups
252- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
253- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
254- updated kernel to 2.4.18-mdk6
255- generate mountlist in dev-abetical order ;)
256- fixed minor bug in .spec file
257- better at finding /boot/boot.b if your distro breaks the de facto standard
258- fixed minor bug in MakeMountlist
259- fixed install.sh
260- cleaned up deplist.txt
261- added rudimentary -v / --version flag
262- line 1180 or so --- duplicate mindi.iso entries --- fixed
263- added /bin/[ - a softlink to /bin/sh
264- ListAllPartitions() - sanity fix (KP)
265- fixed .spec bug
266- better feedback
267- added Markus's RAID patch
268- ListAllPartitions() - include /mnt/win* (Hugo)
269
270* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
271- better logging by dependency-calculating code
272- better handling of dependencies, specifically softlinks
273- if called by mondo then use mondo's temp dir as our temp dir too
274- changed gawk to $AWK in a few places, to allow for Debian
275- added host* config files to deplist
276- added tftp, ifconfig to busybox
277- added RPC support to uClibc
278- cleaned up creation of Mondo-Mindi configuration file
279- fixed bug in TryToFindKernelPath which stopped it from handling
280 multiple, same-version kernels gracefully
281- cleaned up deplist.txt
282- receive 'DIFFERENTIAL' variable from Mondo
283- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
284- better devfs support; call fgrep in places instead of grep (Andrew Korn)
285- fixed analyze-my-lvm (Ralph Gruwe)
286- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
287- added x11-tools.tgz option
288- updated /dev/console and /dev/tty0 (Paul Stevens)
289- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
290- catch sigint, sighup, etc.
291- fixed LILO-related message.txt mistake
292- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
293- better devfs support (Andrew Korn)
294
295* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
296- fixed RH7.3 readonly bug
297- improved nfs config file creation
298- search more locations for isolinux.bin
299- added isonuke option
300- faster data disk creation
301- better DevFS support (Hector Alvarez, DuckX)
302- nfs-related fix (Hans Lie)
303- abort if vfat filesystem present but mkfs.vfat missing
304- removed softlink to pico
305- allow Mondo to say no compression will be used
306- added [ to ramdisk
307- tar data disks with -b [block size] of 32k
308- don't autoboot to 'RESTORE' screen - it's scary!
309- let user choose lilo or syslinux as boot loader
310- added syslinux support
311- cleaned up message screens
312
Note: See TracBrowser for help on using the repository browser.