source: MondoRescue/branches/2.05/mindi/mindi.spec@ 189

Last change on this file since 189 was 189, checked in by bcornec, 18 years ago

fix rights on mindi for RPM

  • Property svn:keywords set to Id
File size: 11.8 KB
Line 
1#
2# $Id: mindi.spec 189 2005-12-13 01:45:05Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mindi
11%define version 1.05
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
33Name: %name
34Version: %version
35Release: %mrel
36License: GPL
37Group: System/Kernel and hardware
38Url: http://mondorescue.berlios.de
39Source: %{src}
40BuildRoot: %{_tmppath}/%{name}-%{version}
41Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools, afio, which
42# Not on all systems
43#Conflicts: bonnie++
44
45%description
46Mindi takes your kernel, modules, tools and libraries, and puts them on N
47bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
48and do system maintenance - e.g. format partitions, backup/restore data,
49verify packages, etc.
50
51%prep
52%{__rm} -rf $RPM_BUILD_ROOT
53%setup -n %name-%{version}
54
55%build
56%ifarch ia64
57%{__make} -f Makefile.parted2fdisk clean
58%{__make} -f Makefile.parted2fdisk
59%endif
60
61%install
62export DONT_RELINK=1
63
64%{__rm} -rf $RPM_BUILD_ROOT
65MINDIDIR=$RPM_BUILD_ROOT%{_libdir}/mindi
66export PREFIX=${RPM_BUILD_ROOT}
67export RPMBUILDMINDI="true"
68
69./install.sh
70
71%{__rm} -f $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox-i386.net
72
73%clean
74%{__rm} -rf $RPM_BUILD_ROOT
75
76%post
77if [ -f /usr/local/sbin/mindi ]; then
78 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
79fi
80
81%ifarch ia64
82 %{__mkdir_p} /usr/local/bin
83 if [ "`file /sbin/fdisk |grep 'LF 64-bit LSB executable'`" ] ; then
84 %{__cp} /sbin/fdisk /sbin/fdisk.mondosav
85 %{__mv} /sbin/fdisk /usr/local/bin/fdisk
86 %{__ln_s} -f /usr/sbin/parted2fdisk.pl /sbin/fdisk
87 echo "Warning: you fdisk binary is now under /usr/local/bin"
88 fi
89%endif
90
91%files
92%defattr(644,root,root,755)
93%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
94%doc CHANGES INSTALL COPYING README TODO README.ia64 README.pxe README.busybox
95%attr(755,root,root) %{_sbindir}/*
96%{_libdir}/mindi
97%{_mandir}
98
99%changelog
100* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
101- ia64 is now working
102- use install.sh script
103- use libdir for binary data
104
105* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
106- Merge of patches mentionned on mondo ML + ia64 updates
107- Fix bugs when called alone
108
109* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
110- supports exec-shield
111
112* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
113- better support of SLES 8
114
115* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
116- better kernel-level logging
117- added ACL, xattr binaries to deplist.txt
118- fixed obscure bug which occasionally stopped mindi from correctly finding
119 and documenting all LVM2 LVM-on-RAID volumes
120
121* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
122- added ide_tape and other modules to mindi's config detection
123- unmount errant ramdisk ($mtpt) if fail to create boot floppy
124- better support of ISO dirs at restore-time (Conor Daly)
125
126* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
127- first 1.0x release
128- busybox now static
129- trap Ctrl-Alt-Del; trigger soft reset
130- better SuSE 9.1 support
131- added parted2fdisk.pl (IA64) (Bruno Cornec)
132- add LVM2 support for kernel 2.6 (Takeru Komoriya)
133- better detection of multiple Mindis (Martin Fürstenau)
134- don't complain if just a Mindi boot CD & not a platform for Mondo
135- updated busybox to 1.0.0pre10
136- removed uClibc
137- add memtest support
138- 2.6 kernel support
139- removed Embleer files (Andree Leidenfrost)
140- added kernel-only floppy support, to accommodate really big kernels
141- updated+rebuilt busybox
142- added star support
143- mount /sys at boot-time
144- better 64-bit and 2.6 kernel support
145- better LVM, failsafe kernel support (Jim Richard)
146- use LILO, not raw kernel, on 1.4MB boot floppy
147- record names of unsaved modules, for future reference
148- enlarged ramdisk by 8MB
149
150* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
151- changed some '==' to '=' --- now more RH6-friendly
152- allow absolute pathnames again in deplist
153- disable multifunc cd thing
154- better Gentoo support (Bill)
155- better OnStream support
156- better Slackware support (Laurenz)
157- added partimagehack-static to deplist.txt
158- recompiled Busybox - now 10k smaller; better stack-handling
159- fixed boot screen typo
160- added support for 'auto' fs format
161- better devfs support for Mandrake users
162- better Debian+LVM support (Ralph Grewe)
163- updated analyze-my-lvm to handle floating-point gigabyte -L values
164
165* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
166- altered rootfs's /dev entry to stop cvs from becoming confused
167- tweaked MAX_COMPRESSED_SIZE
168- added multi-function CD support to mindi and sbin/post-init
169- re-mount root as rw just in case
170- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
171- added support for 5th column in mountlist.txt for labels
172- added symlinks.tgz
173- suppress erroneous error msgs re: failsafe kernel
174
175* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
176- added cciss.o to SCSI_MODS
177- if format type is (e.g.) ext3,ext2 then use 1st entry
178- re-enabled fsck*
179- if cciss in use the enable it at boot-time
180- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
181- better ISO support
182- tweaked Mindi to use 10-15% fewer floppies
183- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
184 to be run by Mindi before it bootstraps to aux data disks;
185 e.g. 'echo engage > /proc/scsi/something'
186- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
187 to be run by Mindi after it boots but before it runs mondorestore
188- allow for Debian & other Stiefkinder that use 'none', not 'swap'
189 as the mountpoint of the swap partition
190- removed afio dependency
191- re-worked install.sh and tarball not to use tgz's
192- cleared up the boot msg
193- updated busybox to 0.60.5; updated uClibc to 0.9.19
194- add #!/bin/sh to start of insert-all-my-modules
195- fixed obscure bug in install-additional-tools
196- changed grep -m to grep | head -n1 for Debian users
197- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
198
199* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
200- fixed LVM/RAID bugs (Brian Borgeson)
201- if bad lilo, give more verbose error before quitting
202- added mt and perl to deplist.txt
203- insist on gawk being present
204- insmod ide-cd, cdrom, isofs, just in case
205- boot-time tmpfs ramdisk is now 40m (was 34m)
206- cleaned up logs
207- iso mode now calls Interactive
208- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
209- clean up some calls to grep, esp. partition_mountpt=...
210- corrected some bashisms, to suit Debian ped- er, users
211- made first line refer to bash, not sh, to make sure
212 the Debian people know Mindi requires bash, not hs
213- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
214- disabled code which would have made Mindi use sfdisk instead of fdisk
215 if it looked as if Debian's fdisk would misbehave
216
217* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
218- new devel branch
219- EXTRA_SPACE=16384
220- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
221- patched analyze-my-lvm (Benjamin Mampaey)
222- detect built-in boot.b files in lilo
223- cleaned up spec file a bit, more use of macros (Jesse Keating)
224- return w/err, don't abort, if Matt Nelson's RH8 system is farked
225- better at finding isolinux.bin
226- better at analyzing dependencies when running on broken distributions
227- try harder to boot from CD, even if tape fails
228- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
229- better resolution of relative softlinks, leading to fewer
230 duplicates on data disks and therefore fewer data disks
231- detect Debian+devfs; use sfdisk instead of fdisk in that
232 eventuality, to work around yet another of Debian's warts
233- removed /lib/libuuid.* from rootfs.tgz
234- fixed vi
235- mindi now uses gawk --traditional (making gawk behave in a functionally
236 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
237- removed / from list of dirs accessed when trying to resolve deplist entry
238- spinner bugfix; handle odd LABELs properly (Tom Mortell)
239- fixed LVM/RAID bugs (Brian Borgeson)
240
241* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
242- misc code clean-up
243- save boot device's boot sector
244- detect and beware Compaq diagnostic partitions
245- better handling of devfs V non-devfs kernels and boot devs
246- trimmed busybox 0.60.3 binary on boot disk
247- mindi now resides in /usr/local/bin
248- removed lilo from dependencies
249- more Gentoo-friendly
250
251* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
252- if your kernel's builddate doesn't match any of the kernels in
253 your /boot directory then fudge the issue & find the closest
254 match (*grumble* Debian)
255- scan tape & CD at start, to force inclusion of modules on boot device
256- double EXTRA_SPACE if >7 disks
257- slimmer, more lithesome logfile
258- now accepts --findkernel
259- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
260- better handling of non-Linux partitions on DevFS-enabled kernels
261- misc clean-ups
262- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
263- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
264- updated kernel to 2.4.18-mdk6
265- generate mountlist in dev-abetical order ;)
266- fixed minor bug in .spec file
267- better at finding /boot/boot.b if your distro breaks the de facto standard
268- fixed minor bug in MakeMountlist
269- fixed install.sh
270- cleaned up deplist.txt
271- added rudimentary -v / --version flag
272- line 1180 or so --- duplicate mindi.iso entries --- fixed
273- added /bin/[ - a softlink to /bin/sh
274- ListAllPartitions() - sanity fix (KP)
275- fixed .spec bug
276- better feedback
277- added Markus's RAID patch
278- ListAllPartitions() - include /mnt/win* (Hugo)
279
280* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
281- better logging by dependency-calculating code
282- better handling of dependencies, specifically softlinks
283- if called by mondo then use mondo's temp dir as our temp dir too
284- changed gawk to $AWK in a few places, to allow for Debian
285- added host* config files to deplist
286- added tftp, ifconfig to busybox
287- added RPC support to uClibc
288- cleaned up creation of Mondo-Mindi configuration file
289- fixed bug in TryToFindKernelPath which stopped it from handling
290 multiple, same-version kernels gracefully
291- cleaned up deplist.txt
292- receive 'DIFFERENTIAL' variable from Mondo
293- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
294- better devfs support; call fgrep in places instead of grep (Andrew Korn)
295- fixed analyze-my-lvm (Ralph Gruwe)
296- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
297- added x11-tools.tgz option
298- updated /dev/console and /dev/tty0 (Paul Stevens)
299- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
300- catch sigint, sighup, etc.
301- fixed LILO-related message.txt mistake
302- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
303- better devfs support (Andrew Korn)
304
305* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
306- fixed RH7.3 readonly bug
307- improved nfs config file creation
308- search more locations for isolinux.bin
309- added isonuke option
310- faster data disk creation
311- better DevFS support (Hector Alvarez, DuckX)
312- nfs-related fix (Hans Lie)
313- abort if vfat filesystem present but mkfs.vfat missing
314- removed softlink to pico
315- allow Mondo to say no compression will be used
316- added [ to ramdisk
317- tar data disks with -b [block size] of 32k
318- don't autoboot to 'RESTORE' screen - it's scary!
319- let user choose lilo or syslinux as boot loader
320- added syslinux support
321- cleaned up message screens
322
Note: See TracBrowser for help on using the repository browser.