source: MondoRescue/branches/2.0.7/mindi/distributions/rpm/mindi.spec@ 437

Last change on this file since 437 was 424, checked in by bcornec, 18 years ago

mondo now uses /usr/share for the restore-scripts (/usr/lib should contains binary only) - this also makes rpmlint happier

  • Property svn:keywords set to Id
File size: 1.7 KB
Line 
1#
2# $Id: mindi.spec 424 2006-02-21 21:48:23Z bcornec $
3#
4%define name mindi
5%define version VVV
6%define mrel RRR
7%define src SSS
8%define grp GRP
9%define addreqb bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools
10%define addreq DDD
11%define rel %{mrel}
12
13Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
14Name: %name
15Version: %version
16Release: %rel
17License: GPL
18Group: %{grp}
19Url: http://mondorescue.berlios.de
20Source: %{src}
21BuildRoot: %{_tmppath}/%{name}-%{version}
22Requires: %{addreq}
23# Not on all systems
24#Conflicts: bonnie++
25
26%description
27Mindi takes your kernel, modules, tools and libraries, and puts them on N
28bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
29and do system maintenance - e.g. format partitions, backup/restore data,
30verify packages, etc.
31
32%prep
33%{__rm} -rf $RPM_BUILD_ROOT
34%setup -n %name-%{version}
35
36%build
37%ifarch ia64
38%{__make} -f Makefile.parted2fdisk clean
39%{__make} -f Makefile.parted2fdisk
40%endif
41
42%install
43export DONT_RELINK=1
44
45%{__rm} -rf $RPM_BUILD_ROOT
46export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
47export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
48export RPMBUILDMINDI="true"
49
50./install.sh
51
52%clean
53%{__rm} -rf $RPM_BUILD_ROOT
54
55%post
56if [ -f /usr/local/sbin/mindi ]; then
57 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
58fi
59
60%files
61%defattr(644,root,root,755)
62%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
63%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
64%{_mandir}/man8/*
65%{_libdir}/mindi
66%attr(755,root,root) %{_sbindir}/*
67%attr(755,root,root) %{_libdir}/mindi/aux-tools/sbin/*
68%attr(755,root,root) %{_libdir}/mindi/rootfs/bin/*
69%attr(755,root,root) %{_libdir}/mindi/rootfs/sbin/*
70
71%changelog
Note: See TracBrowser for help on using the repository browser.