Ticket #460: mondo-2.2.9.5_p20110202123354.ebuild

File mondo-2.2.9.5_p20110202123354.ebuild, 1.8 KB (added by Talamona Francesco, 13 years ago)

Horribly hacked ebuild to work around the fact that the extract path is changed

Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7inherit libtool
8
9DESCRIPTION="The premier GPL disaster recovery solution."
10HOMEPAGE="http://www.mondorescue.org"
11SRC_URI="ftp://ftp.mondorescue.org/src/${PN}-${PV}.tar.gz"
12
13LICENSE="GPL-2"
14SLOT="0"
15KEYWORDS="~x86 ~ia64 ~amd64 -*"
16IUSE=""
17
18DEPEND="virtual/libc
19 >=sys-libs/slang-1.4.1
20 >=dev-libs/newt-0.50"
21RDEPEND="app-arch/afio
22 sys-block/buffer
23 sys-devel/binutils
24 >=app-arch/bzip2-0.9
25 virtual/cdrtools
26 >=sys-apps/mindi-2.0.7
27 >=dev-libs/newt-0.50
28 >=sys-libs/slang-1.4.1
29 sys-block/parted
30 >=sys-boot/syslinux-1.52"
31
32S="${WORKDIR}/${PN}-${PV}"
33S="/var/tmp/portage/app-backup/mondo-2.2.9.5_p20110202123354/work/mondo-2.2.9.5/"
34
35src_unpack() {
36 unpack ${A}
37 cd "${S}"
38 chmod 750 configure
39}
40
41src_compile() {
42 elibtoolize
43 econf || die "Configuration failed"
44 emake VERSION=2.2.9.5 || die "Make failed"
45}
46
47src_install() {
48 make install DESTDIR="${D}" || die "make install failed"
49 mkdir -p "${D}/var/cache/mondo"
50 exeinto /usr/share/mondo
51 doexe mondo/autorun
52}
53
54pkg_postinst() {
55 einfo "${P} was successfully installed."
56 einfo "Please read the associated docs for help."
57 einfo "Or visit the website @ ${HOMEPAGE}"
58 echo
59 ewarn "This package is a new version after a long gap."
60 ewarn "Please report bugs to http://bugs.gentoo.org/"
61 ewarn "However, please do an advanced query to search for bugs"
62 ewarn "before reporting. This will keep down on duplicates."
63 echo
64 einfo "Prior to running mondo, ensure /boot is mounted."
65 ewarn "Grub users need to have a symlink like this:"
66 ewarn "ln -s /boot/grub/menu.lst /etc/grub.conf"
67 einfo "Unless you want to have mondo backup your distfiles,"
68 einfo "append \"-E ${DISTDIR}\" to your mondoarchive command."
69 echo
70}